1. #1
    Ensign
    Dabei seit
    Feb 2011
    Beiträge
    197

    Unhappy UEFI-Dual-Boot-Konfiguration ergibt Fehlercode 0xc0000225

    Hallo!

    Meine Wunschkonfiguration wäre Windows XP Professional 32-bit auf meiner 500 GB HDD (MBR-Partitionsstil) und Windows Vista Ultimate 64-bit und Windows Sie7en Ultimate 64-bit auf meiner 1,5 TB HDD (GPT-Partitionsstil) (Hardware-Details entnehmt ihr bitte meinem in der Signatur verlinkten Sysprofile). Die XP- und Vista-Installationen habe ich schon komplett fertig eingerichtet. Heute habe ich das Windows Sie7en-Setup gestartet (natürlich durch Anbooten von der 64-bit-DVD im UEFI-Modus) und von dort aus die zweite GPT-Partition erstellt (die 200 MB-Systempartition und die 128 MB große MSR-Partition waren bereits von der Windows Vista-Installation vorhanden). Nach dem ersten Teil der Installation startete er im UEFI-Modus den Windows-Start-Manager, der mir die Dual-Boot-Auswahl bot und nach drei Sekunden den Windows Sie7en-Start initiierte. Dieser brach allerdings nach einer Sekunde mit dem Fehlercode 0xc0000225 ab. Zunächst startete ich von der DVD die Systemstartreparatur. Dort schrieb er, dass er das Problem nicht automatisch beheben könnte, listete den Fehlercode im Protokoll aber mit auf. Danach löschte ich im Windows-Setup die für Windows Sie7en vorgesehene Partition wieder, erstellte sie neu und ließ ihn erneut darauf installieren. Es blieb beim gleichen Resultat. Die Google-Suche ergab als Lösung das Ausführen von "Bootrec.exe /RebuildBcd" in der Windows-Reparaturumgebung der DVD. Allerdings traute ich mich das bis jetzt noch nicht, weil ich Angst habe, dass er die Reparatur auf der 500 GB HDD statt auf der 1,5 TB HDD durchführt und mir dadurch den NTLDR von Windows XP überschreibt. Ist die Sorge gerechtfertigt oder kann ich den Versuch ruhig wagen? Könnte das überhaupt zum Erfolg führen oder hat jemand von euch eine bessere Idee, bei der ebenfalls die Windows Vista-Installation unversehrt bliebe?

    Windows Vista lässt sich über den Windows-Start-Manager im UEFI-Modus übrigens weiterhin problemlos starten und funktioniert auch einwandfrei (er erkennt dort sogar die zweite GPT-Partition).

    Über schnelle Hilfe wäre ich wirklich sehr dankbar!

    EDIT: Da ich davon ausging, dass der Fehler daraus resultiert, dass die zweite GPT-Partition vor dem Start des Windows PE noch nicht existierte und das Windows-Setup die Booteinträge deshalb falsch schreibt, startete ich den PC erneut von der 64-bit-DVD im UEFI-Modus, löschte die zweite GPT-Partition diesmal nicht sondern führte nur im Windows-Setup eine Schnellformatierung durch und ließ ihn Windows Sie7en zum dritten Mal darauf installieren. Wieder mit dem gleichen Ergebnis! Nun traute ich mich doch in der Windows-Reparaturumgebung "bootrec.exe /fixboot" und "bootrec.exe /RebuildBcd" auszuführen, wobei er bei letzterem 0 verwendbare Windows-Installationen fand, obwohl ich den PC natürlich auch dieses Mal im UEFI-Modus der 64-bit-DVD gestartet habe. Den NTLDR von Windows XP auf meiner 500 GB HDD hat er dabei zwar glücklicherweise nicht überschrieben, die Vorgänge haben den Windows Sie7en-Startfehler aber auch nicht behoben.

    Oben vergaß ich noch zu schreiben, dass unter dem Fehlercode als Info bei mir nicht, wie in den meisten Berichten geschrieben, "The boot selection failed because a required device is inaccessible." sondern "Unerwarteter Fehler" steht. Von daher scheint der Fehler eine andere Ursache als bei den meisten Anderen zu haben, die die Software selbst nicht definieren kann.

    Kann mir denn keiner von euch eine Hilfestellung geben?

    Gruß von Cin-Hoo
    Geändert von Cin-Hoo (25.04.2013 um 14:05 Uhr) Grund: Ergänzung
    Sysprofile meines Haupt-Desktop-PCs

    Sysprofile meines Notebooks: Compaq Presario CQ71-417EG mit Intel Core 2 Duo T6600 CPU @ 2,20 GHz, 4 GB DDR2-RAM, nVIDIA GeForce G 103M GPU, Toshiba MK5056GSY HDD (500 GB), 17,3" Display und vorinstalliertem Windows Sie7en Home Premium 64-bit

  2. Anzeige
    Logge dich ein, um diese Anzeige nicht zu sehen.
  3. #2
    config.sys
    Gast

    AW: UEFI-Dual-Boot-Konfiguration ergibt Fehlercode 0xc0000225

    nur mal so eine Frage, warum nimmst du nicht ein Host OS und virtualisierst die anderen?
    Dann hast du keine Probleme mit dem bootrec.

  4. #3
    Ensign
    Ersteller dieses Themas

    Dabei seit
    Feb 2011
    Beiträge
    197

    AW: UEFI-Dual-Boot-Konfiguration ergibt Fehlercode 0xc0000225

    @config.sys
    Weil ich, wie ich auch schon in meinem Sysprofile schrieb, Windows XP für ältere Programme und Spiele nutzen möchte (gerade für DirectX-basierte Spiele soll die Unterstützung in virtuellen Maschinen ja nicht so super sein). Windows Vista soll später das "Software-Exil" für von mir nicht ganz so geschätzte Programme werden und dort möchte ich auch VirtualBoxen (mit Linux-Distributionen etc.) für Experimente einrichten. Als Hauptbetriebssystem werde ich (wenn es denn erst mal läuft ) Windows Sie7en verwenden, dass ich von jeglichen Virtualisierungstreibern fernhalten wollte.

    Im oberen Beitrag vergaß ich noch zu schreiben, dass ich natürlich als allererstes den Fehlercode auf der Microsoft Supportwebsite nachgeschlagen habe. Der Artikel bezog sich jedoch nur auf Windows Vista Service Pack 1 und Windows Server 2008 Service Pack 1 und beschrieb als Ursache für das Problem eine manuelle Größenveränderung der GPT-Systempartition (Damit ist doch die unsichtbare 200 MB-Partition am Anfang des Datenträgers gemeint, oder?), die ich definitiv nicht durchgeführt habe.

    Weiß denn wirklich niemand einen Rat?

    Gruß von Cin-Hoo
    Sysprofile meines Haupt-Desktop-PCs

    Sysprofile meines Notebooks: Compaq Presario CQ71-417EG mit Intel Core 2 Duo T6600 CPU @ 2,20 GHz, 4 GB DDR2-RAM, nVIDIA GeForce G 103M GPU, Toshiba MK5056GSY HDD (500 GB), 17,3" Display und vorinstalliertem Windows Sie7en Home Premium 64-bit

  5. #4
    Lt. Commander
    Dabei seit
    Nov 2011
    Beiträge
    1.983

    AW: UEFI-Dual-Boot-Konfiguration ergibt Fehlercode 0xc0000225

    Warum willst du Vista und 7 unbedingt auf einem GPT-Datenträger installieren, das ist bei 1,5TB Kapazität nicht nötig.
    Dieser ganze UEFI-, Secure-Boot usw.-Kram verursacht gerade bei Multiboot-Systemen viele Probleme und hat praktisch keine Vorteile, bis auf ein etwas schnelleres Booten und selbst das muss nicht immer der Fall sein.
    Ich würde die 1,5TB-HDD ganz normal als MBR-Datenträger einrichten und dann ganz normal, also ohne UEFI-Installation, die Betriebbsysteme drauf installieren. Man könnte auch erwägen, alle OSes, also auch das XP mit auf die große HDD zu legen.
    Einfach, "altmodisch", aber funktioniert.
    CPU: AMD Phenom II X6 1090T - Cooler: Scythe Mugen 2 Rev. B | Mainboard: Gigabyte GA-870A-UD3
    RAM: A-Data 2x 4GB DDR3 1333 | GPU: Asus Radeon R9 270X | PSU: Seasonic S12 Energy+ 650
    SSD: Crucial RealSSD C300 256GB | HDD: Samsung Spinpoint F3 1TB | Monitor: ViewSonic VX2835wm 28"
    OSes: Windows 7 Ultimate SP 1 (64 Bit) | Windows XP Home Edition SP 3 (32 Bit)

  6. #5
    Ensign
    Ersteller dieses Themas

    Dabei seit
    Feb 2011
    Beiträge
    197

    Unhappy AW: UEFI-Dual-Boot-Konfiguration ergibt Fehlercode 0xc0000225

    @SilenceIsGolden
    Wenn ich in nächster Zeit keine Lösung für das Problem finde, werde ich Windows Vista auch wieder vernichten und normale Installationen nach dem MBR-Partitionsstil durchführen, das war auch mein Gedanke für den absoluten Notfall. Wäre nur ein bisschen ärgerlich, weil ich Vista, bis auf die virtuellen Maschinen, die ich erst bei Bedarf einrichten werde, schon komplett fertig habe. Die zwei Festplatten hatte ich nur gekauft, weil ich Vista und Sie7en eben als UEFI-Installationen haben wollte und Windows XP 32-bit ja nicht auf einem GPT-Datenträger installiert werden kann, ansonsten hätten mir die 1,5 TB natürlich vollkommen ausgereicht. Dass UEFI-Installationen keine großen Vorteile bringen, weiß ich, es war halt einfach als Experiment gedacht, dass leider gehörig in die Hose gegangen ist. Außerdem sollte es dazu dienen, dass ich in meinen virtuellen Maschinen auch EFI aktivieren kann, da ich mal davon ausgehe, dass, genauso wie bei der Aktivierung von PAE/NX in der VirtualBox, dieses Merkmal auch in der Realität gegeben sein muss, sprich, dass sich das Host-OS dazu ebenfalls im UEFI-Modus befinden muss. Oder stimmt das so nicht?

    Zu meinem Problem wäre noch erwähnenswert, dass bevor der Fehlerbildschirm erscheint ganz kurz "Starting Windows" oder "Windows wird gestartet" (ist nur der Bruchteil einer Sekunde, deshalb kann ich es so schnell gar nicht lesen) zu sehen ist.

    Ich hoffe, dass jemand von euch doch noch eine Idee hat.

    Gruß von Cin-Hoo
    Sysprofile meines Haupt-Desktop-PCs

    Sysprofile meines Notebooks: Compaq Presario CQ71-417EG mit Intel Core 2 Duo T6600 CPU @ 2,20 GHz, 4 GB DDR2-RAM, nVIDIA GeForce G 103M GPU, Toshiba MK5056GSY HDD (500 GB), 17,3" Display und vorinstalliertem Windows Sie7en Home Premium 64-bit

  7. #6
    Lt. Commander
    Dabei seit
    Nov 2011
    Beiträge
    1.983

    AW: UEFI-Dual-Boot-Konfiguration ergibt Fehlercode 0xc0000225

    Ich habe die EFI-Option in VirtualBox noch nie aktiviert, glaube allerdings, dass dies nur ein emuliertes EFI ist, welches ermöglicht, den Gast im EFI-Modus in die VM zu installieren. Jedenfalls steht bei den Beschleunigungsoptionen AMD-V usw. da, dass die CPU das unterstützen muss, bei der EFI-Option steht dieser Hinweis aber nicht da, sodass ich davon ausgehe, dass es eben nur ein von VirtualBox emuliertes EFI ist, dass mit dem vorhandenen auf dem Host nichts zu tun hat. Mein Mainboard hat kein EFI und ich kann die EFI-Option in VirtualBox trotzdem aktivieren.
    CPU: AMD Phenom II X6 1090T - Cooler: Scythe Mugen 2 Rev. B | Mainboard: Gigabyte GA-870A-UD3
    RAM: A-Data 2x 4GB DDR3 1333 | GPU: Asus Radeon R9 270X | PSU: Seasonic S12 Energy+ 650
    SSD: Crucial RealSSD C300 256GB | HDD: Samsung Spinpoint F3 1TB | Monitor: ViewSonic VX2835wm 28"
    OSes: Windows 7 Ultimate SP 1 (64 Bit) | Windows XP Home Edition SP 3 (32 Bit)

  8. #7
    Ensign
    Ersteller dieses Themas

    Dabei seit
    Feb 2011
    Beiträge
    197

    Exclamation AW: UEFI-Dual-Boot-Konfiguration ergibt Fehlercode 0xc0000225

    Stimmt, die Beschleunigungstechnologien sind nur verfügbar, wenn sie von der CPU unterstützt werden (bei meinem Notebook z. B. ist die Registerkarte komplett ausgegraut). Allerdings war es bei der Einrichtung einer VirtualBox für die Windows 8 Release Preview auf meinem PC so, dass ich unter der "Hauptprozessor"-Registerkarte "PAE/NX aktieren" auswählen konnte, obwohl die No-Execute Memory Protection-Technologie für meine CPU im UEFI-Setup deaktiviert war (das wusste ich aber nicht). Das Ergebnis war, dass VirtualBox davon ausging, dass die Funktion aktiviert ist, mir der Bootloader der Windows 8-DVD aber den berühmten Fehlercode 0000x5D kredenzte. Von daher könnte ich mir gut vorstellen, dass das bei der EFI-Option genauso ist. Ob bei "PAE/NX aktivieren" allerdings auch, wie bei den Beschleunigungstechnologien, ein expliziter Hinweis steht, weiß ich leider nicht mehr.

    EDIT: Ich habe meine Windows Vista-Partition mal gesichert und ein wenig mit Rohinstallationen weiter experimentiert. Damit ich es nicht jedes Mal extra betonen muss: Alle Vorgänge wurden natürlich über den UEFI-Modus der jeweiligen 64-bit-DVD durchgeführt.
    1. Versuch: Bei der Vista-Installation hatte ich vergessen gleich beide Partitionen anzulegen. Um das als Fehlerquelle auszuschließen, habe ich mit dem "clean"-Befehl von diskpart die Datenträgerpartitionierung meiner zweiten Festplatte komplett zerstört, den PC heruntergefahren, wieder angeschaltet und im Windows Vista-Setup nun sofort die vollständige Partitionierung vorgenommen. Die Vista-Installation verlief wie immer reibungslos, bei Sie7en endete es mit dem gleichen Fehlerbildschirm wie vorher.
    2. Versuch: Meine Vermutung war immer, dass das Windows Sie7en-Setup einfach nicht dazu in der Lage ist, die EFI-Systempartition nachträglich zu modifizieren. Also versuchte ich, ihn zu seinem Glück zu zwingen. Dazu habe ich die EFI-Systempartition, die MSR-Partition und die Windows Sie7en-Partition über das Windows Sie7en-Setup gelöscht, sodass nur noch die Partition mit der Windows Vista-Rohinstallation übrig blieb. Nach einem Neustart war der Windows-Start-Manager natürlich aus dem UEFI-Bootmenü verschwunden. Nun erstellte ich über das Windows Sie7en-Setup wieder die zweite Partition (er schrieb auch brav seine Zusatzpartitionen) und startete die Installation (allerdings warnte er vorher, dass die Partitionsreihenfolge nicht dem Standard eines GPT-Datenträgers entspräche). Das Ganze endete mit dem gleichen Ergebnis.
    3. Versuch: Da ich sowieso ein Backup wiederherstelle, wie wäre es Windows Sie7en zuerst auf die zweite Partition zu installieren, das Vista-Backup auf die erste wiederherzustellen und dieses dann von der Windows Sie7en-Startreparatur in die BCD eintragen zu lassen? Also habe ich die Datenträgerpartitionierung der zweiten Festplatte wieder mit dem "clean"-Befehl von diskpart komplett zerstört, den PC heruntergefahren, wieder angeschaltet, im Windows Sie7en-Setup zwei Partitionen angelegt, beide sofort einer Schnellformatierung unterzogen und für die Installation bewusst die zweite ausgewählt. Auch dies endete mit dem gleichen Ergebnis.
    4. Versuch: Für mein Notebook hatte ich mir mal vom Microsoft-Server das U-Media-Refresh-DVD-Abbild von Windows Sie7en 64-bit heruntergeladen und zu einem Universal-Abbild freigeschaltet. Da mir die Kopie schmutzig geworden war und meine Internetverbindung zu langsam ist, um das Image noch mal zu laden, wollte ich sie für meinen PC eigentlich nicht verwenden, aber um auszuschließen, dass meine Original-DVD für dieses Vorhaben benötigte Patches noch nicht enthält oder gar defekt ist, versuchte ich es mit der Kopie doch. Der von mir gewählte Durchführungsablauf war der gleiche wie im 3. Versuch, leider blieb aber auch das Ergebnis gleich. Von daher lässt sich meine Original-64-bit-DVD als Fehlerquelle ausschließen, die ich für den 5. Versuch auch wieder verwendete.
    5. Versuch: Jetzt kommt der Hammer! Aus purer Neugierde versuchte ich nun das Pferd von hinten aufzuzäumen. Dazu habe ich die Datenträgerpartitionierung der zweiten Festplatte wieder mit dem "clean"-Befehl von diskpart komplett zerstört, den PC heruntergefahren, wieder angeschaltet, im Windows Sie7en-Setup zwei Partitionen angelegt (nur mit dem Unterschied, dass die große Partition für Windows Sie7en diesmal an erster Stelle stand und die 300 GB-Partition für Windows Vista die zweite war), beide sofort einer Schnellformatierung unterzogen und für die Installation die erste ausgewählt. Obwohl sich auf der Festplatte kein anderes Betriebssystem befand und Windows Sie7en nun auf der ersten Partition des GPT-Datenträgers installiert war, erhielt ich nach dem ersten Neustart (nach dem ersten Teil der Installation) den Fehlerbildschirm mit dem Fehlercode 0xc0000225 und der Info "Unerwarteter Fehler"!

    Woran kann das liegen? Mal ganz davon abgesehen, dass ich die drei Betriebssysteme jetzt höchstwahrscheinlich als "normale" Installationen nach dem MBR-Partitionsstil einrichten werde, müsste dieser Fehler wohl mal an Microsoft gemeldet werden? Denn das kann doch nur ein unglückliches Zusammenspiel aus Softwarefehler in Windows Sie7en und UEFI-Fehler meines Mainboards sein, oder? Komischerweise funktioniert die UEFI-Installation von Windows Vista problemlos und auch dessen späterer Betrieb ist einwandfrei möglich.

    Gruß von Cin-Hoo
    Geändert von Cin-Hoo (26.05.2013 um 16:39 Uhr) Grund: neue Erkenntnisse
    Sysprofile meines Haupt-Desktop-PCs

    Sysprofile meines Notebooks: Compaq Presario CQ71-417EG mit Intel Core 2 Duo T6600 CPU @ 2,20 GHz, 4 GB DDR2-RAM, nVIDIA GeForce G 103M GPU, Toshiba MK5056GSY HDD (500 GB), 17,3" Display und vorinstalliertem Windows Sie7en Home Premium 64-bit

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •