1. #1
    Lt. Commander
    Dabei seit
    Okt 2005
    Ort
    Im schönen Harz
    Beiträge
    1.801

    Excel 2003 - Liste auswerten?

    Hallo Leute,

    ich habe ein Problem.
    Ich möchte aus einer Liste bestimmte werde ausgeben lassen.
    Und zwar habe ich eine Liste mit Benutzern die Berechtigungen haben.
    Buchstabe= Benutzer Zahl=Berechtigung
    a 1
    a 2
    a 3
    b 1
    b 2
    c 1
    c 2
    c 3
    c 4

    Die Funktion soll jetzt folgendes ausgeben.
    a 1,2,3
    b 1,2
    c 1,2,3,4

    Mit sVerweis hab ichs hinbekommen, dass er die Werte ausliest.
    aber halt immer nur den ersten und dann die restlichen übergeht.
    Ich bekomme als:
    a 1
    b 1
    c 1

    Kann mir jemand helfen, wie ich Excel dazu bringe die Werte (nur die Zahlen) des ensprechenden Benutzers in ein Zelle zu schreiben?

    Danke für jeden Tipp.
    - Intel Core i5 3570K cooled by Xigmatek Loki - Asus P8Z77-V LX -
    - 8GB Crucial Ballistix Tactical DDR3-1866 - Gainward GF GTX770 Phantom 2GB - Thermaltake Smart M550W 80Plus
    - 1x 128GB SSD Samsung 830 - 1x 1TB HDD Seagate - 1x 1,5TB HDD Seagate -
    Mobil: Nokia Lumia 925 Grau mit WP8.1
    HTPC/Steam-PC - Cooltek G3 - Athlon II X4 640 - GA-MA790FX-DQ6 - 6GB DDR2 - GTX560Ti - Corsair CX430 - Vista 64Bit

  2. Anzeige
    Logge dich ein, um diese Anzeige nicht zu sehen.
  3. #2
    Mr. Snoot
    Gast

    AW: Excel 2003 - Liste auswerten?

    Hü,

    ist nicht ganz so einfach, da SVERWEIS eben nur das erste Vorkommen eines Suchbegriffes findet.

    Dazu könntest du diese Formel benutzen (deine Daten in Spalte A und B):
    =WENN(ZEILEN($1:1)>ZÄHLENWENN(A:A;"a");"";INDEX(B:B;KKLEINSTE(WENN(A$1:A$9="a"; ZEILE($1:$9));ZEILE(A1))))

    ---------

    WICHTIG! Diese Formel muss so eingegeben und IMMER (also auch wenn du mal was daran änderst) mit Strg + Shift + Enter bestätigt werden!

    ---------

    Die Formel (bspw. steht die jetzt in Zelle C1) kannst du dann erstmal ganz normal nach unten ziehen mit dem Ergebnis, dass du erstmal in jeder Zeile, C1 bis C3, einen korrespondierenden Wert zu a bekommst.


    Diese Einzelwerte müsste du dann verketten. Das geht bspw. so:
    =C1&", "&C2&", "&C3
    Ist leider bei vielen Zellen händisch umständlich zu machen. Man kann es zwar für beliebig viele Zellen "automatisieren", wird aber dann mit der Kommasetzung zwischen den Zahlen schwierig: http://www.online-excel.de/excel/singsel.php?f=35#s12

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •