1. #1
    Cadet 1st Year
    Dabei seit
    Jul 2017
    Beiträge
    11

    Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Huhu Leute,

    habt ihr vielleicht eine Idee?

    Ich möchte eine Kreuztabelle erstellen in der ich einfach nur ein x eintrage, wenn Urlaub genommen wird. Das "x" soll aber für jede Person einen individuellen Wert haben.

    Als Beispiel:

    -----------------Müller------Meier------Schmidt
    01.01.2018--------------------------------------
    02.01.2018-------x-----------x------------------
    03.01.2018----------------------------------x---

    Das x von Müller und Schmidt soll immer "1" sein, dass x von Meier "0,5" (Halbtagskraft).
    Sodass die Summenfunktion am Ende der Zeile beim 02.01.2018 1,5 (Müllers x = 1, Meiers x = 0,5 ausgibt).

    Geht das ohne eine "versteckte" Hilfsspalte?
    Mir fällt momentan nur ein, neben jede Spalte eine versteckte zu friemeln mit =WENN(ISTLEER(Zelle davor);"";0,5) (im Fall von Meier) und die summieren zu lassen.

    Danke,
    LG
    Snowbull

  2. Anzeige
    Logge dich ein, um diese Anzeige nicht zu sehen.
  3. #2
    Lt. Commander
    Dabei seit
    Mär 2013
    Beiträge
    1.238

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Du weißt, dass das erfassen von personenbezogenen Daten strengen Regeln unterliegt und das du mit so einer Tabelle in Teufels Küche kommen kannst?

    Ansonsten:
    https://support.office.com/de-de/art...9-7b0318583163

  4. #3
    Lieutenant
    Dabei seit
    Jan 2007
    Ort
    Dresden
    Beiträge
    523

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Zitat Zitat von Snowbull Beitrag anzeigen
    Huhu Leute,

    habt ihr vielleicht eine Idee?

    Ich möchte eine Kreuztabelle erstellen in der ich einfach nur ein x eintrage, wenn Urlaub genommen wird. Das "x" soll aber für jede Person einen individuellen Wert haben.

    Als Beispiel:

    -----------------Müller------Meier------Schmidt
    01.01.2018--------------------------------------
    02.01.2018-------x-----------x------------------
    03.01.2018----------------------------------x---

    Das x von Müller und Schmidt soll immer "1" sein, dass x von Meier "0,5" (Halbtagskraft).
    Sodass die Summenfunktion am Ende der Zeile beim 02.01.2018 1,5 (Müllers x = 1, Meiers x = 0,5 ausgibt).

    Geht das ohne eine "versteckte" Hilfsspalte?
    Mir fällt momentan nur ein, neben jede Spalte eine versteckte zu friemeln mit =WENN(ISTLEER(Zelle davor);"";0,5) (im Fall von Meier) und die summieren zu lassen.

    Danke,
    LG
    Snowbull
    Mach dich eine Zeile mit den Faktoren unter die Namen. Das ist dann auch transparenter, deshalb würde ich die auch nicht ausblenden.

  5. #4
    Ensign
    Dabei seit
    Apr 2011
    Beiträge
    196

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    So wie halwe habe ich mir das auch vorgestellt. Siehe Bild.
    Klicke auf die Grafik für eine größere Ansicht 

Name:	excel.png 
Hits:	55 
Größe:	19,0 KB 
ID:	655190

    Aber was machst du, wenn jemand einen halben Tag Urlaub nimmt?

  6. #5
    Ensign
    Dabei seit
    Sep 2010
    Beiträge
    227

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Du solltest die Daten wie folgt hinterlegen:

    Datum, Person, ArbeitsTyp, Urlaub
    1.1.2018, Müller, 1 , x

    Dann erzeugst du eine Pivottabelle in einem neuen Arbeitsblatt mit den Spalten/Zeilen die du sehen willst.

    Dann benötigst du keinerlei Formeln.
    ASRock 6Extreme (Z97) | i7-4790@4.5GHz | Palit GTX 980 Ti | 24GB RAM@2400 | Samsung 840 256 MB | Samsung 850 Pro 1 TB | Fractal Define R5 | Thermaltake Macho rev. B | be quiet Dark Power P10 550W|Win7 Pro 64-bit | Philips BDM4065@60Hz 3840x2160
    System

  7. #6
    Cadet 1st Year
    Ersteller dieses Themas

    Dabei seit
    Jul 2017
    Beiträge
    11

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Hallo,

    erst einmal an euch alle danke für den Input.

    @Sthyen: Das gibt es zum Glück nicht. Deine Version (verknüpfte Wenn-Formeln) kam mir in den Sinn - jedoch 100 Leute
    @yxcvb: Das stimmt, ist jedoch kein Problem, da alle gesetzlichen und unternehmensinternen Regeln (die teilweise noch einmal strenger sind) eingehalten werden. Dennoch danke für deine Sorge! - und deinen Tipp.
    @Makkaroni: Klingt super, versuche ich!

    Danke allen!
    LG

  8. #7
    Newbie
    Dabei seit
    Dez 2017
    Beiträge
    2

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Hallo,

    ich habe in einer Zelle 6 Zahlen stehen:

    z.B. 123456 und muss dahinter immer -2017-11 einfügen! Wie geht das?
    Die 6 Zahlen am Anfang sind immer anders.
    Also so soll ich am Ende aussehen

    123456-2017-11
    567891-2017-11

    und so weiter

    Könnt Ihr mir weiter helfen?

  9. #8
    Commodore
    Dabei seit
    Mär 2008
    Ort
    Evergreen Terrace 742
    Beiträge
    4.121

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Bei über 100 Leuten wirst du um eine zusätzliche Hilfsspallte nicht rum kommen.
    Finde den Vorschlag von halwe auch am sinnvollsten

    EDIT

    @Marcel Filz

    10 Sekunden googlen, brachten mich zur Formel "=verketten"

  10. #9
    Rear Admiral
    Dabei seit
    Jun 2009
    Ort
    the Wired
    Beiträge
    6.113

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    @Marcel Filz: Entweder mit Barts Formel VERKETTEN oder noch einfacher einem Kaufmansund (&)

    Code:
    =A1&"-2017-11"
    No matter where you are ... everyone is always connected.

    Keinen Bock auf Überwachung? Freie, sichere Alternativen für OS, Browser, VoIP, E-Mail, IM & Co. bei PRISM Break.

  11. #10
    Vice Admiral
    Dabei seit
    Apr 2012
    Ort
    im Herzen Deutschlands
    Beiträge
    6.471

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Mal eine Anregung an die begabteren Bastler als mich.
    Ich setze allerdings eine Hilfszeile (ausgebelndet) voraus die pro Mann angibt ob mit 1 oder 0,5 zu multiplizieren ist. Oder in unserem Falle zu addieren. Ich denke da also an SUMMEWENN() je Damtumszeile. Wenn ein X ann addiere unsere 0,5 oder 1 (aus der versteckten Zeile) auf - und wir haben das Ergebnis, bequem mit Bereichsangaben um noch mehr Leute zu erfassen.

    CN8
    »Regen, Regen, gehe weg · verzieh’ dich an ’nen and’ren Fleck!« (nach Hägar, dem Schrecklichen)

  12. #11
    Captain
    Dabei seit
    Dez 2012
    Beiträge
    3.304

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    =ZÄHLENWENN(ZELLE;"x")*1 bzw. *0.5.

  13. #12
    Newbie
    Dabei seit
    Dez 2017
    Beiträge
    2

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Danke

    Ergänzung vom 08.12.2017 07:42 Uhr: DANKE

    Ergänzung vom 08.12.2017 07:43 Uhr: Ich hatte gegoogelt, aber wirklich nichts gefunden.
    DANKE für Deine Hilfe

  14. #13
    Cadet 1st Year
    Ersteller dieses Themas

    Dabei seit
    Jul 2017
    Beiträge
    11

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    Hallo noch einmal zusammen,
    danke euch alle für euer Input.
    Hatte in der Zwischenzeit noch eine summen+indirekt Funktion im Sinn, mich aber letztlich dazu entschieden diverse Zählenwenn zu verknüpfen (nachdem das einmal geschehen ist, konnte ich sie ja einfach "runterziehen").

    Danke nochmal <3

    Viel Spass und schönes Wochenende, falls wir uns nicht mehr "lesen"
    Snow

  15. #14
    Vice Admiral
    Dabei seit
    Apr 2012
    Ort
    im Herzen Deutschlands
    Beiträge
    6.471

    AW: Excel: beliebige Eingabe in eine Zelle soll immer den selben Wert haben

    SummeWenn() hätte für mich den Vorzug, dass ich den Faktor in der diskreten Zeile verändern kann ohne einzelne Formeln anzufassen.
    Eric March
    »Regen, Regen, gehe weg · verzieh’ dich an ’nen and’ren Fleck!« (nach Hägar, dem Schrecklichen)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Forum-Layout: Feste Breite / Flexible Breite