1. #1
    Lt. Junior Grade
    Dabei seit
    Apr 2016
    Beiträge
    472

    Question RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    Hey,

    ich habe eine RX 580 gekauft die Retour gegangen ist, diese macht allerdings einige Probleme.

    1. Sie wird nicht richtig im Treiber erkannt, das heißt, dass sie am Anfang nur im Wattmann dargestellt wurde und dann nach dem Neustart gar nicht mehr. Die Globalen Einstellungen sind nicht erreichbar.

    2. Ich habe das BIOS mit dem ATI/AMD Tool gespeichert und wollte mir das mal genauer anschauen bzw. überarbeiten. Dieses ließ sich aber nicht öffnen und es kam der Hinweis das es sich hierbei um kein BIOS im Standard Format handelt.

    "This BIOS is non standard size. Flashing this BIOS may corrupt your graphics card."

    Meine Vermutung ist, dass da irgendwer mit der GPU rumgespielt hat und mist gebaut hat. Diese hat er dann wieder zurückgeschickt, oder könnt ihr euch das irgendwie erklären?

    Und dann diese Fehlermeldung bei der steht: Der angefordere Bereich geht über das Arrayende hinaus.




    ______________________________________

    Informationen über das Aufrufen von JIT-Debuggen
    anstelle dieses Dialogfelds finden Sie am Ende dieser Meldung.

    ************** Ausnahmetext **************
    System.ArgumentOutOfRangeException: Der angeforderte Bereich geht über das Arrayende hinaus.
    bei System.Runtime.InteropServices.Marshal.CopyToNative(Object source, Int32 startIndex, IntPtr destination, Int32 length)
    bei PolarisBiosEditor.PolarisBiosEditor.fromBytes[T](Byte[] arr)
    bei PolarisBiosEditor.PolarisBiosEditor.OpenFileDialog_Click(Object sender, EventArgs e)
    bei System.Windows.Forms.Control.OnClick(EventArgs e)
    bei System.Windows.Forms.Button.OnClick(EventArgs e)
    bei System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    bei System.Windows.Forms.Control.WndProc(Message& m)
    bei System.Windows.Forms.ButtonBase.WndProc(Message& m)
    bei System.Windows.Forms.Button.WndProc(Message& m)
    bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Geladene Assemblys **************
    mscorlib
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2600.0 built by: NET471REL1LAST.
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll.
    ----------------------------------------
    PolarisBiosEditor
    Assembly-Version: 0.0.0.0.
    Win32-Version: 0.0.0.0.
    CodeBase: file:///C:/Users/Kirparon/Documents/4.%20RX%20580%20BIOS%20Modding/2.%20Programe/2.%20PolarisBiosEditor/PolarisBiosEditor.exe.
    ----------------------------------------
    System.Windows.Forms
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2556.0 built by: NET471REL1.
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll.
    ----------------------------------------
    System
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2556.0 built by: NET471REL1.
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll.
    ----------------------------------------
    System.Drawing
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2556.0 built by: NET471REL1.
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll.
    ----------------------------------------
    System.Configuration
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2556.0 built by: NET471REL1.
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll.
    ----------------------------------------
    System.Core
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2600.0 built by: NET471REL1LAST.
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll.
    ----------------------------------------
    System.Xml
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2556.0 built by: NET471REL1.
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll.
    ----------------------------------------
    mscorlib.resources
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2556.0 built by: NET471REL1.
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0.0_de_b77a5c561934e089/mscorlib.resources.dll.
    ----------------------------------------
    System.Windows.Forms.resources
    Assembly-Version: 4.0.0.0.
    Win32-Version: 4.7.2556.0 built by: NET471REL1.
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.resources/v4.0_4.0.0.0_de_b77a5c561934e089/System.Windows.Forms.resources.dll.
    ----------------------------------------

    ************** JIT-Debuggen **************
    Um das JIT-Debuggen (Just-In-Time) zu aktivieren, muss in der
    Konfigurationsdatei der Anwendung oder des Computers
    (machine.config) der jitDebugging-Wert im Abschnitt system.windows.forms festgelegt werden.
    Die Anwendung muss mit aktiviertem Debuggen kompiliert werden.

    Zum Beispiel:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    Wenn das JIT-Debuggen aktiviert ist, werden alle nicht behandelten
    Ausnahmen an den JIT-Debugger gesendet, der auf dem
    Computer registriert ist, und nicht in diesem Dialogfeld behandelt.
    Geändert von Thukydides (09.03.2018 um 04:03 Uhr)

  2. Anzeige
    Logge dich ein, um diese Anzeige nicht zu sehen.
  3. #2
    Commander
    Dabei seit
    Jan 2012
    Beiträge
    2.414

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    normalerweise haben rx580 einen bios switch, probiere doch mal das sekundäre bios.

    ansonsten gibts noch die möglichkeit ein originalbios aus einem archiv zu flashen, falls es wirklich das bios ist.

  4. #3
    Lt. Junior Grade
    Ersteller dieses Themas

    Dabei seit
    Apr 2016
    Beiträge
    472

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    In welchem Archiv muss ich schauen?

  5. #4
    Admiral
    Dabei seit
    Nov 2003
    Ort
    bei meinem Sohn
    Beiträge
    9.281

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    Er meinte damit, per Google Suche ein Ort Bios der Karte.
    Hab meine rx470 auch geflasht auf 570, aber dann wurden viele Werte nicht erkannt. Hab es daher gelassen und das org Bios drauf.
    Kannst ja mal das 2. Bios auslesen und dann auf das 1. Flashen. Je nach original wert muss der Takt halt etwas runter oder rauf.
    Dies ist meine Aussage und spiegelt nicht die Meinung der Forums-Redaktion wieder!

    Worker-Bee
    :::: BENCH: 12.455 3DMarks (11)

  6. #5
    Lt. Junior Grade
    Ersteller dieses Themas

    Dabei seit
    Apr 2016
    Beiträge
    472

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    Ich habe die MSI Radeon RX 580 Gaming X 8GB und soweit ich weiß hat die kein Dual-BIOS: https://geizhals.de/msi-radeon-rx-58...-a1609960.html

    Oder täusche ich mich da? Sehe jedenfalls keinen Schalter und in Geizhals wird diesbezüglich auch nichts erwähnt.

    Habe schon versucht etwas drauf zu flashen aber mein Vorgänger hat ziemlichen Mist gebaut. Ich kann zwar eine ROm Speichern, die hat dann 0 kb größe und lässt sich nicht auslesen. Flashen lässt sich aber leider gar nichts. Komme auch nur ganz selten überhaupt in das Tool rein weil es immer einen Rom Fehler meldet.

  7. #6
    Lt. Commander
    Dabei seit
    Nov 2006
    Ort
    München
    Beiträge
    1.865

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    Ehrlich gesagt würde ich da gar nicht so viel rummachen und die Karte umtauschen. Selbst wenn sie aus einer Retoure gekommen ist, muss sie funktionieren, wenn sie dass nicht tut ist es nicht Dein Problem, sondern die des Händlers, der ja eigentlich die Pflicht hat, die Grafikkarte vorher zu testen.
    Zitat Zitat von noboundaries Beitrag anzeigen
    Die Investition in Highend Hardware wegen Zukunftssicherheit ist ebenso sinnvoll wie die Investition in frischen Fisch zum Verzehr 4 Wochen später.

  8. #7
    Lieutenant
    Dabei seit
    Feb 2017
    Beiträge
    751

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    Bios Versionen von allen Anbietern findet man hier : https://www.techpowerup.com/vgabios/

    Angaben zum aktuellen : GPU -Z

    Ich würde die Karte Retouren da wohl am Bios rum gepfuscht wurde .

  9. #8
    Lieutenant
    Dabei seit
    Feb 2005
    Ort
    Ehemalige Ostzone
    Beiträge
    777

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    Da hat vermutlich einer am BIOS gebastelt. Dadurch wird die Karte jetzt vom Treiber nicht mehr erkannt.
    Such mal testweise nach "atikmdag-patcher".
    Da musst du dann den Treiber installieren und VOR dem Neustart den Patcher drüberlaufen lassen. Dann erst Neustart.
    BitFenix Prodigy black | GA-Z87N-WIFI | Xeon 1230v3 | Crucial Ballistix 16 GB CL8 | RX 480
    beQuiet Straight Power E9-400W | Samsung 850 pro
    Kühlung: V - 1x 230mm BitFenix Spectre | H - Antec 920 @ 2x 120mm Enermax TB Silence

  10. #9
    Lt. Commander
    Dabei seit
    Feb 2013
    Beiträge
    1.162

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    Ihr wisst aber schon ,wenn das Bios flashen daneben geht ,keine Garantie besteht .
    Du hast neue einwandfreie Wäre erhalten sollen .
    Ist nicht ,also zurück .

  11. #10
    Lt. Commander
    Dabei seit
    Aug 2007
    Beiträge
    1.404

    AW: RX 580 wird nicht richtig erkannt, BIOS scheint nicht normal zu sein

    Ja das ist das Problem mit Retourenware - meist kommt die nicht ohne Grund Retour.

    Würd ich gar nicht dran rumfummeln sondern einfach zurückschicken.
    X370 meets B350 ...

    PC: AMD Ryzen 1700 @ 3775 MHZ OC, MSI X370 Gaming Plus, 32GB Aegis 2800, PNY GTX 1060 3GB, 240GB SSD, 2TB HDD, Arctic Freezer 33, TT Level 10 GT

    TV-BOX: AMD Ryzen 2200G @ 3900 MHZ OC, ASRock AB350 Pro4, 8GB Trident-Z 3466, GB GTX 1050ti 4GB, 120GB SSD, 1TB HDD, Alpenföhn Sella, RGB Tower

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Forum-Layout: Feste Breite / Flexible Breite