Fehlendes Catalyst Control Center unter Windows 7 - Workaround

RAMSoße

Lt. Commander
Dabei seit
März 2018
Beiträge
1.109
Hallo Zusammen

Leider passt dies noch nicht ganz in die Retroecke. Ich hoffe hier bin ich richtig und ich kann vorallem jemanden viel Zeit ersparen.
Folgendes Szenario hatte ich: Retrorechner mit Win7 64 bit aufgebaut. Eine Selbstgebastelte NTLite Iso mit aktuellen Patches ect. Installiert. Im PC befindet sich seine Radeon HD 5770. AMD Treiber für dieses OS geladen. 1x Catalyst und einmal die Crimsen Beta.
ich entschied mich für die Crimsen Beta, da diese eine bessere Performance haben - siehe hier

Nun ist es so, das die Treiber-Installation zwar startete aber nur die HDMI Audio Treiber sowie der InstallManager installiert wurde. Von den eigentlichen Grafiktreibern und dem ControlCenter keine Spur. Auch bei Catalyst selbes Ergebnis. Viele User raten dazu DDU zu benutzen und mit diesem alle GPU Treiber erstmal restlos zu entfernen. Oder Vorher schon .Net Framework welches der Treiber von AMD benötigt zu installieren. Das bringt oder brachte in meinem Fall alles üüüberhaupt nichts. Ich nehme an der Stelle auch einmal Bezug auf verschiedenen Forenbeiträgen hier und hier.

Unbenannt.png


Woran liegt das? Ich habe probiert eine Win7 64bit Pro Version, die es blank im Netz gibt zu installieren und zu schauen ob es mit dieser geht. Kann ja sein das es einen Konflikt mit bestehenden Treibern/Patches gibt. Und die gibt es anscheinend. Bei der blank Version habe ich, bevor ich sogar den Chipsatztreiber installierte, erstmal den Crimsen Treiber gestartet. Und siehe da: Er will alle alles installieren und erkennt die Grafikkarte. d.h. es liegt wohl an irgendeinem Patch. Bei der Menge an Patches kann ich das nicht heraus finden. Aber ich will meine NTlite Version installieren. Also was tun:

Workaround 1
(kann ausgeführt werden wenn man sein Windows behalten will und oder auf das Control Center verzichten kann)

Einfach unter Geräte-Manager die Grafikkarte suchen. Wird komischer Weise nur als VGA Karte erkannt. Dort die Treiber manuell installieren d.h. die Inf Datei aus dem entpacktem Installationsordner der Catalyst oder Crimsn Treiber suchen.

Workaround 2 - Wenn man seine selbstgebaute Win7 Version behalten will

Blanke Win7 iso aus dem Netz installieren. Bevor man irgendwas installiert, den Grafiktreiber installieren*. Danach seine Wunsch Win7 Version auf USB oder DVD packen. Sollte sie nicht deckungsgleich d.h. Pro vs. Ultimate sein - muss vorher noch Anytime upgrade ausgeführt werden. Danach das Setup der Wunsch Win7 Version im Betriebssystem vom Medium ausführen und durchlaufen lassen. Die Treiber werden dann übernommen. Das System startet mind. 1mal Neu. Auffällig ist, dass danach .Net Framework 4.5 meckert und sagt es sei kaputt. Sanduhr. Womöglich ein Reperaturvorgang und danach noch einen Neustart. Dann kann das Wunsch Win7 mit Treiber endlich benutzt werden.

* die besagten .Net Treiber liefern die GPU Treiber im Normalfall mit und installieren diese im gleichen Durchlauf

Ich denke es liegt an irgendeinem Update oder direkt an .NetFramework. Wenn ich damit nur einem helfen konnte, bin ich schon glücklich :D

PS: Läuft soweit alles super. Einzigster Wermutstropfen - Im dropdown Menü taucht das ControlCenter nicht mehr auf. Nur noch in der Taskleiste. Wie man dies behebt, schreibt @Hilfsheinz eins weiter unten.
 
Zuletzt bearbeitet:
H

Hilfsheinz

Gast
Versuch mal "ccc-next64.msi" im Treiberordner AMD/WU_CCC2/CN/CNEXT mit Doppelklick auszuführen.
Im AMD-Ordner ist auch eine "ccc2_install.exe" versteckt, diese mal ausführen ob dann das Menü im Dropdown erscheint. WHQL-Treiber mal testen und hilft nach diesen Aktionen ein Neustart wenn es nicht sofort funktionieren sollte.
 
  • Gefällt mir
Reaktionen: RAMSoße

RAMSoße

Lt. Commander
Ersteller dieses Themas
Dabei seit
März 2018
Beiträge
1.109
Die ccc-next64.msi findet er die andere hat er gar nicht. Klappt aber. Vielen dank. Nach einem Neustart ist sie wieder im dropsown Menü
 
  • Gefällt mir
Reaktionen: Hilfsheinz
Top