ftp nimmt keine Eingabeumleitung

Blutschlumpf

Fleet Admiral
Dabei seit
März 2001
Beiträge
17.755
Ich hab folgendes Problem:
Ich will per ftp automatisiert Daten auf nen Server schieben.

das will ich machen mit
ftp [IP] < [datei mit befehlen für den ftp]

in der datei mit befehlen für den ftp steht dann folgendes drin:

User
Passwort
ftp-Befehl 1
ftp-Befehl 2
usw.

Wenn ich manuell connecte klappt das, es wird erst nach dem user gefragt, dann nach dem passwort, dann kann ich loslegen.

nur wenn ich die Befehle in ner Datei hab und die Eingabe mit "<" umleite habe ich das Problem, dass das für den User klappt, aber ftp dann trotzdem auf der Konsole nach dem Passwort fragt und dann den Rest abarbeitet.

Hab schon in der manpage geguckt, nen Parameter wo ich username und passwort angeben kann scheints nicht zu geben und ne Verbindung auf ftp://user:passwort@[IP] nimmt ftp nicht an.

Ich machs jetzt über die Datei .netrc, aber das muss prinzipiell doch auch so gehen.
 
Zuletzt bearbeitet: (Smilie abgestellt)

mahdi

Cadet 4th Year
Dabei seit
Jan. 2004
Beiträge
116
versuch das vielleicht mal anders herum:
$ cat [datei mit befehlen] | ftp
dann sollte eigentlich auch so was gehen:
$ cat [datei mit befehlen] | ftp ftp://username : password@server
(natuerlich ohne leerzeichen, aber hier im forum wird das sonst zu einem smilie)
 

Blutschlumpf

Fleet Admiral
Ersteller dieses Themas
Dabei seit
März 2001
Beiträge
17.755
Ne, da fragt der genauso nach. Und das ftp ftp://username : password@server klappt unabhängig von der Umleitung nicht, weil der da keinen gültigen hist drin sieht.
 
Top