Howto: Setup VPN Server?

japetus

Newbie
Dabei seit
Feb. 2004
Beiträge
7
Hallo,

versuche seit einiger Zeit eine VPN Verbindung zu einem Rechner aufzubauen. Der Client ist auch soweit korrekt installiert, nur mit dem Host hapert es noch ein wenig. Ich muss zugeben, dass ich mich in die Materie noch nicht wirklich tief eingelesen habe, aber so wie ich das jetzt gelesen habe, muss überhaupt auf dem Host ersteinmal ein VPN Server eingerichtet werden und da kommt mein Problem ins Spiel, denn, wie obiger Titel schon sagt, ich weiß nicht wirklich wie. Unter www.windows-netzwerke.de wird auf deren tolle CD verwiesen, aber nur mal so zu rumspielen ne CD bestellen?!?
Wenn jemand, eine Anleitung hat wäre ich dankbar für für den Link.

Besten Dank

japetus
 

ALCx

Commander
Dabei seit
Okt. 2001
Beiträge
2.922
Ohne nähere Angaben, was du eigentlich genau machen willst, wird dir hier keiner helfen können.

Zwischen zwei beispielsweise Win2000 PCs , muss auf dem Host eine eingehende Verbindung konfiguriert werden und auf dem Client eine VPN Verbindung. Ist eigentlich recht einfach, da es durch den Assistenten selbstklärend ist.

Bei einem beispielsweise Win2000 Server als Host, muss ein VPN Server erstellt werden über Routing&RAS. Bei Active Directory muss demjenigen User, der sich einwählen will, zusätzlich der Zugriff über VPN gestattet werden.

Ich hab mal kurz gegoogelt und da gibts es zahlreiche Erklärungen zum Thema VPN.
 

japetus

Newbie
Ersteller dieses Themas
Dabei seit
Feb. 2004
Beiträge
7
Ups, ja richtig Betriebssystem sollte angegeben werden mein Fehler.
Ja, das Problem ist das ich für die Konfiguration für NT4.0 und Win2000 schon einiges gefunden habe, es dreht sich aber um zwei XP Pro Rechner, und da habe ich zwar auf dem Host und dem Client jeweils eine VPN Verbindung eingerichtet, auf dem Host die Art der Verbindung auf PPTP-VPN Verbindung umgestellt (wobei ich aber auch schon "automatisch" dringelassen habe) und auf dem Client einfach mal auf automatisch gelassen. Unter Sicherheit habe ich die Datenverschlüsselung auf Optional gestellt und unter den verwendeten Protokollen nur das PAP zugelassen.
Einer der Rechner (Client) geht über ADSL ins Netz und hat somit eine dynamische IP (logisch) und der Server was ja auch ganz praktisch ist, hat durch die Verbindung über Kabelmodem eine statische öffentliche IP, dennoch bekomme ich immer Fehler 800 Server nicht erreichbar, bzw. Sicherheitsparameter nicht korrekt. Nur erreichbar ist der Server mit einer Latenz von 20ms und Sicherheit...ok verratet es niemanden weiter aber beide Rechner stehen mit heruntergelassenen Hosen da und die Sicherheitseinstellungen für die VPN ist mittlerweile auch alles andere als restriktiv.
Achja ich kann mir zwar nicht vorstellen, dass es damit zu tun hat, aber die Gastkonten sind auf beiden Rechner aktiv, auf beiden Rechnern ist ein Profil mit dem gleichen Namen und identischen Passwort eingerichtet.

Vielleicht hat noch jemand ne Idee, ich gebe es zu mein erster Thread war mit Infos ein wenig rar gesegnet.

japetus
 

ALCx

Commander
Dabei seit
Okt. 2001
Beiträge
2.922
Also, bei XP müsste es genauso funktionieren wie bei Win 2000. Ich kann es aber nicht testen, hab kein XP ;) .

Allgemein:
Beim Host eine neue Verbindung erstellen und zwar eine "eingehende Verbindung". Beim Clienten eine normale VPN Verbindung erstellen. Beim Client die IP zum Host eingeben. Bei beiden PPTP als Tunnelprotokoll verwenden(L2TP versteht kein NAT, bzw. das funktioniert nicht wenn NAT im Spiel ist), als Authentifizierungsmethode bei beiden MS-CHAPv2(oder MS-Chap) verwenden. . Einen Benutzer auf dem Host erstellen. Mit diesem Benutzeraccount versuchen vom Client auf den Host zu connecten. Kommt dann immer noch keine Verbindung zustande, könnten Firewall oder möglicher Router dran schuld sein. Zum Beispiel XP integrierte Firewall oder DSL Router. PPTP braucht, soweit ich noch weis(ich gebs zu, hab nachgeschaut ;) ), TCP Port 1723, GRE Protokoll-ID 47 .

Ich hab das hier bei mir im Netzwerk mal probiert, ohne irgendwelche extra Einstellungen, einfache die beiden Verbindungen erstellt und fertig. Funktionierte auf Anhieb.

Versuch das nochmal und berichte mal, vorallem mal genaue Fehlermeldung mit Screenshot.
 
Zuletzt bearbeitet:

japetus

Newbie
Ersteller dieses Themas
Dabei seit
Feb. 2004
Beiträge
7
Danke Dir für die Antwort, aber die VPN Einrichtung unter XP sieht tatsächlich anders als bei 2000 aus. Laut dem Howto der MS Knowledgebase brauch die Verbindung nur auf dem Client eingerichtet werden und dann soll es schon rocken. Auch die Troubleshooting Vorschläge waren leider vergebene Liebesmüh. Firewalls sind bei beiden Rechner ausgeschaltet und die durch die Softwarefirewalls zuvor gesetzten Policies rückgängig gemacht. Router o.ä. sind nicht (mehr) im Einsatz. Die Antwortlatenz des Zielrechners liegt bei sehr guten 22ms und der Datenverlust tritt nur an einem der passierten Routern auf und der liegt auch bei einem mehr als nur vertretbaren Wert von 1%, wobei der Gesamtverlust laut pingpath dann gegen 0, aber ich habe schon mit schlechteren Werten gearbeitet. Ich muss zugeben, dass ich von Sicherheitsprotokollen Null Ahnung habe, aber die Einstellung habe ich sowohl auf default gelassen und laut Anleitung einer Site bereits auf die niedrigste Sicherheitsstufe gestellt.
Hier gerne nochmals die Fehlermeldung als Anhang aber ehrlich gesagt gibt die nicht wirklich was her. :(
Ich habe zwar langsam keine Lust mehr auf das VPN aber für eine zündende Idee wäre ich dankbar

japetus

___________
If you can't beat your computer at chess, try kickboxing.
 

Anhänge

japetus

Newbie
Ersteller dieses Themas
Dabei seit
Feb. 2004
Beiträge
7
Hey Danke, hat tatsächlich jetzt geklappt, werde mich mal in nächster Zeit mit Sicherheitszertifikaten auseinender setzen aber der Zugriff funktioniert optimal.
Ich bin zwar ehrlich gesagt noch nicht ganz sicher woran es im Endeffekt gelegen hat, aber wie war das nochmal "ich weiß zwar nicht was ich hier tue, aber es funktioniert und das ist die Hauptsache". :D

Nochmal besten Dank

japetus

________________
Who's General Failure and why's he reading my disk?
 
Top