mandrake 10.0 / radeon 9600 pro mal wieder

TheUnreal

Newbie
Dabei seit
März 2004
Beiträge
2
hi,

ich hab' hier einen rechner mit nforce2-chipsatz und eine radeon 9600 pro graka. kernel-version = 2.6.3-4mdk, x-version = 4.3.0.1.

laut mdk-installation sollte die radeon mit aktiviertem 3d installiert sein, aber es scheint nur der mesa-treiber geladen zu sein.

also hab ich mir die treiber von ati geladen (fglrx-4.30-3.7.6.i386.rpm) und installiert. laut www.gmpf.de soll man den kernel neu kompilieren und diverse optionen aktivieren, aber lt. make menuconfig waren diese optionen schon voreingestellt, also hab ich den kern mal nicht kompiliert.

gglrxinfo zeigt trotzdem nur den mesa treiber.

wär nett wenn mir jemand helfen könnte

gruss
peter
 

TheUnreal

Newbie
Ersteller dieses Themas
Dabei seit
März 2004
Beiträge
2
ok, danke erstmal für den tip.

also, ich hab mir den nforce-treiber runtergeladen, aber bei make bekomm ich folgendes:


[peter@XP2600 nforce]$ make
make -C nvnet
make[1]: Entering directory `/Daten/nforce/nvnet'
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.6.3-4mdk/build/include nvnet.c
In file included from /lib/modules/2.6.3-4mdk/build/include/linux/irq.h:20,
from /lib/modules/2.6.3-4mdk/build/include/asm/hardirq.h:6,
from /lib/modules/2.6.3-4mdk/build/include/linux/interrupt.h:11,
from nvnet.h:30,
from nvnet.c:21:
/lib/modules/2.6.3-4mdk/build/include/asm/irq.h:16:25: irq_vectors.h: No such file or directory
In file included from /lib/modules/2.6.3-4mdk/build/include/asm/hardirq.h:6,
from /lib/modules/2.6.3-4mdk/build/include/linux/interrupt.h:11,
from nvnet.h:30,
from nvnet.c:21:
/lib/modules/2.6.3-4mdk/build/include/linux/irq.h:70: error: `NR_IRQS' undeclared here (not in a function)
In file included from /lib/modules/2.6.3-4mdk/build/include/linux/irq.h:72,
from /lib/modules/2.6.3-4mdk/build/include/asm/hardirq.h:6,
from /lib/modules/2.6.3-4mdk/build/include/linux/interrupt.h:11,
from nvnet.h:30,
from nvnet.c:21:
/lib/modules/2.6.3-4mdk/build/include/asm/hw_irq.h:28: error: `NR_IRQ_VECTORS' undeclared here (not in a function)
/lib/modules/2.6.3-4mdk/build/include/asm/hw_irq.h:31: error: `NR_IRQS' undeclared here (not in a function)
nvnet.c: In function `nvnet_open':
nvnet.c:735: warning: passing arg 2 of `request_irq' from incompatible pointer type
nvnet.c: In function `nvnet_remove':
nvnet.c:1248: error: structure has no member named `driver_data'
make[1]: *** [nvnet.o] Fehler 1
make[1]: Leaving directory `/Daten/nforce/nvnet'
make: *** [nvnet_make] Fehler 2
[peter@XP2600 nforce]$

damit kann ich leider nix anfangen...

-------------------------------------------------------------------------------------------------------------------------

vergesst das mal schnell *peinlich* was ich hier versucht hab zu installieren, waren die treiber für die nforce-netzwerkkarte... ;-)
 
Zuletzt bearbeitet:
Top