MSI Installer macht Probleme unter Windows XP

godflesh

Cadet 2nd Year
Dabei seit
Jan. 2002
Beiträge
16
Also:
ich benutze WindowsXP +ServicePack

Jedesmal wenn ich ein Programm über den MSI Installer(2.0) (de)installieren will bleibt das Teil hängen. Entweder beim Zusammensuchen der Daten oder irgendwo beim Kopierprozess(0%, 21%, 54%, ....).
Dann dauert es meistens ne halbe Stunde und es ist fertig. Manchmal passiert auch gar nix mehr! :kotz:

ABER: Der Prozess IKernel.exe welcher für den MSI Installer zuständig ist und die Anwendung selber ist nicht abgestürzt (kein "Anwendung reagiert nicht" Scheiss), sie verbraucht weder Systemresourcen noch geht irgendwas weiter.... :mad:

BITTE HELFT MIR!!!
Ich habe schon nach Updates für den MSI Installer gesucht aber bin nicht fündig geworden. Die gibts nur für Win2k, NT4, 9x. :mad:

Bitte schreibt mir nichts von formatieren, Windows neu installieren oder sowas....ich hab nämlich keine Zeit und muss nonst in die Schreibtischkante beißen!

KREATIVE LÖSUNGEN GESUCHT!!!!!!
 

Nico 77

Lt. Commander
Dabei seit
Feb. 2002
Beiträge
1.106
Du wirst es nicht hören wollen, aber du weißt genau was ich dir sagen will. Format C:;)

Nein ganz ehrlich hatte so ein ähnliches Problem mal mit dem Windowsinstaller, nur das sich bei mir nichts mehr installieren ließ was mit dem Windowsinstaller zutun hatte und du wirst nichts finden der ihn repariert! Selbst das ersetzen des orginal Windowsinstaller von der Cd hilft nicht, ist dieser im A.... dann bleibts auch so.

Falls es dir doch gelingen sollte, dann die erste Mail an mich!
 
Zuletzt bearbeitet:

godflesh

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Jan. 2002
Beiträge
16
du hast nicht nur ein ähnliches Problem sondern das selbe. setups ohne das windows installer teil funktionieren nämlich.....
so eine scheisse.
ich will kein format c: :heul:
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.086
Run the following command from a command prompt:
Start > Ausführen: msiexec /unregister > OK > Neustart,
Start > Ausführen: msiexec /regserver > OK
 
Zuletzt bearbeitet:

Nico 77

Lt. Commander
Dabei seit
Feb. 2002
Beiträge
1.106
Oh sollte es doch eine Möglichkeit geben? Das wäre natürlich ne fette Sache!

@godflesh
Sage bitte bescheid ob werkam´s Tipp geholfen hat! (Hoffe nur du hast noch nicht formatiert:D )

@werkam
:daumen:
 

Gizmo0815

Lt. Commander
Dabei seit
Sep. 2002
Beiträge
1.602
@werkam: Ich nehme mal an der die msiexec der Windows Installer ist. Warum geht der wieder wenn man ihm neu registriert? Ist da etwa nur in der Registrierung der Datei was kaputt?

Gruß Gizmo0815.
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.086
Bei den alten Versionen des Windowsinstallers z.B. 98/ME/NT/2K konnte man einfach die Datei neu installieren und den Rechner neu starten, dann wurden die fehlenden Komponenten eben neu installiert. Bei XP geht es nicht, weil er da schon Bestandteil des Systems ist. Wenn nun ein Programm älteren Datums installiert wird, will es den Installer Version 1.2 haben (es kennt den 2.0er noch nicht) und registriert diesen als Standard, das eigentliche Programm wird installiert und nach einem Neustart ist der 2.0er nicht mehr zu gebrauchen. Deshalb muß man diesen 1.2er einfach abmelden (unregister) und den 2.0er wieder aktivieren (registrieren), da er Bestandteil vom System ist, wird er nun auch wieder benutzt. Hoffe ich habe es einigermaßen verständlich erklärt. Bei mir hat der Installer von WinOnCD 5.0 mal sehr große Probs verursacht, so dass ich gezwungen war ein sehr langes Gespräch mit dem Support zu führen, der sich nach mehreren Mails auch mit einem Ergebniss gemeldet hatte, eben dieser Erklärung und einem Link zu M$, wo man sich weitere Infos holen konnte.
http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q260404&ID=KB;EN-US;Q260404
 

Gizmo0815

Lt. Commander
Dabei seit
Sep. 2002
Beiträge
1.602
@werkam: Danke, habs verstanden. Muss man natürlich wissen. Kann ich sicher mal verwenden. :D

Gruß Gizmo0815.
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.086
Wie immer gern geschehen, ich will nur hoffen, dass es den Beiden auch was genutzt hat. Man hört ja nichts mehr :lol:
 

Nico 77

Lt. Commander
Dabei seit
Feb. 2002
Beiträge
1.106
Mir bringts nichts, hatte das Problem vor längerer Zeit und habe dann irgendwann Format C: gemacht weil damals keiner einen rat wußte. Mal schauen was godflesh zu sagen hat.
 

godflesh

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Jan. 2002
Beiträge
16
erstmal danke, dass sich jemand darüber gedanken macht....

Ich habe nochmal probiert etwas zu installieren. Nachdem ich die CD aus dem Laufwerk geholt und eine Stunde was anderes gemacht habe gings dann:
der Installer brachte die Fehlermeldung, dass die CD nicht im Laufwerk ist, also rein damit und siehe da: der ganze Krempel wird auf die Platte kopiert!

ich habe außerdem in cmd "msiexec /unregister" and nach dem neustart "msiexec /register" ausgeführt...
Allerdings bringt mir msiexec bei letzterem Befehl einen Fehler: "unzulässige Funktion"

und das Problem ist nach wie vor da...

Ich muss wohl damit leben, dass es Stunden dauert Programme zu installieren oder zu deinstallieren....bis ich mal Zeit habe Windows neu einzurichten....

PS: meinem Zeitproblem ist auch die späte Antwort zuzuschreiben, sorry......
 
Top