Problem mit Soundserver beim Asus A7N8X und SuSE 9.0

G

Green Mamba

Gast
moin,

ich hab bereits die aktuellen chipsatz-treiber von nvidia installiert. allerdings kann ich immer nur eine audio-quelle wiedergeben. wenn mein instant messenger z.b. einen ton von sich gegeben hat, kann ich mit xmms kein lied mehr abspielen.

erst wieder nachdem ich im yast bei der soundkarte einfach was verändere, und anschließend wieder zurückverändere, dann läuft auch xmms wieder. kann ihn auch schließen, und wieder öffnen.

gibt allerdings in der zwischenzeit irgendein anderes programm einen ton von sich, hab ich wieder das selbe problem. die fehlermeldung hab ich mal unten angehangen.
vielen dank schon mal für die hilfe. :)

schönen gruß
green mamba
 
L

lems

Gast
Das liegt wohl daran, daß Hardware-Mixing nicht unterstützt wird.
Hardware Mixing ist auf dem nForce zwar möglich, allerdings nicht in den nVidia eigenen Treibern implementiert (Funktioniert mit ALSA auch nicht, da nVidia die Spezifikationen ja für sich behält).
Bleibt nur Software mixing mit ESD, ARTS und was es sonst noch so gibt...
 
Zuletzt bearbeitet:
G

Green Mamba

Gast
irgendwie bin ich blind, und find die einstellung nicht. :(
 
Zuletzt bearbeitet:

phyre

Lt. Junior Grade
Dabei seit
Mai 2001
Beiträge
402
man kann das softwaremixing aber auch über alsa selber machen, softwaremixing über arts wollte bei mir irgendwie nicht ganz, und wenn wird die soundkarte dann wieder die ganze zeit von arts besert.. kann aber auch daran liegen, dass ich bei mir alles übern SPDIF lazfen lass und das noch nicht so doll implementiert ist, wie ich finde...

also mal ne beispielhafte /etc/asound.conf von der alsa-project site:

---snip---

pcm.nforce-hw {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "nforce"
}

#0,0 is analog out (i.e. headphone socket on the shuttle), and 0,1 is
#spdif out.

pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "hw:0,1"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

ctl.nforce-hw {
type hw
card 0
}

--snip---

zumindest bei meinem board (ASUS A7N8X-Deluxe 1.04) ist 0,0 analog und 0,2 digital out...
also nach dem beispiel hat man dann 2-3 alsa-"devices" sag ich mal... default und nforce haben softwaremixing und nforce-hw geht dann wieder über die nicht-mixing-fähige schnittstelle direkt...

hofe ich hab nen bissle weitergeholfen... :D

cu phyre
 
G

Green Mamba

Gast
also die datei /etc/asound.conf existiert bei mir nicht. und klänge->soundserver find ich nicht!? ichhab ich mal nen screenshot von kcontrol->sound&multimedia->sound-system->hardware gemacht und angehängt, vielleicht kann mir boron ja sagen was genau ich da machen muss, und ob das überhaupt die richtige stelle ist die gemeint ist? :(

//edit--> nach oben schieb^^
//edit--> nochmal nach oben schieb^^ (noch keine lösung für das problem gefunden!)
//edit--> immernoch keine lösung gefunden... bin ich denn der einzige mit dem problem?
//edit--> tja, so langsam verzweifel ich!
//edit--> kann mir denn niemand helfen :freak:
 

Anhänge

Zuletzt bearbeitet:

Boron

Commander
Dabei seit
Sep. 2001
Beiträge
2.784
Ich habe jetzt mal ein Bild angehängt wo das bei meinem KDE 3.1.3 zu finden ist.
 

Anhänge

G

Green Mamba

Gast
ich meine aber auch genau bei dieser stelle nichts von arts gesehen zu haben. ich werde es sofort wieder ausprobieren, sobald mein dateisystem wieder ansprechbar ist.

//edit
so, anderes problem gelöst, aber leider ist an der stelle bei mir nix von arts zu sehen. :(
 
Zuletzt bearbeitet:

aki

#!/bin/bash
Teammitglied
Dabei seit
Feb. 2002
Beiträge
3.395
bei mir sieht es genauso aus, mamba
sound läuft über oss und es können keine sounds gleichzeitig abgespielt werden.

alsa habe ich auch schon selber kompiliert, in den configs rumgewühlt, per yast2 versucht, will einfach nicht.

ich denke mal, dass es per yast2 nicht funktioniert, weil es noch auf die 2.4er kernel abgestimmt ist und noch versucht module mit der endung .o zu laden anstatt .ko (die richtige karte wird allerdings erkannt)

in dem Info Center steht unter sound
Card config:
--- no soundcards ---
audio devices: not enabled in config
usw.

alsa geht also gar nicht. vielleicht bin ich auch einfach zu doof die richtigen sachen in die configs einzutragen *g* keine ahnung, hauptsache ich hab überhaupt noch irgendwie sound.
 
G

Green Mamba

Gast
soo, mit der 9.1er version gibts nun keine probs mehr!
danke nochmal an alle für die hilfe! :)
 
Top