Problem - Wireless - ping geht -- datentransfer nicht

Hellraiser

Lt. Junior Grade
Dabei seit
Juli 2001
Beiträge
459
Situation: 3 Rechner sind über Wireless Network verbunden durch ad-hoc, peer to peer. Die Übertragungsrate ist auf 2 MBit eingestellt. Die Rechner können sich gegenseitig pingen (0% Packetverlust). Es ist ebenfalls möglich eine FTP-Verbindnug (auf port 21) aufzubauen,
ABER sobald dann eine Datei kopiert werden soll, wird NICHTS übertragen.
Echt diffus die Angelegenheit.

Zur Entfernung: 1. Rechner im 1. Stock, 2. Rechner im Erdgeschoss, 3. Rechner im Kellergeschoss.

Ich dachte es läge irgendwie an Firewalleinstellungen oder an der Verschlüsselung, Firewall mal ausgeschaltet, Verschlüsselung und authentifizierung durch KEY ebenfalls deaktiviert, aber Nein, dies hilft leider nicht weiter.

Ich verwende Netzklasse C (192.168.0.1-192.168.0.3).

In den Wireless-Settings ist "use antenna diversity" aktiviert.

Es war ursprünglich beabsichtigt, den Rechnern 1 und 2 Internetzugang durch Rechner 3 zu geben (Rechner 3, Keller, ist am NTBA angeschlossen (ISDN)).


Weiß jemand woran das oben beschriebene Problem eventuell liegen kann?
 
Zuletzt bearbeitet:

[Moepi]1

Lt. Commander
Dabei seit
Jan. 2002
Beiträge
1.233
Hast Du ggf. auch die windowsinterne FW ausgeschaltet (nur bei XP)?
Ist wirklich merkwürdig, wenn wenn der Ping geht, dann kann eigentlich nur noch ne FW den Datenverkehr stoppen... - es sei denn es hat sich kräftig was auf Softwareseite geschrottet, bei 3 Rechnern aber unwahrscheinlich.
 

Hellraiser

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2001
Beiträge
459
Es ist nur eine Firewall für die isdn verbindung eingerichtet, nicht bei der wireless lan connection.

Hier sind nochmal mehrere Werte, die ich unter den Wireless settings eingestellt habe:

Regulatory domain: Europe (ETSI)
Maximum TX power level: 100 mW
Default Channel: Channel 1 (2412 MHz)
Supported rates: Automatic (max 2 MBit/s)
Fragmentation threshold: 2345 Bytes (2346 means 'OFF')
RTS threshold: 2346 bytes (2347 means 'OFF')

checkbox checked: Ethernet compatibility mode
checkbox checked: use antenna diversity

--------

Ich bin gerad noch auf die Idee gekommen, dass die Fragmentation zu groß sein könnte. Werd ich gleich testen, ob es daran liegen könnte.
 

Hellraiser

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2001
Beiträge
459
es funktioniert nachdem folgendes verändert wurde (was nicht heißt, dass absolt jeder schritt zur lösung beitrug):
ich bin froh, dass es nun funktioniert, denn unter windows ist das kein normalzustand für linux gibts eben leider keine treiber :(

zunächst hab ich die rechner doch noch einmal nebeneinandergestellt.
dann hatte ich noch am tag zuvor die netzwerkkarten ausgebaut gehabt, um sie anderenorts zu testen. Vor Zurückeinbau der Karten habe ich noch die windows registrierunsdatenbank von resteinträgen, bzgl der wireless karten gereinigt. so, also hab ich nun die beiden rechner nah aneniander gestellt, karten installiert, verbindungsparameter wie oben eingerichtet, mit dem UNTERSCHIED, dass kein 'antenna diversity' und keine Verschlüsselung, Netzwerkauthentifizierung durch Key aktiviert war. Auch Die LiteStep Shell hab ich sicherheitshalber mal zurück auf die normale Windows-Shell gesetzt. Ich habe dann noch die WindowsDienste (ich verwende Windows XP, denn mit Win9X geht wireless mit den treibern überhaupt nicht) "Konfirgurationfreie drahtlose Verbindungen", "DNS-Client"; "DHCP-Client" DEAKTIVIERT. der Test mit dem FTP-Transfer erfolgte nun positiv: (jetzt stehen die Recher schon wieder an gewohnter Stelle: Keller + Erdgeschoss):

150 Opening ASCII mode data connection (994484 bytes).
226 Transfer complete.
FTP: 994484 Bytes empfangen in 67,08 Sekunden 14,83KB/s

Die Verbindung ist zwar gering aber für ISDN ausreichend, zumnidest für einen Kanal :)

Auch wenn man es bei Microsoft vermuten könnte: Die Firewall für die ISDN-Verbindung hatte keinen Einfluss auf die Wireless LAN verbindung.

Ich versuche nun erstmal die Verbindung wieder so herzustellen, dass wenigstens Netzwerkauthentifizierung und Verschlüsselung aktiv sind.
 
Zuletzt bearbeitet:

Hellraiser

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2001
Beiträge
459
Das Reaktivieren von 'Antenna diversity' hatte keinen negativen Einfluss auf die Verbindung:

150 Opening ASCII mode data connection (994484 bytes).
226 Transfer complete.
FTP: 994484 Bytes empfangen in 28,75Sekunden 34,59KB/s

= Verbindungsgeschwindigkeit ~verdoppelt.
 

Hellraiser

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2001
Beiträge
459
Data Encryption wieder aktiviert auf 64bit, Verbindung funktioniert.
 
Zuletzt bearbeitet:

Hellraiser

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2001
Beiträge
459
Data Encryption mit 128 bit übertrug ebenfalls noch aktzeptabel genug.

Nach Aktivieren der Network Authentification kam keine Verbindung zustande.
 
Top