Setup ProjectCars - MotionReprojection

Kraeuterbutter

Commander
Dabei seit
Nov. 2007
Beiträge
2.201
Hallo,
vielleicht hat jemand Lust mir die Geheimnisse von MotionReprojection näher zu bringen?

ich spiele mich mit fpsVR und Project Cars (das 1er)
in Kombination mit meiner Samsung Odyssey Plus

soviel ich mitbekommen habe: übernehmem die Mixed Reality-Brillen nicht alle Werte von STeam, sondern nutzten teilweise eigene..

einer dieser Werte ist der Motion-Reprojection-Parameter in der "default.vrsettings" Datei im Ordner:
C:\Program Files (x86)\Steam\steamapps\common\MixedRealityVRDriver\resources\settings

jetzt hab ich vor 1 Woche die Parameter die ich in einem Youtube-Video für PRoject Cars in einem Tutorial gesehen habe übernommen..
konnte es dann aber nicht testen (Zeit)
jetzt hab ich es heute getestet, und läuft nicht mehr so flüssig wie früher

bei Kopfbewegungen "Geisterbilder", also Reprojection

nur: egal was ich mache, ich komme nicht mehr auf die 90Hz
es ist immer bei 45Hz gedeckelt

(Setup: i7 6700K und overclocked GTX 1070)

ich hab in STeam mal die Globale Auflösung auf 200% Gestellt und die Anwendungsauflösung ebenfalls auf 200%

so krieg ich die Framerate auf 25-30Frames runter, GPU-Auflastung auf 98% (ist sogar noch spielbar so, gar ned mal so schlecht und super scharf alles)

dann hab ich global und Anwendungsbezogen auf 80% gesetzt
also weniger als nötig (STeam würde mir 140% empfehlen)

ich komme auf GPU-Frametimes von 7-8ms (und CPU-Frametimes von 16-17ms)
bei der GPU sagt er mir 30% Auslastung

also jetzt müsste sich ja 90 wieder ausgehen (laut anderer Berichte kriegen Leute mit 970 ja auch 90Hz hin)
aber nein, weiterhin gedeckelt mit 45Hz

obwohl ich im Ini-File der Odyssey denke ich richtig eingestellt habe:

{
"driver_Holographic" : {
"renderTargetScale" : 2.0
},
"driver_Holographic_Experimental" : {
// Motion reprojection doubles framerate through motion vector extrapolation
// motionvector = force application to always run at half framerate with motion vector reprojection
// auto = automatically use motion reprojection when the application can not maintain native framerate
// off = ReprojectionMode deaktiviert (laut Internet - Reinhard)
"motionReprojectionMode" : "off",

// Automatic motion reprojection indicator to display the mode currently selected
// green = off because application can render at full framerate
// light blue = on because application is cpu bound
// dark blue = on because application is gpu bound
// red = off because application running at less than half framerate
"motionReprojectionIndicatorEnabled" : true,

// Use temporal history to get higher quality motion vectors. motionReprojectionMode must be set to 'auto' or
// 'motionvector' for this setting to have an affect.
"motionReprojectionTemporalEnabled" : true,
usw.



also wenn jemand einen Tipp für mich hätte, wäre das grandios !

DAnke !

es wird eh schwierig zwischen: gute Qualität mit 45Hz und reprojection
oder 90Hz, superflüssig aber dafür Pixelgrafik zu entscheiden
Ergänzung ()

ProjectCars minimum Settings.JPG
 
Zuletzt bearbeitet:

Kraeuterbutter

Commander
Ersteller dieses Themas
Dabei seit
Nov. 2007
Beiträge
2.201
ich hab KEINE Ahnung wieso...

nach nun einigen 15mal Programm und SteamVR und Mixed-REality_NEustarts,
sowie 2 mal neu REchnerbooten
funktionierts auf einmal...

plötzlich hatte ich 50 FRames... (hohe Grafikeinstellungen, die ich zuvor so gewählt hatte, dass ich über 45Hz bleibe, damit Reprojection arbeiten kann - weil unter 45Hz schaltet es sich aus)

hab die Grafikeinstellungen jetzt so reduziert, dass ich auf 90Hz bei "leeren" Szenen und 70-80Hz bei viel Action komme damit ich nun REprojection deaktivieren kann...
somit hab ich für mich den besten Kompromiss aus Performance + Optik - ohne Reprojecting

was es noch auszutüfteln gilt:
welche Einstellungen (Antialising, MXXA oder wie die alle heißen, 2x 4x, 8x, 16x, usw.)
der besten Kompromiss aus Perfomance und Optik darstellen..

also was mir und meinem Geschmack am besten zusagt bei der von mir gewünschten Framerate
 
Top