System.ini fehlt

F

FutureAttack

Gast
Ich hatte folgendes Problem:

Als ich meinen PC hochgefahren habe ist er beim laden von Windows hängengeblieben, also habe ich Reset gedrückt. Beim Hochfahren kam dann die Fehlermeldung, dass die Systemdatei System.ini fehlt.
Weiß jemand wodurch das kommt, ich habe keine Ahnung warum plötzlich eine Datei verschwindet.

Ansonsten läuft mein System perfekt.

System: A-Open Bigtower mir 350Watt Enermax Netzteil
AMD Athon C 1,33 GHz
MSI K7T266 Pro+R
256 MB DDR Ram
MSI Geforce2 Pro 64 MB DDR RAM
Soundblaster Live
IBM IC35 L0 40
 

Kwuteg

Foren-Wookie
Dabei seit
Mai 2001
Beiträge
4.386
Böser Fehler

Die System.ini gehört zu den Internals von Windows. Wenn die nicht da ist/nicht auffindbar ist, sollte man ganz vorsichtig weitermachen. Windows löscht seine eigenen Systemdateien nicht - so blöd ist nichtmal Windows! :lol:

Bleiben drei Möglichkeiten:
1. Du hast sie selber gelöscht - unbeabsichtigt oder im Zuge eines Wutanfalls -> eher unwahrscheinlich...
2. Deine Festplatte hat Macken und die System.ini liegt in einem fehlerhaften Sektor -> Wenn dem so wäre, solltest du deine wichtigen Daten in Sicherheit bringen! Überhaupt schaust du am besten mal hier rein.
3. Ein Virus hat die System.ini editiert oder gelöscht oder sonstwelchen Unfug gemacht -> Ein Anti-Viren-Check schadet nie!
 

Kwuteg

Foren-Wookie
Dabei seit
Mai 2001
Beiträge
4.386
Klopf, klopf

Hey, KnaTarTz, da hast du was übersehen:

Original erstellt von FutureAttack
... Ansonsten läuft mein System perfekt.
Daraus entnehme ich, daß Windows trotz der Fehlermeldung läuft. Korrigiere mich, wenn es doch anders sein sollte, FutureAttack.
KnaTarTz' Methode ist richtig, aber damit ist nicht die Ursache für das Verschwinden der Systemdatei geklärt. Und wenn man die Ursache nicht kennt, kann es - selbst nach gelungener Rettungsoperation - wieder passieren.
Übrigens dachte ich, FutureAttack würde das Standard-Windows (also eine der 98-Versionen) verwenden, da er sein OS gar nicht erwähnt hat.
Jetzt bist du dran, FutureAttack. ;)
 

hapelo

Commander
Dabei seit
März 2001
Beiträge
2.117
Hi FutureAttack
Mit scanreg /restore sollte sich dies im DOS-Modus bei Win 98/SE/ME beheben lassen. Bei Winnt kann ich leider nur mit den Achseln zucken.
 

Crazy_Bon

Rear Admiral
Dabei seit
März 2001
Beiträge
5.690
Vielleicht wurde die Konfiguration von Windows geändert und Windows wollte ein bisschen die System.ini umschreiben beim hochfahren. Da nun Windows aber abschmierte scheint die Datei auf der Platte verloren gegangen zu sein, wieder herstellen könnte man sie durch eine Restore-Funktion.
Aber normalerweise sollte Windows schlau genug sein und dies selbst tun bzw. wieder eine neue Datei anlegen, hat er das getan?
 
F

FutureAttack

Gast
Als Betriebssystem habe ich Windows Me drauf.

Als er dann nicht mehr hochgefahren ist weil die system.ini gefehlt hat (nach dem Startabsturz) da Windows mir den Vorschlag gemacht, im Dos Modus scanreg/Restore einzutippen, habe ich dann auch gemacht und dadurch konnte ich die System.ini´s der vergangenen Tagen wiederherstellen, und siehe da Windows lief wieder.

Meinen eigentliche Frage war aber warum die plötzlich verschwindet. Ich denke dass es so war wie Crazy_Bon es geschildert hat, das würde passen.
 
Top