USB 2.0-Gerät wird von Windows XP Home nicht erkannt

Georgyboy

Newbie
Dabei seit
Feb. 2004
Beiträge
3
XP hat offensichtlich ein Problem mit USB-Geräten, das auch mit SP1 nicht beseitigt wird. Unter Windows Me lief nämlich mein an den USB 1.1-Port angeschlossener externer Harddisk-Drive (LaCie USB 2.0 Drive) einwandfrei. Seit ich (dummerweise!!!) auf XP umgestiegen bin, läuft nichts mehr. Zunächst liess ich mich von Microsoft auf SP1 vertrösten – gemäss dem Versprechen in Knowledge Base Q314634, dass das Problem mit SP1 behoben werde. Dem ist aber nicht so und weil ich die Schnauze voll hatte von der blöden Meldung "Hochgeschwindigkeits-USB-Gerät an Nicht-Hochgeschwindigkeits-USB" (siehe KB312370) und 40facher Speed nicht gering zu schätzen ist, kaufte ich einen USB 2.0-Adapter (PC-Card). Damit brachte ich aber meinen HDD auch nicht zum laufen.
Alle Treiber werden korrekt geladen, der Geräte-Manager zeigt unter dem USB-Controller und für das Laufwerk keine Konflikte (siehe Anhang). Bei der Neuinstallation des USB-Adapters sowie nach dem Anschliessen des HDD erscheint eine Meldung, dass die Geräte betriebsbereit seien. Nach wenigen Sekunden verschwindet das Laufwerksymbol aber aus dem Systray und das Laufwerk wird im Arbeitsplatz nicht angezeigt.
Ich habe ziemlich alles versucht, was ich im Internet zu diesem Problem finden konnte:
- USB-Controller unzählige Male deinstalliert und mit verschiedenen Treibern neu installiert.
- Installation von VIA USB2 driver package, V258
- Intel Chipsatz 5.1.1.1002 versucht zu installieren. Es wird die Meldung zurückgegeben: «Das aktuelle Betriebssystem unterstützt die Intel-Chipsatz-Komponenten auf Ihrem System. Eine Inf-Aktualisierung ist nicht erforderlich.»
- BIOS-Update vom Hersteller meines Rechners (Compaq)
- Im BIOS die USB-Unterstützung deaktiviert
- Neuer Eintrag in der Registry gemäss KB 314634 (de) vorgenommen, um zu
verhindern, dass ein OHCI-Controller in den Ruhezustand wechselt
- Aktualisierung über Geräte-Manager findet keinen anderen Treiber
- Installation von Microsoft Package 822603 !!!
- Support-Anfrage bei LaCie: "You might want to contact Microsoft."

Fragen:
- Wie kann ich einen neuen Enhanced Host Controller (EHCI) installieren und wie bringe ich die Host-Controller wieder weg, die nach einer manuellen Deinstallation automatisch geladen werden?
- Wie bringe ich XP dazu, einen USB 2.0 Host Controller zu laden?

Falls es nicht an den Treibern, sondern an der Verfügbarkeit von Laufwerksbuchstaben liegen sollte: Der externe HDD erhielte den Laufwerksbuchstaben I:. (Meine Festplatte hat mehrere Partions.) An B: hängt ein Superdisk, der noch unter Windows Me den Laufwerksbuchstaben H: hatte. Tweak UI zeigt die Drives von I: bis Z: als verfügbar an (Kästchen aktiviert).
Frage:
- Kann man einem Laufwerk, das von XP nicht erkannt wird, manuell einen Laufwerksbuchstaben zuordnen? Erkennt dann XP das Gerät?

:confused_alt: Wer hat den entscheidenden Tipp? Damit ich nicht noch weitere Nächte durchwache, ist er mir 100 € wert.

(siehe Anhänge: Device Manager, Details zum USB-Host Controller und Treiberübersicht)
Danke, dass du soweit gelesen hast.
 

Anhänge

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
61.596
http://support.microsoft.com/default.aspx?scid=kb;de;822603
http://support.microsoft.com/default.aspx?scid=kb;de;310575&Product=winxpGer
USB 2.0 müssten die Anschlüsse sein, die per Kabel mit der Karte verbunden sind. Die 1.1 Anschlüsse dürften mit dem Board verbunden sein. Wenn du nicht in den Rechner sehen willst, ein 2.0 Gerät mal an verschiedenen Anschlüssen prüfen, ob eine Meldung kommt.
2.0 Geräte, die schon mal an einem 1.1 Port gehangen haben deinstallieren und neu installieren. Im Bios prüfen ob USB 2.0 aktiviert ist.
Weiterhin kannst du Folgendes probieren:
Systemeigenschaften, Erweitert, Umgebungsvariablen:
unter Systemvariablen "Neu" jeweils anlegen

1) devmgr_show_details Wert: 1
2) devmgr_show_nonpresent_devices Wert: 1

Nicht korrekt arbeitende Geräte vom PC trennen, wenn möglich.
Dann in Gerätemanager, Ansicht: ausgeblendete Geräte anzeigen.
Hier jetzt nicht korrekt funktionierende Geräte deinstallieren. Alle Geräte mit Fehler (gelbes Ausrufungszeichen) deinstallieren. Alle Geräte die grau unterlegt sind (nicht angeschlossen)und mit USB zu tun haben, deinstallieren. Unter USB alle Einträge von unten nach oben deinstallieren. Wichtig! PC zwischendurch nicht neu starten. Jetzt den Explorer starten.
Unter c:\windows\inf alle oem*.* - dateien löschen (del oem*.*)
Im gleichen Verzeichnis noch die Datei 'infcache.1' löschen.

Erst jetzt den PC ausschalten (kein Reboot). Nach Runterfahren min. 15
Sekunden warten und PC neu starten ohne die Problemgeräte. Eventuelle
Installationsmeldungen bestätigen bzw. entsprechend Bildschirmmeldung
verfahren. Rechner rebooten. Jetzt Problemgeräte entsprechend Bedienanleitung
oder Handbuch neu installieren.
 
Zuletzt bearbeitet:

Georgyboy

Newbie
Ersteller dieses Themas
Dabei seit
Feb. 2004
Beiträge
3
Danke für deine Tipps. Leider hat es noch nicht geklappt. Nach weiteren verlorenen Stunden vermute ich einen IRQ-Konflikt. Bloss: wie finde ich das heraus?

Gruss
Georges
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
61.596
IRQ Konflikte kannst Du im Geraetemanager nachvollziehen.
 

Georgyboy

Newbie
Ersteller dieses Themas
Dabei seit
Feb. 2004
Beiträge
3
Hallo
Vielen Dank für die Mithilfe. Mit der Treiber-Installation habe ich mich lange, sehr lange herumgeschlagen. Daran kann es nicht liegen; XP verfügt ja inzwischen über eigene Treiber, mit denen sich ein USB 2.0-Gerät betreiben lassen müsste.

Auch an einem IRQ-Konflikt kann es nicht liegen. Dafür habe ich etwas anderes rausgefunden: Meine externe HDD weist einen Fehler auf. Ich bin darauf gekommen, als ich versuchte, Partition Magic zu starten. Ohne USB-Kabel geht das, mit angeschlossenem USB-Gerät wird ein CRC-Fehler angezeigt. Diese Ursache hat sich bestätigt, als ich das Gerät erneut an einen Windows-Me-Rechner anschloss. Zuerst war es wieder einmal erstaunlich, wie Plug'n-Play funktioniert, wenn es tatsächlich funktioniert. Windows Me, das inzwischen fast vier Jahre auf dem Buckel hat, fand fast mühelos die Treiber - das Gerät wurde erkannt und im Arbeitsplatz angezeigt. Allerdings waren von den ursprünglich fünf eingerichteteten Partitionen nur zwei verfügbar auch Partition Magic zeigte einen Fehler an (jedoch nicht den gleichen wie auf meinem XP-Rechner). Ich werde das defekte Gerät durch ein neues ersetzen; alle Welt kostet das ja mittlerweile nicht mehr.

Dennoch eine letzte Frage: Wie kann man von der Betriebssystemebene aus (also mittels DOS-Befehlen) ein externes Speichergerät ansprechen? (Scandisk, Chkdsk etc. weisen ins Leere) Für das CD-Rom gab es früher MSCEDEX; gibt es für externe Speichermedien etwas ähnliches? So nämlich liesse sich vielleicht mein HDD mit Norton Disc Doctor reparieren.
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
61.596
Stell im Bios ein, das Du Unterstützung für USB unter DOS hast, dann kann es sein, dass Du auch Zugriff auf die Platte bekommst.
 
Top