wie deinstalliert man lilo

rastidsl

Cadet 2nd Year
Dabei seit
Jan. 2004
Beiträge
21
hallo,
hab da mal ne frage und zwar habe ich linux (paralel zu windows) installiert und will es jetzt wieder deinstallieren und dat weis ich wies geht nur wie bekomme ich den bootmanager lilo von meiner ersten festplatte wieder runter ohne windows neu zu instalieren.

wäre echt gut wenn mir da einer helfen könnte
danke im vorraus
 

blümli

Rear Admiral
Dabei seit
Jan. 2003
Beiträge
5.267
Kommt darauf an, welche Windows-Version du hast. Bei Win 98/ME etc. musst du einfach auf der DOS-Ebene "fdisk/mbr" eingeben. Bei Windows 2000 und XP musst du per Windows-CD booten, auf "reparieren" gehen und "Fixmbr [Laufwerk]" eingeben. Bei beiden Methoden wird der Master-Boot-Record wiederhergestellt.
 
Zuletzt bearbeitet:

Tod

Banned
Dabei seit
Feb. 2004
Beiträge
6.202
Hi,
ich habe Linux installiert, aber es lief nicht. Und in WinXP kam ich auch nicht mehr rein. Nun habe ich mittels der Wiederherstellungskonsole fixmbr und fixboot gemacht/eingegeben, aber nun kommt eine Fehlermedlung, daß er das Betriebssystem nivht starten konnte... Hilfe! :(

Danke f. Hilfe
 
F

Fiona

Gast
Hast du fehlerfrei fixboot und fixmbr ausgeführt?
Manchmal gibt es eine Fehlermeldung wegem Bootmanager.
Wenn ja Versuche;

C:\>bootcfg /rebuild

Dann sollte dein WinXP augelistet werden und du kannst es zum starten auswählen.

Viele Grüße

Fiona
 

Tod

Banned
Dabei seit
Feb. 2004
Beiträge
6.202
Hi Fiona,
eine Fehlermeldung während der Maßnhamen hatte ich nicht. Ich werde mal Deinen Befehl ausprobieren...

Also, er hat ein Wininstallation gefunden. Aber dann kamen irgendwelche Sachen, die ich nicht verstanden habe... was muß ich dann machen? Ich hab bei den ganzen Optionen, die er mir angeboten hat, einfach mit Enter durchgeklickt... und dann nach Exit und Reboot kam wieder o.g. Fehlermeldung, er konnte das Sys nicht laden.
 
Zuletzt bearbeitet:

Tod

Banned
Dabei seit
Feb. 2004
Beiträge
6.202
Also:
Das in dem Bsp kapiere ich nicht... das geht weit über meine Fertigkeiten. Ich kann ja auch außer mit der WinXP-CD nix am Rechner machen... sitze am PC meiner Mitbewohnerin.

Nun, nach dem Befehl "bootcfg /rebuild" kommt folgendes:

Insgesamt gefundene Windows-Installationen: 1
[1]: C:\Windows
Installation zur Startliste hinzufügen? (Ja/Nein/Alle):_
Was muß ich danach machen?

Sorry für die Mühe...
 
F

Fiona

Gast
Stimmt! :rolleyes:
Trotzdem es gibt da nicht nur Ptedit32 sondern auch Ptedit als Dosversion.
Erstelle eine Bootdiskette und kopiere ptedit darauf und boote davon deinen PC.
Poste mal wie im Beispiel die ersten 3 fettgeschriebenen Werte.
 

Tod

Banned
Dabei seit
Feb. 2004
Beiträge
6.202
Sorry, aber das geht leider auch nicht... dieser PC, der noch geht, hat kein Diskettenlaufwerk... und eine CD-RW hab ich auch keine mehr...

O nein... ich befürchte, ich komme, ich komme um eine Neuinstallation nicht drumrum... aber ob dann Win wieder normal startet?

Ich verstehe nicht, warum die fix-Befehle nicht funktionieren.
 
F

Fiona

Gast
Versuche es vielleicht nochmal mal mit
C:\>fixbboot C:

Gib dann mal;

C:\>map ein.
Schreibe dir den Pfad von deiner Startpartition für WinXP auf.

Beispiel;

\Device\HardDisk0\Partition1

Sollte ungefähr so aussehen.

Gib dann fixmbr nach den Daten deiner Startpartition ein.
Beispiel
fixmbr \Device\HardDisk0\Partition1

Hoffe das hilft!

Viele Grüße

Fiona
 

Tod

Banned
Dabei seit
Feb. 2004
Beiträge
6.202
Hi Fiona,

hat leider auch nix gebracht... trotzdem Danke! Ich installiere jetzt Windows neu. Hoffentlich geht es dann... sonst muß ich ne neue Platte kaufen.

Eins weiß ich: nie wieder Linux! :(


Edith:

Nur zur Kenntnisnahme ;)
Ich ahbe eben mit einer WinXP-Neuinstallation begonnen und Windows-Setup, hat festgestellt, daß kein Windows mehr auf auf Partition 1 war... soviel dazu. Dann kann es auch nicht starten... schöner Sch***!

Edit 2:
Und jetzt hab einen Fehler beim Lesen des Datenträgers... ich kotz geich! Jetz is die Platte im Arsch oder wie? Verflucht sei Linux! Jetzt kann ich nicht mal mehr WinXP neu installieren... ganz großes Kino... suuuper Urlaub.
 
Zuletzt bearbeitet:
F

Fiona

Gast
Wenn du sowieso neu installieren möchtest, kannst du auch gleich von der CD Setup ausführen. Lege wenn möglich auf einer anderen Partition oder Festplatte ein anderes Verzeichniss an. Beispiel WinXPrepair. Nach dem Kopieren und dem Neustart die CD rausnehmen. Jetzt besteht die Möglichkeit, das du gefragt wirst, ob du Windows starten möchtest oder das Setup, oder welches Windows gestartet werden soll. Ansonsten kannst du immer noch WinXP voll neu installieren. Wenn du die Bootauswahl erhältst, kann man die in Windows in der Boot.ini entfernen.

Viele Grüße

Fiona

Edit; überschnitten!
Ja dann ist es klar :( !

Mache mal chkdsk /r
Auch mal das Diagnosetool downloaden und testen.
Gibt es hier!
Außerdem solltest du die Partition beim Setup löschen, neu erstellen und dann formatieren.
 
Zuletzt bearbeitet:

Boron

Commander
Dabei seit
Sep. 2001
Beiträge
2.784
Und bitte nicht Linux den Schwarzen Peter für eine kaputte Platte (physikalisch kaputt) zuschieben.
Hardware zerstören kann Linux nicht (Windows übrigends auch nicht ;)).
 
E

elmex

Gast
ich denke mal das die Festplatte nicht defekt ist, Windows hat bloß Probleme mit dem Dateiensystem umzugehen!

Versuche doch mal wärend des Windows-Setup die Partiton wo XP installiert werden soll zu löschen und dann darauf XP wieder zu installieren!


Noch was = Linux ist kein Krempel, genau so wenig wie dein Windows :mad:


gruss elmex der Krempelliebhaber
 
E

elmex

Gast
das Problem das du beschrieben hast, hatte ich auch mal, und so wie ich es oben beschrieben habe , konnte ich XP auch wieder installieren, es gibt auch eine andere Möglichkeit, Suse installieren und mit Suse die Festplatte partitionieren und formatieren(fat32).



gruss elmex
 

Tod

Banned
Dabei seit
Feb. 2004
Beiträge
6.202
Nun ja, jetzt isses zu spät... ich habe Linux auf eine eigens im FAT32 formatierte installieren wollen... hat soweit ja auch alles wunderbar geklappt, er hat sich die Partition zusammengepfriemelt, wie er es wollte und das Sys startete... aber höllenlangsam! Dauerte jedesmal locker 4 bis 5 Minuten. Und dann konnt eich eben schon nicht mehr in Windows. Hatte den ganzen Tag Ärger damit, da wirst Du verstehen, daß ich, zumal Linux-Anfänger, da einen Hals kriege wie ein Nashorn.
Ich bewundere es, wenn sich Leute so detailliert damit auskennen, aber für mich ist das noch zu umständlich...

Ich versuche rade die nächste INstallation... habe jetzt die Partition 1 wieder gelöscht, neu erstellt unf formatiere grade mit NTFS. Und dann starte ich den nächsten Installationsversuch...

Edit...
Nun, die letzte Maßnahme hat jetzt wenigstens zum Teilerfolg einer neuen Windows-Installation geführt... hatte grade ein Sys zusammen, das richtig schön lief... Murphy's Law. Jetzt geht die Treiber- und Programm-Orgie wieder los... *seufz*, aber zum Glück scheint außer den Windows-Dateien und einigen Profilen nicht viel verloren gegangen zu sein... bis jetzt, jedenfalls...

Ich danke für die Mühe der Boardies!
 
Zuletzt bearbeitet:
Top