PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Bootmgr auf falscher Festplatte?



ddennis
03.05.2009, 14:30
Hallo, habe ein kleines Problem. Habe eben mal wieder nach langer Zeit meinen PC formatiert und Vista neu installiert. So habe zwei Festplatte im PC. Habe von der Vista DVD gebootet, hab meine eine Festplatte formatiert, und darauf Vista installiert. Alles schön und gut, hab nachdem Vista drauf war alles wie Treiber installiert, und musste dann neustarten. Dann meinte er beim Booten das die " BOOTMGR " fehle. Hab im Bios nachgeguckt, alles stimmt. Meine Seagate Festplatte, wo Vista drauf ist, ist an erster Stelle. Meine kleinere Maxtor an zweiter, wie immer schon. Aber es geht einfach nicht, nur wenn ich meine Maxtor an erster Stelle setzte Bootet Windows. Warum? Auf der Seagate Festplatte ist Vista drauf und auf der Maxtor nix, hab nur meine Dateien als Sicherung draufgeschoben, aber wieso soll da die BOOTMGR drauf sein?

Ich bin nun leicht verwundert, weil habe immer meine Seagate als erste Festplatte genutzt, und nun geht es auf einmal nichtmehr? Ich meine ist ja nicht schlimm, nur finde ich es merkwürdig das auf der Vista Festplatte die BOOTMGR fehlt, und auf meiner zweiten Festplatte , ist sie vorhanden? Zumal da kein Betriebssystem drauf ist :D

Sepp1993
03.05.2009, 14:49
Das Problem hatte ich auch mal. Du musst die beiden Sata Stecker tauschen oder du entfernst den Sata Stecker bei deiner 2. Festplatte und startest dann das System. dann herunter fahren und wieder die 2. Festplattwe anschließen.

ddennis
03.05.2009, 14:53
Was ich vergessen hatte zu sagen, die Seagate ist eine SATA Festplatte und die kleinere Maxtor ist eine IDE.

MountWalker
03.05.2009, 16:34
Alle anderen Festplatten außer der Systemplatte abstecken - vom Rechner komplett trennen. Dann von der Installations-DVD starten und, wenn es erscheint (es erscheint, ich weiß nur nicht wann), statt Installation auf "Reparaturoptionen" klicken, warten bis die Prüfung auf instalierte Windows-Systeme abgeschlossen ist, die Windows-Installation anklicken und "reparieren" klicken. Dann wird er kurz was machen und dann vermutlich behaupten, es hätte nichts zu reparieren gegeben - den Bootmgr hat er aber trotzdem neu geschrieben und diesmal auf die richtige Platte.

Moderne Bootmanager wie Bootmgr und Grub, aber auch altmodische wie Lilo, lassen sich sehr schnell durcheinanderbringen, wenn sich die vom BIOS automatisch markierte und nicht mit der Anzeige im BIOS-Status übereinstimmende Festplattenreihenfolgenummerierung ändert - Bootmgr findet dann Winload.exe nicht mehr, Grub findet seine Stage 2 nicht mehr und Lilo findet den kernel nicht meh, weil sie dann alle an der falschen Stelle suchen. Deswegen nach Möglichkeit bei Betriebssysteminstallationen immer ausschließlich die Betriebssystemfestplatte anschließen. ;)

HisN
03.05.2009, 16:37
Für Windows ist die IDE-Platte immer die erste Platte im System. Und da die Boot-Dateien immer auf der 1. primären Partition auf der 1. Festplatte im System landen ... Dingdong.
Hättest abstecken sollen.

ddennis
03.05.2009, 17:27
So also ich habs nun mal so gemacht wie " MountWalker " meinte. Hab von der Vista DVD gebootet, hatte vorher die IDE Platte abgesteckt, und bin dann im Setup bei reparieren reingegangen. Er hat das Problem auch gleich erkannt und behoben. Nur ist mir nun aufgefallen, als ich beim Windows Ladebildschirm Reset gedrückt habe, und er wieder Hochfuhr. kommt ja dann diese Auswahlmöglichkeiten: " Windows normal starten, letzter funktionierende .... , abgesicherten Modus .... " etc. Das ist nun alles in Englisch. :D

Wieso ist das so?