Excel - Anzahl unterschiedlicher werte abhänig von einem Wert klappt nicht?

Excelmania

Lieutenant
Dabei seit
Apr. 2010
Beiträge
583
Hallo.

ich wollte gerne excel zählen lassen wie viele unterschiedliche bezeichnungen einem festen wert in einer tabelle (in der spalte E steht zum beispiel mehrmals eine 1 und in der spalte b stehen viele verschiedene werte, von denen würde ich nun gerne die anzahl wissen. )zugeordnet sind. leider klappt es jedoch mit der folgenden formel nicht.


{=SUMME((VERGLEICH('Zellen-Ansicht'!E$3:E$202&'Zellen-Ansicht'!B$3:B$202;'Zellen-Ansicht'!$E$3:$E$202&'Zellen-Ansicht'!B$3:B$202;0)=ZEILE(1:203)*('Zellen-Ansicht'!$E$3:$E$202='Auswertung KK'!$A5)*('Zellen-Ansicht'!B$3:B$202<>""))*1)}

hat jemand eine idee?
 

Samsonxxx

Lt. Commander
Dabei seit
Jan. 2006
Beiträge
1.312
hier stand Müll
 

Ironie

Lieutenant
Dabei seit
Dez. 2005
Beiträge
653
lad doch mal dein beispiel-file hoch, oder gib uns einen ausschnitt davon.
Kann es grad nicht ganz nachvollziehen
 

Mogwai

Lt. Junior Grade
Dabei seit
Juni 2008
Beiträge
447
Wenn es nicht zuviele verschiedene Werte sind wäre "zählenwenn" vielleicht eine Option. Müsstest halt für jeden Wert eine Formel in ein Feld schreiben.
 

Ironie

Lieutenant
Dabei seit
Dez. 2005
Beiträge
653
Hab dir hier mal n Screenshot davon gemacht, wie es mit der "Zählenwenn" Funktion aussieht.

In Spalte B stehen deine "Festen werte" hier -> 1,2,3,4
In Spalte C die Anzahl, wieviel unterschiedliche werte den Bezeichnungen zugeordnet sind.
und in Spalte E die unterschiedlichen Bezeichnungen

Formel für Zelle C3 : =ZÄHLENWENN($E$3:$E$12;B3)
-> Sucht aus der Matrix E3:E12 die Werte , vergleicht sie mit B3 und gibt die Anzahl der "Treffer" in C3 aus.

Bitte um kurze rückmeldung, ob es das war, was du gesucht hast ^^
 

Anhänge

Zuletzt bearbeitet:
Top