Excel Funktion

avatas

Cadet 4th Year
Dabei seit
Sep. 2009
Beiträge
83
Hallo zusammen,

ich habe folgendes Problem mit Excel. Erstmal meine Schilderung, ich kaufe immer 180 Briefmarken in meiner Exceltabelle schreibe ich dann immer auf für welchen Brief ich eine Marke benutzt habe. Jetzt wollte ich mir eine Art couter machen der Runterzählt wieviele Marken ich noch habe.
Dazu habe ich dann einfach die Formel: =SUMMENPRODUKT(ISTTEXT(A3:A9999)*1) Da schaut er ja einfach ob in der Zelle etwas drin steht und Zählt hoch. Neben dran habe ich dann einfach: =SUMME(180-G2).

Mein Problem ist jetzt das die erste Formel ja einfach weiter Zählt wenn in Axxx etwas drinsteht und bei der zweiten Formel zieht es weiter ab -1,-2,-3 usw.
Ich bräuchte also eine Art reset. d.h wenn ich bei Null Briefmarken bin wieder 180 Kaufe und der Zähler wieder bei 180 Startet.

Also wenn jemand eine komplett neue und Leichtere Idee hat, immer her damit.
Oder jemand eine Idee hat wie ich meine vorhandene verbessern kann das es Funktioniert.

Danke und gruß
Ava
 

xbrtll

Lt. Junior Grade
Dabei seit
Juni 2009
Beiträge
278
Wenn du einen Ansatz beibehalten möchtest, dann verwende =REST(-G2;180). (Wozu war SUMME überhaupt gut?)
 

xbrtll

Lt. Junior Grade
Dabei seit
Juni 2009
Beiträge
278
Dir fehlt noch das Minus vor dem G2. ;)

Alternativ =180-REST(G2;180), falls dort statt 0 lieber 180 stehen soll.
 

avatas

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Sep. 2009
Beiträge
83
Super, das ist genau das was ich gesucht habe. und ich habe mich mit allen Möglichen Formeln rumgeärgert...
Warum Schwer wenn es auch Einfach geht :)

Also Vielen Danke für die schnelle und super Lösung!
 
Top