Excel gibt Wert 1900 wieder obwohl kein Eintrag vorhanden?

Excelmania

Lieutenant
Dabei seit
Apr. 2010
Beiträge
584
Hallo.

Ich habe folgende Formel mit der Werden untereinander die Jahreszahlen wieder gegebenwie sie in meiner Erfassung auftauchen. Leider gibt excel einmalig auch immer den 1900 zurück obwohl dieser garnicht existent ist. Wieso?

Code:
=WENN(ZEILE(O1)>SUMME(WENN(Erfassung!$A$9:$A$5000<>"";VERGLEICH(JAHR(Erfassung!$A$9:$A$5000);JAHR(Erfassung!$A$9:$A$5000);0)=ZEILE($1:$4991))*1);"";JAHR(MIN(WENN((JAHR(Erfassung!$A$9:$A$5000)>O1)*(Erfassung!$A$9:$A$5000<>"");Erfassung!$A$9:$A$5000))))
 
G

GMG-CC

Gast
Moin,

also, ich verstehe die ganze Formel nicht. Der erste Teil
Code:
WENN(ZEILE(O1)
ist nicht gerade hilfreich, denn das ergibt so oder so 1 als Ergebnis.

Ansonsten: Als Ergebnis dieser Formel wird wahrscheinlich 0 (Null) oder "" herauskommen und wenn das Ergebnisfeld als Datum im Format "JJJJ" formatiert ist bzw. das Ergebnis mit der Funktion JAHR(irgendwas) berechnet wird, dann kommt 1900 heraus.
 

ryan_blackdrago

Captain
Dabei seit
Nov. 2006
Beiträge
3.778
@cpt. Nemo
Ach so : Hier ist es ganz gut erklärt : http://www.iris.uni-stuttgart.de/lehre/eggenberger/gdi/2/Excel/DatumUhrzeit/Datumswerte.htm
Gib mal die Zahl 400 ein. Diese entspricht dem Datum 03.02.1901. Dann wird in a2 auch 1901 angezeigt. 366 = 31.12.1900 ; 367 = 01.01.1901 ; usw.

//EDIT : eine leere Zelle entspricht dem Wert 0 ; 0 gilt als Datum 00.01.1900. Deshalb zeigt es bei leeren Zellen auch 1900 an. Die Formel für die Funktion in A2 müsste wie folgt angepasst werden:
Code:
=WENN(A1="";"";JAHR(A1))
 

Anhänge

Zuletzt bearbeitet: (Geistesblitz)
G

GMG-CC

Gast
@ryan_blackdrago

Zeig mir bitte einmal einen einzigen Kalender, der den 00.01.1900 kennt. Vielleicht ein China-Nachbau, aber in der westlichen Welt gibt es so etwas nicht. Darum verstehe ich genau das Ergebnis nicht.

Denn: Gib mal
Code:
=DATUM(1900;1;32)
ein, und voilà, es wird (der Excel-Logik entsprechend) der 1.2.1900 angezeigt.

Es will mir einfach nicht in den Kopf, dass es den Tag 0 (null) gibt. Es gibt ja auch nicht das Jahr 0! Und darum verstehe ich das nicht.
 

ryan_blackdrago

Captain
Dabei seit
Nov. 2006
Beiträge
3.778
@cpt. Nemo
Gehört wahrscheinlich zu den Dingen : Sieht zwar komisch aus, ist aber so :)

Wahrscheinlich weil man irgendwann mit der Zeitrechnung anfangen mußte, hat man den 01.01.1900 gewählt.
Evtl. den Wert 1 da dies das erste sinnvoll zu verwendende Datum ergibt?!

Da aber 0 auch eine 'Zahl' ist, muß irgendwas auch als Ergebnis rauskommen.
0 ist aber eben kein sinnvoll zu verwendendes Ergebnis.

Wird über Extras > Optionen > Berechnung > 1904-Datumswerte eingetragen, entspricht 0 dem 01.01.1904.

OpenOffice hat den selben Fehler, aber mit anderem Datum.
0 = 30.12.1899 ; 1 = 31.12.1899 ; 2 = 01.01.1900 ; usw.

Mit den Formeln, so tickt Excel nun mal. Nachvollziehbar wird's, wenn man die Formeln Tag, Monat, Jahr mal probiert:
 

Anhänge

Top