[FireTV] Kodi/ES Explorer - kann keine Verbindung zum Server aufbauen

Jokeboy

Rear Admiral
Registriert
Okt. 2007
Beiträge
6.119
Guten Abend ihr Profis :)

Folgendes Problem:
Ich wollte mir gerade eben mit dem FireTV wieder ein paar Filme von meinem PC streamen (was früher Problemlos ging über SMB, mit Kodi) doch ich bekomme keine Verbindung mehr zustande (Connection timed out).

Ich habe vor kurzem Windows refreshen lassen (ganzer Reset) doch ich glaube nicht das es an dem liegen kann. Über Smartphone/PC/Tablet kann ich auf die Freigaben zugreifen nur eben über dem FTV nicht mehr.

Das Teil hab ich letztendlich dann auch zurückgesetzt, geholfen hat es aber auch nicht...

Da ich mittlerweile mit meinem Latein am Ende bin, hoffe ich das ihr eventuell eine Lösung parat habt.

Also was ich bis jetzt gemacht habe:
- FTV reset
- Windows Firewall ein/aus <- aber wie gesagt Freigaben gehen mit anderen Geräten im Netzwerk
- Mittels IIS eine FTP Site erstellt um mit Kodi darauf zuzugreifen, ging auch nicht
- Im router ein static lease für den FTV eingerichtet
- Ping auf FTV funktioniert, sowie ADB sideloading (habe so Kodi installiert)

Danke!
JB
 
Kodi, bis inkl. v17, beherrscht von Haus aus erst einmal nur SMBv1, ein relativ frisch installiertes Windows 10 hat dies deaktiviert (aus gutem Grund). Kommt halt aus dem Linux-Umfeld und da ist NFS die bevorzugte Methode. Davon ab kann man Kodi aber auch beibringen, direkt mit SMBv2 oder SMBv3 zu sprechen. Quelle, ansonsten genauere Config kann ich dir morgen raus suchen bei Bedarf.

FTP: Keine Ahnung, bin froh dass ich mit dem IIS und seinen Anhängen so gut wie nix zu tun habe^^
Du findest aber hier eine Liste von wo Kodi alles Medien "sehen" bzw. abspielen kann, teils auch mit Anleitungen direkt verlinkt.

PS: Auch wenn Aktivierung von SMBv1 auf Windows der vermeintlich einfachere Weg ist: Lass es. SMBv1 gehört nicht grundlos abgeschafft und ausgerottet.
 
Oho, hätte nicht gedacht das jemand noch antwortet :D

Ja habe auch mittlerweile herausbekommen das es an SMB1 lag. Natürlich werde ich das nicht aktivieren (mir ist die Schwachstelle bewusst von dem), mich wundert jedoch das es vor dem Windows reset es trotzdem funktionierte obwohl ich es seitdem die Schwachstelle Publik wurde deaktiviert hatte.

Habe vorhin einfach Kodi Leia 18 alpha installiert das von Haus aus SMB2/3 unterstützt - jetzt geht wieder alles (hoffe nur das die Alpha nicht zu instabil ist :D)

Edit:
Und der IIS ist ziemlich simpel wenn man sich damit beschäft hat - FTP kann man damit auch ganz einfach einrichten.
 
Zuletzt bearbeitet:
Ja, aber FTP hat nur Nachteile heutzutage.. Probleme beim NAT (okay, NAT selbst ist meh), Plaintext bei Auth, Plaintext bei Datenaustausch.
Aber freut mich zu hören, dass die Kodi Devs das Thema inzwischen angehen.
 
Zurück
Oben