IIS7 Weiterleitungen auf andere lokale Server/Webseiten

Erdmännchen

Commander
Dabei seit
Dez. 2008
Beiträge
2.242
Hey!

Ich hab ein Problem für euch:
Ich hab mir das ganze Wochenende die Zähne daran ausgebissen, aber ich komm nicht weiter.

Folgendes Szenario:
Ich hab einen IIS-7 Webserver auf einem Windows Home Server 2011.
Der hat diverse Standard-Webseiten, die man über seinen Port 80 erreicht, den ich im Router-NAT auch auf ihn forwarde, um von außen drauf zu kommen.

Jetzt sind in demselben LAN noch diverse andere Server. Hat mit HomeAutomation zu tun.
Sprich mehrere weitere Rechner, die auch auf Port 80 meist mit nem Apachen Einfache Seiten bereitstellen.

Jetzt sollen diese "unter"-Webserver auch von außen über Port 80 erreichbar sein. Entweder als Subdomains oder als Subfolders.
Beispiel:
Über "www.domain.de" kommt man von außen auf den HomeServer.
Über "sub2.domain.de" soll man jetzt auf Rechner 2 kommen können.
Über "domain.de/sub3" soll man auf Rechner 3 kommen können.

Wie kann ich das auf dem IIS7 einrichten bzw. auf dem HomeServer, da der ja Anfragen vom Router auf die anderen Rechner umleiten muss.

Am Wochenende hab ich mich die ganze Zeit mit "URLRewrite" und "Application Request Routing" rumgeschlagen wie hier beschrieben.
Auch dieses Tutorial hab ich durchexerziert, scheitere aber immer am Punkt 1b, da das Icon nicht da ist.
Leider erfolglos, da ich nach Installation der Module diese nicht im IIS7-Manager zu finden sind. Ich weiß nicht, ob der Windows Home Server nur einen abgespeckten IIS am laufen hat oder was da los ist. Jedenfalls geht es mit ARR und URLRewrite nicht.

Gibt es noch weitere Möglichkeiten oder hat jemand nen Tipp?

EDIT: Ich bin mittlerweile soweit, dass Traffic umgeleitet wird!
Funktioniert via ARR und URLRewrite doch. Vielleicht hats nen Rechner-Neustart gebraucht, damit das Modul endlich in der Console auftaucht.

Allerdings hab ich jetzt folgendes Problem:
Irgendwie scheint das URLRewriting nicht zu funktioniern. Auf RootFoldern funktioniert es, aber nicht auf SubFoldernd:
www.domain.de/sub1 - wird korrekt weitergeleitet auf sub1
www.domain.de/sub1/folder - wird nicht korrekt weitergeleitet auf sub1/folder
 
Zuletzt bearbeitet:

winbug

Newbie
Dabei seit
Apr. 2012
Beiträge
1
Hallo zusammen,

Situation:
2008 Server 10.3.50.63 xx.domain.eu
2003 Small Businnes Server + Exchange 10.3.50.53 xy.domain.eu
eine externe IP (dynamisch)
Portweiterleitung 443 auf 10.3.50.63

bei mir hat das Rewriting hinter einer FritzBox so weit recht gut funktioniert. Ohne sich jetzt all zu viel mit der Materie auseinander gesetzt zu haben. Die oben genannten Links haben viel geholfen ;-) DANKE!

Ich leite die Seiten:
https://xx.domain.eu/exchange und
https://xx.domain.eu/exchweb
weiter auf den Internen 2003 Exchange Server:
https://xy.domain.eu/exchange

es klappt so weit bei ../exchange da man automatisch auf ../exchweb geleitet wird, zwecks Authentifizierung.

ABER:

hierbei meldet der IIS 7 einen 404.8 Fehler (HTTP Error 404.8 – HIDDEN_NAMESPACE
)?
Ab da komme ich nicht wirklich weiter. Der Exchange Server funktioniert ja einwandfrei unter dem Link https://xy.domain.eu/exchange und folgende. Auch wenn ich die Portweiterleitung auf der Fritz direkt auf diese interne IP 10.3.50.53 ändere.
Ergo: es muss an der Konfiguration des Rewritings des IIS 7 liegen (2008 Server), denke ich?

Hat jemand eine Idee.

Ach so, ich muss den Port 443 auf den 2008 Server forwarden, da ich dort VPN mit SSTP nutze.

Liebe Grüße
Winbug

PS. ja, ich kenne die Suchfunktion, bin aber bisher nicht fündig geworden.
 
Top