In Excel alle durch 5 teilbare Zahlen markiern

fireblade_xx

Commodore
Registriert
Okt. 2007
Beiträge
5.016
Hallo zusammen,

habe heute ein Praktikum als FISI gemacht. Er hat mir die Aufgabe gestellt: Ich habe eine Tabelle voller Zahlen und soll die durch 5 teilbaren rot markieren. Ich stehe voll auf dem Schlauch. Ich hoffe ihr könnt mir helfen. Und bitte einfache Lösungen nicht riesen Formeln.

Danke

Gruß
 
naja eine if bedingung und dann halt if(ZAHL/5=INT)
ob das mit INT geht keine ahnung.. aber sollte eig für ganze zahlen stehen^^
sonst musst du den begriff suchen den excel dafür verwendet.
naja ok das mit der farbe wüsste ich jetzt so auch nicht, aber ich denk ma dein prob wird es sowieso ersma sein, die zahlen die durch 5 teilbar sind zu finden
 
Stimmt schon aber ich sollte auch noch wissen wie man sie automatisch einfärben kann. War voll überrascht. Erster Tag, dann erstmal Excel Bücher danach gewälzt hab aber auch nix gefunden. Danke dir schonmal. Werde es gleich mal ausprobieren.
 
zur einfärbung kannst du ja einfach mal ein makro aufzeichnen wie du ne zelle/schrift einfärbst und schaust dir das dann an. dann kannst du sicher filtern welche befehle im makro die färbung vornehmen und dass auf dein programm anwenden...
 
So mal schnell die Funktionen in Excel durchgeschaut... es gibt die Funktion Rest(Zahl;Divisor) damit kann man schonmal prüfen ob die Zahl durch 5 teilen geht, dann kommt nämlich als Ergebnis Null heraus. Das Einfärben erledigt dann eine bedingte Formatierung. (wenn ergebnis null dann kästchen rot)
 
Als Tipp nannte er mir die bedingte Formatierung.
 
Bei deiner Möglichkeit gibt er dann aber 0 aus. Ich brauche aber wieder die Zahl 5.
 
Die 5 steckt ja in der Formel drin als Divisor. Derzeit bereitet mir eher Probleme die zu prüfende Zahl dann rot zu makieren... daran knbber ich auch noch.
 
Zuletzt bearbeitet:
Dividend durch Divisor gleich Quotient.


Probier einfach mal n bischen rum. Da kommst du schon drauf mit den Tipps hier.
Durch Probieren lernt sich´s am besten finde ich.
 
Gehe mal auf Format, dort müsstest du "bedingte Formatierung" auswählen können, nur als kleienr Ansatz.
 
Habs jetzt^^ über Umwege: =RUNDEN($A$1/5;0)*5

Funktion: Er nimmt den Wert teilt diesen durch 5,rundet ihn auf 0 Dezimalen und multipliziert ihn mit 5, dann vergleicht er Ausgang und jetzt, wenn gleich dann markiert er es. Ist umständlich funktioniert aber.

Danke

Gruß
 
Zurück
Oben