Linux hängt wenn nfs laufwerk nicht verfügbar

Mr. Poe

Lt. Commander
Registriert
Juli 2010
Beiträge
1.982
hi,

hab schon länger das problem das wenn ich meinen server/NAS neustarte das dann wärend dieser zeit mein PC so gut wie nicht nutzbar ist.
programme lassen sich nicht schließen, öffnen oder frieren ein, zum teil bis der server wieder erreichbar ist, auch wenn die software keine daten vom server abruft.

ich vermute es liegt am nfs mount.
welche option müsste ich da anpassen damit ich zumindest den desktop und lokale daten/programme normal nutzen kann?

/etc/fstab:
Code:
192.168.100.3:/daten                              /mnt/nfs/delbin/daten   nfs     _netdev,nfsvers=4,minorversion=2,wsize=4096,rsize=4096,bg,softreval,rw     0       0
 
Zuletzt bearbeitet:
Ich hab das gleiche Problem immer mit Thunar. Eine Lösung habe ich bisher leider auch nicht gefunden.
 
Entferne das bg und setze lieber "nofail,x-systemd.automount"

x-systemd.automount sorgt dafür, dass das NFS-Laufwerk nicht schon beim Booten zwingend verbunden werden muss, sondern erst beim ersten Zugriff gemountet wird. nofail verhindert außerdem, dass ein nicht erreichbarer NFS-Server den Bootvorgang zu einem kritischen Fehler macht.
 
  • Gefällt mir
Reaktionen: andy_0
Probiert mal:
Code:
,nofail,x-systemd.automount,x-systemd.mount-timeout=10  0  0
mit einzubinden.
Also dann:
Code:
192.168.100.3:/daten                              /mnt/nfs/delbin/daten   nfs     _netdev,nfsvers=4,minorversion=2,wsize=4096,rsize=4096,bg,softreval,rw,nofail,x-systemd.automount,x-systemd.mount-timeout=10     0       0

nofail = Boot wird nicht abgebrochen/angehalten
x-systemd.automount = Mount wird erst bei Zugriff auf /mnt/nfs/delbin/daten ausgelöst
x-systemd.mount-timeout=10s = Falls der Zugriff den Mount auslöst und der Server nicht antwortet, wird nach 10 s aufgegeben
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: drake23 und andy_0
Die fstab Einstellungen sollten zwar wirklich aktualisiert/erweitert werden, aber das booten ist ja wohl nicht das Problem.

Ich hab das auch, dass sich Dolphin komplett aufhängt und nix mehr mit sich machen lässt, wenn das NAS neu gestartet wird während der PC läuft. Da hilft bei mir nur reboot.
 
Metalveteran schrieb:
Ich hab das auch, dass sich Dolphin komplett aufhängt und nix mehr mit sich machen lässt, wenn das NAS neu gestartet wird während der PC läuft. Da hilft bei mir nur reboot.

Its not a bug, its a feature:
soft / hard
Determines the recovery behavior of the NFS client after an NFS request times out. If neither option is specified (or if the hard option isspecified), NFS requests are retried indefinitely. If the soft option is specified, then the NFS client fails an NFS request after retransretransmissions have been sent, causing the NFS client to return an error to the calling application.


NB: A so-called "soft" timeout can cause silent data corruption in certain cases. As such, use the soft option only when client responsivenessis more important than data integrity. Using NFS over TCP or increasing the value of the retrans option may mitigate some of the risks of using thesoft option.
https://linux.die.net/man/5/nfs

Wenn der NFS-Server wieder da ist geht es ganz normal weiter, selbst nach Wochen.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Metalveteran
Zurück
Oben