nextcloud nicht über dyndns erreichbar

ZuseZ3

Lieutenant
Dabei seit
Jan. 2014
Beiträge
1.016
Hallo erstmal,

ich bastel mir gerade eine eigene cloud zusammen.
Von dem entsprechenden PC aus komme ich über localhost/nextcloud auf die entsprechende Seite.
Über ip/nextcloud komme ich aus einem fremden Netzwerk auch auf die Startseite.
Nicht funktionieren tut dagegen xyz.dyndnss.net/nextcloud. Warum?
Ich erhalte lediglich:

Not Found
The requested URL /nextcloud was not found on this server.


Ohne /nextcloud, nur mit der ip bekomme ich zumindest die Apache infopage.
Ufw hatte ich testweise deaktiviert.
Die FB leitet die Ports 80, 22, 443 weiter an den PC.

Mir ist bekannt, das nc logins von nicht gewhitelisteten IPs nicht erlaubt, aber es zeigt nichtmal die Startseite an.
 
Zuletzt bearbeitet:

blablub1212

Commodore
Dabei seit
Sep. 2009
Beiträge
5.115
Wie sieht denn dein Apache-Vhost für nextcloud aus?

Irgendwie so sollte sie aussehen:

Code:
<VirtualHost *:80>
    ServerName xyz.dyndns.net

    RewriteEngine on
    RewriteCond %{SERVER_NAME} = xyz.dyndns.net
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

<VirtualHost *:443>
    ServerName xyz.dyndns.net
   
    SSLEngine on

    DocumentRoot /var/www/owncloud

    <IfModule mod_headers.c>
      Header always set Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"
    </IfModule>
       
    <Directory />
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        Allow from all
        Satisfy Any
    </Directory>

    <Directory /var/www/owncloud/>
         Options +FollowSymlinks
         AllowOverride All
    </Directory>

    SSLCertificateFile /etc/letsencrypt/live/xyz.dyndns.net/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/xyz.dyndns.net/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf
  </VirtualHost>
(Redirect von Plain auf SSL + letsencrypt)
 
Zuletzt bearbeitet:

ZuseZ3

Lieutenant
Ersteller dieses Themas
Dabei seit
Jan. 2014
Beiträge
1.016
Hi @blablub1212 , erstmal danke für die Antwort.
Ich habe da nichts explizit eingerichtet, da der Server nur für Nextcloud existiert und ich es erstmal einfach zum laufen bekommen wollte. VHosts dienen ja, soweit ich sehe, nur dazu, verschiedene Dienste zu trennen?
Falls ich falsch liege, wo genau finde ich die passende Config datei? Unter /etc/apache2 verliere ich die Übersicht.
 

blablub1212

Commodore
Dabei seit
Sep. 2009
Beiträge
5.115
die findest du unter /etc/apache2/sites-available/ (alle inaktiv und aktiv) und unter /etc/apache2/sites-enabled/ (nur aktive).

Bei dir müsste es eine 000-default.conf oder so ähnlich unter /etc/apache2/sites-enabled/ geben, die ein symlink auf die gleiche Datei unter /etc/apache2/sites-available/ ist.

Du könntest nun mal mit sudo a2dissite 000-default.conf den Standard-Vhost mal ausschalten.

Folgenden Vhost anlegen (sudo nano /etc/apache2/sites-available/test.conf):

Code:
<VirtualHost *:80>
  ServerName xyz.dyndns.net
  DocumentRoot /var/www/nextcloud

  <Directory /nextcloud>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
    Satisfy Any
  </Directory>

  <Directory /var/www/nextcloud/>
    Options +FollowSymlinks
    AllowOverride All
  </Directory>

</VirtualHost>
(xyz.dyndns.net und /var/www/nextcloud mit deinen Werten ersetzen)

Danach kannst du den Vhost mit sudo a2ensite test.conf aktivieren und abschließend nochmal apache2 neuladen mit sudo systemctl restart apache2.

Ich denke danach solltest du auch über Port 80 auf deine Nextcloud über deine Dyndns kommen und kannst den Vhost entsprechend anpassen.
 

ZuseZ3

Lieutenant
Ersteller dieses Themas
Dabei seit
Jan. 2014
Beiträge
1.016
@blablub1212
Hattest recht mit deiner Prognose, habe 000 ersetzt, somit ist test.conf meine zZ einzige aktive config.
Trotz restart und reload komme ich jedoch nicht auf die nextcloud, sondern nur auf die Apache2 Defaultpage.
Ideen woran es liegen kann?

Das directory habe ich beide male auf /var/www/html/nextcloud/ angepasst und den ServerName ebenfalls.

Edit: Jetzt geht ip/nextcloud nicht mehr, ich erhalte folgenden Fehler:
Not Found

The requested URL /nextcloud/index.php was not found on this server.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Edit2:
Nun leitet die ip direkt auf die nc Startseite weiter
 
Zuletzt bearbeitet:

ZuseZ3

Lieutenant
Ersteller dieses Themas
Dabei seit
Jan. 2014
Beiträge
1.016
Und was bewirkt eigentlich die Unterteilung in

<Directory /nextcloud>

und

<Directory /var/www/nextcloud/>

@blablub1212 ?
 
Top