Pulldown Menü, wenn zutrifft dann lösche Inhalt andere Zelle

Arek100

Cadet 4th Year
Dabei seit
Nov. 2011
Beiträge
68
Hallo,

brauche Hilfe, habe ein Pulldown Menü (Zelle B1) mit Ja, Nein Auswahl. Wenn Ja gewählt dann soll der Inhalt in Zelle E1 gelöscht werden.

Habe dieses gefunden aber das funktioniert nicht (keine Wirkung)

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Count = 1 Then
If Target.Address = "$B$1" Then ' Wenn sich dieses Feld ändert...
If Target.Value = "Ja" Then ' ...und diesen Wert annimmt...
Range("E1") = "" ' dann lösche dieses Feld
End If
End If
End If
End Sub

Kann mir jemand helfen?

Danke
 

Caspian DeConwy

Lieutenant
Dabei seit
Aug. 2019
Beiträge
688
Das Pulldown-Menü wurde über Daten \ Datentools \ Datenüberprüfung erstellt, oder ist das ein Steuerelement?

Im ersten Fall: da sollte das Makro funktionieren
Im zweiten Fall: musst du sicherstellen, dass a) das Steuerelement mit der Zelle B1 verknüpft ist und b) in der Zelle B1 tatsächlich auch Ja bzw. Nein steht und nicht nur im Steuerelement.

Am besten eine Beispieldatei hochladen an der man dein Problem nachvollziehen kann.
 

Arek100

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Nov. 2011
Beiträge
68
Hi, Datei kommt und Datei befindet sich erst im aufbau also nicht schimpfen ;)
 

Anhänge

  • Mappe1.zip
    19,2 KB · Aufrufe: 138

Caspian DeConwy

Lieutenant
Dabei seit
Aug. 2019
Beiträge
688
Du musst das Makro direkt in die Tabelle einfügen, nicht in ein separates Modul.
 

Anhänge

  • Bild 002.jpg
    Bild 002.jpg
    60,2 KB · Aufrufe: 147

Arek100

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Nov. 2011
Beiträge
68
Danke :daumen:
Ergänzung ()

Kurze Frage noch:

=WENN(ODER(R5="Ja";S5="Ja";T5="Ja");UND(Tabelle1[@Benachrichtigen]="x");"E-Mail";"Keine E-Mail")

Wie kann ich daraus nur eine Formel machen.
Oder soll Überprüfen ob in einer dieser Zelle Ja steht und zusätzlich unter Tabelle1[@Benachrichtigen ein x vorhanden ist.
 
Zuletzt bearbeitet:

steve1da

Lt. Junior Grade
Dabei seit
Apr. 2018
Beiträge
447
Hola,

Ungetestet:
=wenn(und(oder(R5="Ja";S5="Ja";T5="Ja");zählenwenn(Tabelle1[@Benachrichtigen]"x"));"E-Mail";"Keine E-Mail")
Gruß,
steve1da
 

Arek100

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Nov. 2011
Beiträge
68
musste so umbauen:

=WENN(UND(ODER(R5="Ja";S5="Ja";T5="Ja");(Tabelle1[@Benachrichtigen]="x"));"E-Mail";"Keine E-Mail")

scheint zu Funktionieren.

Danke
 
Top