Pulldown Menü, wenn zutrifft dann lösche Inhalt andere Zelle

Arek100

Cadet 3rd Year
Dabei seit
Nov. 2011
Beiträge
56
Hallo,

brauche Hilfe, habe ein Pulldown Menü (Zelle B1) mit Ja, Nein Auswahl. Wenn Ja gewählt dann soll der Inhalt in Zelle E1 gelöscht werden.

Habe dieses gefunden aber das funktioniert nicht (keine Wirkung)

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Count = 1 Then
If Target.Address = "$B$1" Then ' Wenn sich dieses Feld ändert...
If Target.Value = "Ja" Then ' ...und diesen Wert annimmt...
Range("E1") = "" ' dann lösche dieses Feld
End If
End If
End If
End Sub

Kann mir jemand helfen?

Danke
 
Dabei seit
Aug. 2019
Beiträge
200
Das Pulldown-Menü wurde über Daten \ Datentools \ Datenüberprüfung erstellt, oder ist das ein Steuerelement?

Im ersten Fall: da sollte das Makro funktionieren
Im zweiten Fall: musst du sicherstellen, dass a) das Steuerelement mit der Zelle B1 verknüpft ist und b) in der Zelle B1 tatsächlich auch Ja bzw. Nein steht und nicht nur im Steuerelement.

Am besten eine Beispieldatei hochladen an der man dein Problem nachvollziehen kann.
 

Arek100

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Nov. 2011
Beiträge
56
Hi, Datei kommt und Datei befindet sich erst im aufbau also nicht schimpfen ;)
 

Anhänge

Arek100

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Nov. 2011
Beiträge
56
Danke :daumen:
Ergänzung ()

Kurze Frage noch:

=WENN(ODER(R5="Ja";S5="Ja";T5="Ja");UND(Tabelle1[@Benachrichtigen]="x");"E-Mail";"Keine E-Mail")

Wie kann ich daraus nur eine Formel machen.
Oder soll Überprüfen ob in einer dieser Zelle Ja steht und zusätzlich unter Tabelle1[@Benachrichtigen ein x vorhanden ist.
 
Zuletzt bearbeitet:

steve1da

Ensign
Dabei seit
Apr. 2018
Beiträge
220
Hola,

Ungetestet:
=wenn(und(oder(R5="Ja";S5="Ja";T5="Ja");zählenwenn(Tabelle1[@Benachrichtigen]"x"));"E-Mail";"Keine E-Mail")
Gruß,
steve1da
 

Arek100

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Nov. 2011
Beiträge
56
musste so umbauen:

=WENN(UND(ODER(R5="Ja";S5="Ja";T5="Ja");(Tabelle1[@Benachrichtigen]="x"));"E-Mail";"Keine E-Mail")

scheint zu Funktionieren.

Danke
 
Top