Raspberrypi 2 extrem langsame Interernetverbindung mit dem neuen Router

Lorbin

Cadet 3rd Year
Dabei seit
Apr. 2008
Beiträge
49
Hi,

Seit ein neuer Router Installiert worden ist läuft die Internetverbindung sowie die Verbindung zum Router extrem langsam.
Mit dem Raspberrypi geht das ganze etwa 50 mall langsamer als vorher während es bei einem anderen Rechner fast 80% schneller geht. Was mir besonders ins Auge sticht ist der neue VDSL2 WAN-Zugriff beim Router was ein Grund dafür sein kann.

Bei mit geht alles übers Kabel, kein Wlan.
Als Betriebssystem dient das Raspian
Das vollständige Laden einer Conrad Seite dauert ca. 20min. :(

Danke für eine Hilfe.
 

Lorbin

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Apr. 2008
Beiträge
49
Danke für die erste Hoffnung

Die IP bekomme ich über DHCP.

Mit viel Aufwand habe ich es auch fertiggebracht mit dem Rapberrypi eine fest statische IP zu erwingen, jedoch ohne erfolg.
Die Seiten laden immer noch im grössten Schneckentempo.
Via Router und die MAC Adresse meines Rasberrypi kann ich leider keine feste IP vergeben was aber hoffentlich keinen unterschied machen sollte.
Ergänzung ()

Das Testen hat schon mall was gebracht. ;)

Es gibt anscheinend irgend ein kompatiblitätsproblem zwischen meinem Internet Browser (Midori) und der Internetverbindung mit dem Router.
Mit den Resoursefressenden Browser (Firefox und Chromium) kann das ganze zwar viel schneller geladen werden, aber das scrollen im nachhinein kann man vergessen.
 

Discotizer

Cadet 4th Year
Dabei seit
März 2013
Beiträge
65
was für einen Router hast du denn? hatte auch Probleme mit dem Pi in Zusammenhang mit der Fritzbox per LAN Anbindung. immer einen sehr langsamen Datendurchsatz. verhindern konnte ich das, wenn ich alles Ports der FBox auf 100Mbit beschränkte. oder den Raspi per Wlan eingebunden habe. hab jetzt den TP-Link Archer VR200.Und damit rennt der Raspi.
 

Raijin

Admiral
Dabei seit
Nov. 2007
Beiträge
9.586
"50% langsamer" und "80% schneller" sind nicht hilfreich, solche Angaben kannst du dann auch gleich weglassen..

Um die grundlegende Verbindungsgeschwindigkeit zwischen PI und Router zu testen (bzw. PI<--Router-->PC), lade dir iperf/jperf runter und starte es auf dem PI und einem PC, der per Kabel am Router hängt. Dann führst du einen Speedtest zwischen diesen beiden durch und siehst was die Leitung prinzipiell leisten kann (iperf kopiert quasi RAMzuRAM via LAN). In einem sauberen LAN sollten netto in etwa 90-95% rauskommen. Ist das Ergebnis niedriger, gibt es irgendwo ein Problem (zB defektes Kabel).

Browsertests oder gar Internet-Speedtests sind denkbar ungeeignet, um die Performance in einem Netzwerk zu testen. Wenn obiger Test erfolgreich verläuft, also ca 100 Mbit/s liefern, liegt das Problem grundsätzlich erstmal nicht im Netzwerk an sich. Langsamer Seitenaufbau im Browser kann zB auch durch einen langsamen DNS hervorgerufen werden. Testweise kann man als DNS zB mal 8.8.8.8 für den google-public-dns einstellen.

P.S.: Warum eigentlich Mit viel Aufwand habe ich es auch fertiggebracht mit dem Rapberrypi eine fest statische IP zu erwingen, ? Das ist ein simpler Eintrag in /etc/network/interfaces. DHCP-Reservierungen im Router meide ich persönlich eher, weil ich DHCP eigentlich nur für normale Clients nutze, deren IP im Netzwerk egal ist. Server, Drucker, etc. habe ich auf feste IPs konfiguriert. Sonst hat man keinen Zugriff mehr, wenn der DHCP mal streikt oder auf die Idee kommt neu zu reservieren (mit anderer IP). Mein Speedport reserviert beispielsweise nur für max 3 Wochen. Ziemlich blöd, wenn man solange auf Geschäftsreise oder Urlaub ist und der Drucker hinterher ne andere IP hat....
 
Zuletzt bearbeitet:
Top