SBS2008 - XP Clients verlieren kurzzeitig die Netzwerkverbindung

DoctorTrouble

Cadet 3rd Year
Dabei seit
Mai 2008
Beiträge
33
Hallo,

folgende Probleme bereiten mir seit dem 04.11.2010 Sorgen. Vorher alles perfekt. Es wurde nichts verändert, keine Software, keine Updates und auch keine neue Hardware.

Ausgangssituation:
--------------------
1x SBS2008 SP2 64bit
4x Win XP SP3 pro Clients

Wie ober erwähnt verlieren die XP Clients sporadisch, mal nach 1,5h, 2h mal nach 2,5h für 1-2sec die Netzwerkverbindung zum Server, also auch die Verbindungen zu ihren Freigaben/Netzlaufwerken. Manchmal verlieren sie die Verbindung gleichzeitig, mal aber auch nacheinander.
Da es servergespeicherte Benutzerprofile sind und auch die persönlichen Ordner umgeleitet werden, stüzen die Clients dann ab bzw. es kommen Fehlermeldungen und Fenster ohne Inhalt,
die Schrift in geöffneten Programmen verschwindet usw.

Switch getauscht => keine Besserung
Treiber aktualisiert => keine Besserung
auf Maleware überprüft => nix
NIC am Server tauschen => wird noch gemacht

Hatte es irgend jemand mal mit einem solchen Problem zu tun, oder kann mir jemand geistigen Beistand leisten?

Vielen Dank
 

Revolution

Commodore
Dabei seit
März 2008
Beiträge
4.917
Da es servergespeicherte Benutzerprofile sind und auch die persönlichen Ordner umgeleitet werden, stüzen die Clients dann ab bzw. es kommen Fehlermeldungen und Fenster ohne Inhalt,
die Schrift in geöffneten Programmen verschwindet usw.
Definiere absturz, normal können die User da weiter arbeiten aber eben nicht mehr spreicher.

Das ganze klingt aber sehr nach nem Netz Problem deshlab vermute ich mal die Server nic.


Was steht denn in der Zeit im Log vom SBS?

Was heißt bei dir eigentlich verliert die Verbindung ist alles Weg? Also IP / Netzwerk Link? Nur die Verbindung zum Server?
 

DoctorTrouble

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Mai 2008
Beiträge
33
Am SBS2008 sind im Ereignis-Log zu der Zeit wenn die Verbindung verloren geht keine besonderen Einträge vorhanden, ausser vielleicht mal nen "ID2012 srv" aber nur jeden 5ten Absturz und dann auch nur 1x.

Ein PING auf dem Server, den ich dauerhaft hab laufen lassen zeigt auch keine verlorenen Pakete. Die Clients verlieren nur die Verbindung zu den Serverfreigaben.

Absturz bedeutet am Client soviel wie:
- die Symbole am Client verschwinden alle
(klaro, da redirected folders)
- Programme, die auf Dateien in einer Freigabe zugreifen geben eine Fehlermeldung
und / oder stürzen ab
- Outlook meckert auch rum

Kurzum, nach einem Neustart des/der Clients kann man wieder arbeiten.

Einträge in den Ereignisprotokollen auf den Clients sind nicht zu finden. Am Server auch nicht, ausser vielleicht mal nen "ID2012 srv" aber nur jeden 5ten Absturz.
 

crykiller

Cadet 4th Year
Dabei seit
März 2006
Beiträge
71
Hallo,

Ist der SBS2008 in der Standardkonfig also dhcp und dns server?

Gruß
 

Simon

Fleet Admiral
Dabei seit
Jan. 2002
Beiträge
10.505
Also erstmal bedeuten server-gestützte Profile nicht gleich, dass die Clients permament auf den Profil-Ordner auf dem Server arbeiten. Windows cached bei der Anmeldung eine Kopie des Benutzerprofils lokal auf dem Client und schiebt beim Abmelden die Änderungen wieder zum Server zurück. Ansonsten wäre ein mobiles Arbeiten ja unmöglich.

Wenn natürlich Sitzungen zu Netzlaufwerken permanent von Applikationen genutzt werden, macht sich ein Ausfall des Netzwerkes natürlich bemerkbar.

Prinzipiell bietet das OSI-Schichtenmodell natürlich viele potenzielle Fehlerquellen für das beschriebene Problem.

Interessant wäre es zum Beispiel mal, wenn man testweise nur einen Client (z.B. wenn möglich außerhalb der regulären Arbeitszeit) direkt ohne Switch an den Server anschließt. Bei einer derart überschaubaren Umgebung sollte das eigentlich kein Problem sein. Sollte das Problem immernoch auftreten, weiß man zumindest etwas genauer wo man suchen muss.

Ein paar Details zur Verkabelung der Systeme wären auch noch ganz hilfreich. Läuft das ganze über ein Patchfeld, könnten auch Probleme mit der Erdung eine Rolle spielen. Ist z.B. das Patchfeld nicht geerdet, können sich mit der Zeit Kapazitäten in der Verkabelung aufbauen, die sich dann innerhalb von mehr oder weniger regelmäßigen Abständen auf einen Schlag entladen und durchaus dazu führen können, dass die Verbindung kurz abreißt.

Eine falsche Geschwindigkeits/Duplex-Einstellung auf dem Server könnte auch in Frage kommen. Sofern der Switchport auf Automatische Aushandlung der Geschwindigkeit/Duplex eingestellt ist, sollte dies auf dem Server auch der Fall sein. Gleiches gilt für die Clients.
 

DoctorTrouble

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Mai 2008
Beiträge
33
folgendes habe ich bisher probiert:
-------------------------------------

• Netzwerkswitch getauscht => nix gebracht
• Server NIC getauscht => nix gebracht

Wie gesagt, die Clients stürzen nach ca. 2- 2,5h, manchmal auch früher, ab. Dies macht sich mit Fehlermeldungen, das sind mehrere Fenster ohne Inhalt und rotem X, bemerkbar, außerdem sind zwar noch die Symbole (ICONS) vorhanden aber die Beschriftung ist weg, gleiches im Startmenue. Ping geht nicht mehr also keine Netzwerkverbindung usw. Es lässt sich auch kein Programm mehr öffnen.

Habe auch schon im Fehlerfall die NIC deaktiviert und wieder aktiviert. Hat nicht geholfen, die Clients hatten auch danach keine Netzwerkverbindung

Habe mal spassenshalber beim Client (wenn er läuft) die Netzwerkverbindung getrennt und nach 10 sec wieder angesteckt. Das hat dem Client nicht geschadet und er arbeite ganz normal weiter.

Ich vermute mal, das da irgendetwas den Clients zu schaffen macht und ihn zum Absturz bringt.

Hat jemand noch Ideen zu Fehlereingrenzung?
 
Zuletzt bearbeitet:

DoctorTrouble

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Mai 2008
Beiträge
33
Sorry, das ich mich erst jetzt melde.

Fehler gefunden bzw. ausgemacht.
Es war der Virenscanner von AVIRA.
Virenscanner deinstalliert und anderen installiert => Fehler weg (seit ca. 1 Woche)


Dank an alle die geholfen haben.
 
Top