SSH Zugriff via Dynamische DNS - "Connection timed out"

Dabei seit
Feb. 2017
Beiträge
16
#1
Hallo, ich wollte heute mal SSH Zugriff auf eines meiner Raspis von außerhalb ermöglichen.

Gesagt getan:
account bei noip.com eingerichtet
ddclient und openssh-server installiert
die IP-Adresse wird auch richtig im Portal erkannt.
Port Forwarding eingerichtet (bin bei Vodafone und hab folgenden (gammeligen) Router:
Hersteller Hitron Technologies
Modell CVE-30360


# IP-Adresse Externer Portbereich Interner Portbereich Protokoll
2 192.168.178.13 5000 5000 22 22 TCP

Interne IP-Stimmt auch.

Es kommt immer ein timed out und ich weiß fast nicht mehr weiter. Ich habe noch die Vermutung dass es an der ssh config liegen könnte, nur da habe ich nie groß was rumgestellt und auch nichts im Internet dazu gefunden. Habe sie mal angehängt


Code:
# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22

# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin prohibit-password
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
Ich hoffe ihr könnt mir helfen, wäre sehr dankbar.

Beste Grüße

Storm
 

Cupra 280

Lt. Junior Grade
Dabei seit
Jan. 2015
Beiträge
282
#4
Bitte mal einen Screenshot deiner Portweiterleitungen hier reinstellen.
 
Top