Suche Excel Formel (letzte beschriebene Spalte)

chin842

Lt. Junior Grade
Dabei seit
Okt. 2010
Beiträge
270
Hallo,

folgenedes:

ich habe eine Excel Tabellemit 25 Zeilen und 13 Spalten

Jeden Monat werden in einer neuen Spalte Noten eingetragen.
Ich suche jetzt eine Formel, die automatisch die letzte beiden beschriebene Spalte mit einander vergleicht und die Differenz in die 13te Spalte schreibt.
Gibt es sowas bei Excel, dass er automatisch die letzte beschrieben Spalte erkennt?
Ziemlich aufwendig jeden Monat von Hand die 25 Ergebnisse auszurechnen

z.b

Dieser Monat::::::::::::::nächster Monat
2|1|0|0 +1 ------------- 2|1|3|0 -2
3|2|0|0 +1 ------------- 3|2|1|0 +1
4|5|0|0 -1 -------------- 4|5|2|0 +3

Es handelt sich um Excel 97 -.-

Danke
 
Zuletzt bearbeitet:

jimknils

Captain
Dabei seit
Jan. 2007
Beiträge
3.368
Hast du Word oder Excel 97? Geht aus dem Post nicht eindeutig hervor ;)
 

micjun18

Lieutenant
Dabei seit
Aug. 2005
Beiträge
906
einfach in das feld wo das ergebnis reinsoll =feld2-feld2 vielleicht noch betrag() außenrum und fertig ...
und dann die formel per auto-ausfüllen auf die ganze spalte ziehen
 

13inch

Lieutenant
Dabei seit
Sep. 2010
Beiträge
693
So einfach geht das nicht. Denn die Differenz, die er ausgerechnet haben will, ändert sich von Monat zu Monat. Bzw. die Bezugszellen. Ich würde mit mehreren WENN(PRÜFUNG, DANN, SONST) arbeiten. WENN(Dezember ungleich "", DANN(Dezember-November), SONST WENN(NOVEMBER ungleich "", DANN(November-Oktober), SONST WENN(Oktober ungleich "", DANN(Oktober-September), und so weiter....

Grüße
13inch
 

chin842

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Okt. 2010
Beiträge
270
ja, aber die Formel müsste ich ja jeden Monat umändern.
Ich möchte, dass die Formel sich automatisch ändert, wenn ich die Werte in eine neue Spalte eingetragen habe.


so ähnlich habe ich mir auch schon was überlegt, aber habe die rießige Formel nicht hinbekommen...
 

micjun18

Lieutenant
Dabei seit
Aug. 2005
Beiträge
906
achso grad erst gesehen was du eigentlich willst ...dann mach in das feld wo das ergebnis hinsoll ein WENN-Abfrage mit der du alle spalten durchgehst so ungefähr =WENN(feld2=0; feld1-feld0;0) das kann man noch ineinander verschachteln
Ergänzung ()

sonst musst die spalten schon für 1 Jahr anlegen dann musst die formel nur einmal schreiben und dann nächstes Jahr fängst mit ner neuen Tabelle an oder so

Wenn du den genaueren Verwendungszweck beschreiben würdest könenn wir vielleicht helfen
 
Zuletzt bearbeitet:

13inch

Lieutenant
Dabei seit
Sep. 2010
Beiträge
693
Hier eine getestete Beispielformel für 4 Monate. In den Zellen A1, B1, C1 und D1 stehen Deine Noten drin.

E1 (deine Spalte 13) enthält dann folgendes: =WENN(D1<>""; D1-C1; WENN(C1<>"";C1-B1; WENN(B1<>""; B1-A1; "n/a")))

Musst Du halt für Deine Zwecke auf 12 Monate erweitern.

Wichtig ist, dass Du rekursiv arbeitest. Also: Steht in Dezember eine Note? Ja = Differenz = Dez - Nov, Nein = Steht in November eine Note, Ja = Differenz = Nov - Okt, Nein = Steht in Oktober eine Note....und so weiter. Damit erhältst Du immer die DIfferenz der letzten beiden Monate.
 
Zuletzt bearbeitet:

micjun18

Lieutenant
Dabei seit
Aug. 2005
Beiträge
906
was mir auch noch eingefallen ist du machst nur in jede 2. Zeile die "Daten" und dann kannst in die zusätzliche Zeile die Differenz ausrechnen lassen

Das lässt sich dann beliebig weit fortsetzen

Dann kannst noch mit WENN Abfrage es so Basteln dass er es nur für die zuletzt eingetragene Note berechnet und noch weitergesponnen kannst mit einer SUMME der ganzen Zeile das ergebnis dann noch in eine letzte Übersichtsspalte eintragen lassen, dass die Differenz immer an der gleichen stelle steht
 
Zuletzt bearbeitet:

chin842

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Okt. 2010
Beiträge
270
@13inch,


funktioniert bei mir nicht wirklich deine Formel,

funktioniert nur bei spalte C und D.
Wenn D und C null sind, berechnet er nichts aus A und B.
Ergänzung ()

Funktioniert, hab noch etwas umgeändert :) DANKE, hoffe nur, das excel auch 12 wenn verkettungen kann
Ergänzung ()

=WENN(L1>0; K1-L1;WENN(K1>0; J1-K1;WENN(J1>0; I1-J1;WENN(I1>0; H1-I1;WENN(H1>0; G1-H1;WENN(G1>0; F1-G1;WENN(F1>0; E1-F1;WENN(E1>0; D1-E1;WENN(D1>0; C1-D1; WENN(C1>0;B1-C1; WENN(B1<>""; A1-B1; "n/a")))))))))))

das fertige Formel, aber Excel mag die nicht, zuviele WENN, mekert bei dem 9 Wenn rum....kann excel nur max 8 WENN?
Ergänzung ()

hab einfach 2 Zellen mit der Formel verknüpft :) funktioniert jetzt alles super: Formel

=WENN(L1>0; K1-L1;WENN(K1>0; J1-K1;WENN(J1>0; I1-J1;WENN(I1>0; H1-I1;WENN(H1>0; G1-H1;WENN(G1>0; F1-G1;WENN(F1>0; E1-F1;WENN(E1>0; D1-E1;F2))))))))

Zelle F2::: =WENN(D1>0; C1-D1; WENN(C1>0;B1-C1; WENN(B1<>""; A1-B1; "n/a")))
 
Zuletzt bearbeitet:
Top