Twitch stream buffert permanent trotz richtigen settings [OBS]

MKdennis

Lieutenant
Dabei seit
Feb. 2014
Beiträge
517
hi

ich wollte mal fragen ob ihr ne idee habt zu meinem problem.

ich habe obs nach diesem tutorial http://help.twitch.tv/customer/portal/articles/1262922-open-broadcaster-software
konfiguriert und soweit funktioniert auch alles.

habe die bitrate 3500 puffer 3500 server frankfurt und auch den rest der einstellungen wie empfohlen.
allerdings buffert mein stream immer wenn ich streame und so macht schauen keinen spass.

dachte erst es liegt an twitch aber alle anderen streamer streamen ja auch lagfrei.

meine inet leitung is ne 120/6 von unitymedia

vielleicht hat ja einer ne idee

danke :):)
 

Toms

Vice Admiral
Dabei seit
Juni 2011
Beiträge
6.328
Mit welchen weiteren Einstellungen streamst du? Und was streamst du?
 

Necareor

Admiral
Dabei seit
Juli 2012
Beiträge
9.005
Stell die Bitrate runter, für einen Kanal ohne nennenswerte Zuschauerzahl bekommst du bei so hoher Bitrate kaum einen ruckelfreien Stream hin.
Twitch priorisiert nämlich, d.h. bei einem Kanal mit vielen Zuschauern gibt Twitch diese hohe Bitrate für die Zuschauer auch frei. Bei unbekannten Kanälen kommen bei den Zuschauern im Schnitt nicht viel mehr als 2 MBit/s an, und wenn du dann 3500 KBit/s einstellst, ruckelt und buffert es bei den Zuschauern.
Als Nicht-Partner können die Zuschauer bei dir leider auch keine Qualitätseinstellungen vornehmen, was das Problem wenigsten ein bisschen umgehen würde.

Es liegt also nicht an dir, sondern an Twitch. Das ganze ist auch noch etwas abhängig von Provider und Standort des Zuschauers.
 
Zuletzt bearbeitet:

MKdennis

Lieutenant
Ersteller dieses Themas
Dabei seit
Feb. 2014
Beiträge
517
Mit welchen weiteren Einstellungen streamst du? Und was streamst du?
habe versucht cs go zu streamen. die einstellungen sind wie gesagt bitrate 3500 und puffer 3500 gewesen mit cbr an in 720p bei 30 frames


ok danke necareor ich werds mit weniger bandbreite versuchen. habe gerade mal shadow play getestet da hat es genauso gebuffert sogar noch schlimmer. lag wohl daran das es bei shadwo 60 fps waren.

ich meld mich wieder obs funktioniert hat
 

Necareor

Admiral
Dabei seit
Juli 2012
Beiträge
9.005
Am besten fängst du einfach mal bei 1500KBit/s an, mit einer Auflösung von 960 x 540. 720p ist da zu pixelig bei der Bitrate, und die FPS würde ich auf 20-25 beschränken.

Läuft das flüssig, dann arbeitest du dich immer in 100 KBit-Schritten nach oben. Am Besten testest du das auch über Mobilfunk und Freunde, nicht nur an deiner eigenen Leitung, denn nur weil der Stream bei dir flüssig läuft, muss das nicht für alle anderen Zuschauer gelten. Ab 2000Kbit/s kannst du dann die FPS oder die Auflösung etwas erhöhen, je nachdem was dir wichtiger ist.
 
Zuletzt bearbeitet:

MKdennis

Lieutenant
Ersteller dieses Themas
Dabei seit
Feb. 2014
Beiträge
517
alles klar werd ich versuchen danke.

ich hatte es jetzt mal getestet mit ner bitrate von 1800 auf 720/60. bei meinem freund lief es dann flüssig aber bei mir selber auf dem handy hat es immer noch gebuffert.... ich werd weiter testen

danke für eure hilfe
 

Necareor

Admiral
Dabei seit
Juli 2012
Beiträge
9.005
Mehr als 30FPS solltest du echt nicht machen. Du musst bedenken, dass bei 60FPS im Vergleich zu 30FPS die Bildqualität halbiert wird. Denn bei 1800KBit/s (nehmen wir mal an, nur für Video) erhält bei 60FPS jedes Bild nur noch 30KBit (1800/60), bei 30FPS immerhin 60KBit (1800/30).
Wenn du mal eine Zuschauerzahl hast, die dir eine Bitrate von 3000KBit oder mehr erlaubt, dann kannst du bei schnellen Titeln darüber nachdenken, die FPS zu erhöhen. Vorher solltest du das Maximum an Bildqualität aus der niedrigen Bitrate rausholen.
 

MKdennis

Lieutenant
Ersteller dieses Themas
Dabei seit
Feb. 2014
Beiträge
517
ok danke für die erklärung :)

hatte mich verschrieben. hatte 30fps eingestellt nicht 60.
werde die nächsten tage weiter testen und deine tipps beherzigen. falls ich wider erwarten weiterhin probleme haben sollte melde ich mich nochmal
 
Top