.txt-Dateien öffnen die Konsole anstatt den Editor/Notepad

komatanz

Newbie
Dabei seit
Nov. 2013
Beiträge
3
Heja!
Nachdem ich mich heute morgen mal schnell rangesetzt habe und nach Anleitung eine .bat (für Minecraft :freak: ) erstellt habe, muss ich irgendwie zu doof und zu schnell was geklickt haben, dass sich nun alle .txt-Dateien als cmd-Konsole öffnen.
Leider lässt sich das weder durch "Öffnen mit..." oder "Immer öffnet mit..."-Häcken beseitigen, da das Feld ausgegraut und somit nicht anwählbar ist. Punkt 1 der mich stutzig machte.
Eine Änderung bei der Auswahl der Standardprogramme (Win 7 64bit) lässt sich zwar scheinbar durchführen, wird aber nicht übernommen. Punkt 2.

Zwischenzeitlich ist das "Textdokument" dann auch aus dem Rechtsklick-Kontext-Menü verschwunden - das aber hab ich dank Registry-Vergleich mit meinem Lappi wieder hinbekommen, wenngleich die .txt nun englische Namen haben "Text Document (neu)"... Was mich aber nur minder stört. --> Auf dem Lappi stehnse noch deutsch, beim Erstellen... Aber naja, mal sehen. Eines nach dem anderen.

.txt-Dateien selbst kann ich zwar immernoch mit dem Editor öffnen, allerdings dann nur via Kontextmenü. (Öffnen mit; Bearbeiten)
Rein laienhaft betrachtet deutet nun nichts mehr darauf hin, dass der Fehler in der Registry zu suchen ist. (Davon abgesehen, dass ich die Einträge zu "txtfile" manuell neu (vom Laptop ab-)geschrieben habe und da bei einigen Schlüsseln nun ein leerer Zeichensatz steht....Der wollte mich einfach keinen rg_expand_sz erstellen lassen ohne, dass da nicht ein rg_sz vorher war. Siehe Anhang!)
SInd vielleicht die verbliebenen "leeren" Zeichenfolgen das Problem?
Oder müsste ich lediglich die Registry aufräumen - optimalerweise ohne Drittanbieter-Software...

Vielleicht weiß ja hier jemand Abhilfe, ich benutze .txt nicht selten (u.a. als passive Gedächtnisstütze... ). :)

Mit freundlichem Gruß,
Koma



txt-problem.png
 

Randy89

Captain
Dabei seit
Mai 2013
Beiträge
3.287
Versuch es doch erstmal mit einer Systemwiederherstellung auf einem Zeitpunkt, bevor du die .txt-Zuordnung zerschossen hast.
 

komatanz

Newbie
Ersteller dieses Themas
Dabei seit
Nov. 2013
Beiträge
3
Selbst gelöst - Hatte folgende Seite scheinbar übersehen...

http://www.sevenforums.com/tutorials/19449-default-file-type-associations-restore.html


Löst auch das Sprachfasching aus Englisch (deutsch).txt.
Der einzige Unterschied schienen tatsächlich die "leeren" Einträge zu sein, die man aber vorher nicht löschen konnte.

Immerhin ist die Seite generell nützlich für Registry-Reparaturen, schätze ich. :)

Angenehme Woche, wünsche ich euch!
Koma
 

E.o.B

Lt. Junior Grade
Dabei seit
Juli 2012
Beiträge
442
Hallo,

was steht denn unter standardprogramm für textdatein?
Also Rechtsklick auf eine Textdatei -> Öffnen mit -> Standardprogram auswählen...
 

easy.2ci

Commodore
Dabei seit
Mai 2006
Beiträge
4.242
du kannst in der cmd mit ftype und assoc die Zuordnung korrigieren. Zur Sicherheit eine administrative cmd aufrufen. Die genaue Syntax bekomme ich nicht mehr hin, aber ein bißchen Arbeit muss ja noch für Dich übrig bleiben ^^
 
Top