Was für Einstellungen für Subdomain vornehmen? Host-unlimited

F

Fat32Tony

Gast
Ich habe vor bei meiner Host-unlimited Domain eine Subdomain zu definieren. Apache2 dürfte soweit richtig konfiguriert sein (https.conf etc.) aber bei den Einstellungen im Domainrobot bin ich mit meinem Amateurwissen echt am Ende..

Hier mal ein screenshot:
dyvd558a.png

Was soll ich tun? Ich verwende eine IPv4 Adresse und eine DE-Domain.
 
Zuletzt bearbeitet: (Korrekte deutsche Rechtschreibung.)

Cr41s3

Ensign
Dabei seit
Dez. 2012
Beiträge
246
Ist die Sub-Domain auf dem selben Server, wie die Maindomain?

Ansonsten nur den A-Record auf die andere IP lenken.
Nur sehe ich dort leider auch nicht, wie dies geht ;o
 

Cr41s3

Ensign
Dabei seit
Dez. 2012
Beiträge
246
Wenn es die selbe main domain ist also a.test.de und test.de, brauchst du im Robot nichts neues einstellen
 
F

Fat32Tony

Gast
@Dann muss das Problem wohl doch in der httpd.conf liegen soweit ich das sehe?
 
Zuletzt bearbeitet:
F

Fat32Tony

Gast
Code:
<VirtualHost *:80>
Servername *.domain.de
DocumentRoot /var/www
</VirtualHost>

<VirtualHost *:80>
Servername test.domain.de
DocumentRoot /var/test
</VirtualHost>
Was ist hierdran auszusetzen? Hab dem test Ordner auch mal 777 gegeben, bringt aber nix^^
 

Cr41s3

Ensign
Dabei seit
Dez. 2012
Beiträge
246
Code:
#img.KreisDEV.de
<VirtualHost *:80>
    ServerName www.img.kreisdev.de
    ServerAlias img.kreisdev.de
    ServerAdmin cr41s3@kreisdev.de
    DocumentRoot "C:\Users\Administrator\Desktop\Server\Web\kreisdev\Domains\img.kreisdev.de\public_html"

    ErrorLog "C:\Users\Administrator\Desktop\Server\Web\kreisdev\Domains\img.kreisdev.de\logs\img.kreisdev.de-error.log"
    CustomLog "C:\Users\Administrator\Desktop\Server\Web\kreisdev\Domains\img.kreisdev.de\logs\img.kreisdev.de-access.log" combined

    <Directory "C:\Users\Administrator\Desktop\Server\Web\kreisdev\Domains\img.kreisdev.de\public_html">
        Options -Indexes -ExecCGI -Includes
        Options FollowSymLinks
        Order allow,deny
        Allow from all
        AllowOverride All
        DirectoryIndex index.php index.shtml index.html index.htm
        RewriteEngine on
        LimitRequestBody 512000
    </Directory>
</VirtualHost>
So sieht das bei einer Domain von mir aus.
Bei mir läuft es über Windows, sollte aber identisch zu Linux sein.

Was kommt denn, wenn du versuchst deine Sub-Domain aufzurufen?
 
F

Fat32Tony

Gast
Chrome:
"Diese Website ist nicht verfügbar"
Firefox:
Server not found
Firefox can't find the server at ...

Dazu noch Hinweise auf die Verwendung ebend anderer Subdomains. Der Ordner /var/test scheint also nicht genutzt worden zu sein, denn in ihm liegt eine index.html mit dem Inhalt
Code:
<html>
asdasda
</html>
 

Cr41s3

Ensign
Dabei seit
Dez. 2012
Beiträge
246
Dann liegt es an dem Hoster.
Ich kenne es von vielen Hostern, dass diese nicht belegte Sub-Domains auf die Main-Domain(IP) leiten.
Dann habe ich nur deine Zeit verschwendet und du musst das ganze im Webinterface einstellen, tut mir Leid.
 
F

Fat32Tony

Gast
Eigentlich habe ich deine Zeit verschwendet indem ich dich mit meinem Problem beschäftigt habe :)
Dann kommt aber die ursprüngliche Frage wieder ins Spiel, nämlich dass ich keine Ahnung habe welchen RR Type ich verwenden soll? Der TTL und Prev Wert war vordefiniert, dürfte also nicht ganz so tragisch sein.?
 
F

Fat32Tony

Gast
Okay, ich habe es geschafft.

Ich hatte wohl lediglich keine Rechte den prev Wert zu ändern, das Entfernen der Vordefinition hat mein Problem gelöst.
Vielen Dank @Cr41s3 :)
 
Top