X1950XT Update für den Offiziellen Catalyst 6.11 - W32 (V1.1) / W64 (V1.0)

b|ank0r

Lieutenant
Dabei seit
Nov. 2006
Beiträge
532
X1950XT Update für den Offiziellen Catalyst 6.11 - UPDATE 25.11.2006

Parallel zum Thread im Hardwareluxx:

Hellas,

wie einige von Euch ja bestimmt schon mitbekommen haben herrscht(e) um die X1950PRO und die X1950XT eine gewisse Problematik in Form von alten und verbuggten Treibern. Nachdem heute nun der finale 6.11'er Catalyst Treiber rausgekommen ist und nun eine saubere Unterstützung für die X1950PRO integriert wurde fehlt immernoch jeglicher Support für die X1950XT. Da ich selber Besitzer einer solchen Karte bin und mir dieses ganze Hick Hack nicht mehr antun wollte habe ich mich mal an die neuen Installationsdateien begeben und diese modifiziert bzw. um die X1950XT erweitert.

Das Ergebnis sind sechs abgeänderte Dateien welche Ihr einfach in das entpackte Treiberverzeichnis kopieren müsst und somit die Original Dateien ersetzt. Bei mir hat das wunderbar funktioniert, ich hoffe bei Euch auch und würde mich daher sehr freuen wenn hier welche von Euch das ebenso testen könnten :)

Die nötigen Dateien hänge ich hier mal an und sollten auf dem CCC sowie dem normalen Treiberpaket laufen :wink:

Zum Hintergrund dessen was ich gemacht habe:

Mir ist in dem Treiber aufgefallen das ATI evtl. den Support für die X1950XT hinzugefügt jedoch falsche / fehlerhafte ID's benutzt hat. Ich habe das dementsprechend korrigiert und es hat bisher auch geklappt. Ihr könnt ja auch mal selber einen Blick reinwerfen ist recht logisch.

Wie gesagt bin für weitere Tester sehr dankbar - wäre für Euch (X1950XT Besitzer) ja auch nur von Vorteil ;)


### UPDATE 16.11.2006 ###

- Windows XP X64 Edition hinzugefügt -

### UPDATE 19.11.2006 ###

- Alte Archive aktualisiert -
- Neue ATI Treiber Dateien mit der internen Build '38857' hinzugefügt -

### UPDATE 25.11.2006 ###

- Neue BETA Treiber Dateien des Catalyst 6.12 mit der internen Build '38877' hinzugefügt -


### CHANGELOG W32 ###

Build 37616 (Intern 38529)

Version 1.1

- 'Radeon 1950 Series Secondary' Fehlerkennung behoben -

Version 1.2

- Dateiname sowie Readme aktualisiert -​

### CHANGELOG W64 ###

Build 37616 (Intern 38529)

Version 1.1

- Dateiname sowie Readme aktualisiert -​


### Treiber Download ###

Offizielles 6.11 Release

Build 37616 (Intern 38529)

Referenz by Sapphire
--> einfach unter 'Grafik' die 'Radeon 1950 XT - 256MB' auswählen und das entsprechende herunterladen​

Build 37616 (Intern 38857)


Inoffizielles 6.12 Release

Build ? (Intern 38877)

 

Anhänge

Zuletzt bearbeitet:

meikotimo

Lt. Commander
Dabei seit
Sep. 2005
Beiträge
1.367
THX werde ich mal ausprobieren.
Vll. funktioniert dann auch das mit der 2. Anzeigeoption, denn ich kann bisher immer noch keinen TV als Ausgabegerät hinzufügen.
Zwar wird es erkannt, jedoch kann es nicht aktiviert werden.

€dit: Hmm, nee, irgendwie kann ich keine Bildausgabe auf dem TV ermöglichen.. shit.
 
Zuletzt bearbeitet:

toxelchen

Lt. Commander
Dabei seit
Juli 2004
Beiträge
1.091
du bist mein gott....endlich kann ich einen catalyst installieren. :D

geht einwandfrei.
 

b|ank0r

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
532
@meikotimo:

kann ich leider nicht testen :(

aber immerhin gut zu wissen das es bei euch ebenso einwandfrei funktioniert :)
 

Kaywalker

Ensign
Dabei seit
Jan. 2006
Beiträge
229
Hi,

ich hab mir auch ne x1950XT von Sapphire bestellt. Sollte heute eigentlich noch kommen!
Wenn ich das also richtig verstehe, läuft der orig. Treiber 6.11 von ATI´s HP nicht mit der Karte??
Gibt es eine andere Möglichkeit (Treiber von Sapphire direkt, o.ä.) die karte ans laufen zu bringen? Ich möchte ungern an den Treiber "rumfummeln" damit was läuft. Wenn´s halt garnicht anders geht, o.k. Was kann mir im schlimmsten Fall passieren??


Mfg
Kaywalker
 

toxelchen

Lt. Commander
Dabei seit
Juli 2004
Beiträge
1.091
der mitgeliefrte treiber geht einwandfrei. keine angst...ist halt der ctalayst 6.10.
 

Kaywalker

Ensign
Dabei seit
Jan. 2006
Beiträge
229
Hi,

ist denn jede x1950xt betroffen? Hab hier und da mal gelesen, dass einige
wohl den 6.11 CAT ohne Probs installiert haben.
Werds wohl versuchen müssen...

Heute kam schonmal der Hauptteil meines Weihnachtsgeschenkes an!
( C2D 6600, Arctic Cooling Freezer 7 pro, Gigabyte DQ6, 2 GB MDT DDR-800, beQuiet DarkPower 430W)
Morgen oder Montag soll dann die GraKa kommen. (musste nachgeschickt werden!)

Vllt kann auch jemand ein Komplettpaket mit den MOD-Treibern von b|ank0r machen und zum Download stellen???


Mfg
Kaywalker
 

Rexo

Cadet 3rd Year
Dabei seit
Sep. 2006
Beiträge
48
Hab ne X1950 XTX:

  • Treiber auf der mitgelieferten CD liefen ohne Probleme.
  • Die Catalyst 6.11 liefen auch ohne Schwierigkeiten

Ich hab aber wieder die Treiber von der CD genommen, da diese ein wenig mehr Punkte im 3DMark06 eingefahren haben (ca. 50) - aber das kann man vernachlässigen.. evtl. hab ich bei nem erneuten Durchlauf der beiden Treiber das umgekehrte Ergebnis ;)
 

b|ank0r

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
532
@REXO:

Du hast ja auch eine XTX und keine XT ;)

@ALL:

Gibt ein kleines Update :)
 

Sublogics

Rear Admiral
Dabei seit
Feb. 2005
Beiträge
5.818
Sauber b|ankOr!
Hab gestern meine X1950 XT von Connect3D bekommen und - Oh Schreck! - kein Treiber lief. Weder der auf CD, noch der angeblich funktionierende 6.8er, geschweige denn der 6.11.
Die sparsamen Connect3Dler bieten hierzu auch keinerlei Infos auf der eigenen HP.
So habe ich bei ATis Haus und Hof-Produzent Sapphire geschaut und bin auf einen Beitrag von dir mit Link zu deinem Thread im ForumDeluxx gestoßen.
Astreine Arbeit - allerbesten Dank. Wieso können weder die Hersteller noch ATi so eine simple Maßnahme selbst erledigen?
 

b|ank0r

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
532
@Sublogics:

Es ist schon erschreckend wenn zwei Catalyst Versionen (6.10 / 6.11) vorüber schreiten und ATI es noch immer nicht geschafft hat die 1950XT zu integrieren. Sowas hätte es bei nVidia nicht gegeben - und sei es in einer ihrer "Beta-Treiber" Varianten (und das meist im Vorraus bevor man von den Karten überhaupt wusste) :(
 

serkon142

Lt. Commander
Dabei seit
Nov. 2005
Beiträge
1.118
Erstmal dankeschön das du so nett warst und es gemacht hast, aber kannst du mir mal erklären wie ich es genau mache?

Da steht folgendes:

C2_38529.inf
CX_38529.inf



C2_38529.INI
CA_38529.INI
CX_38529.INI
INSTALL.INI

Ok die Daten gibt es wenn man es entpackt, aber woher zum Teufel soll ich wissen das davon ini und was davon inf Dateien sind? Sie sehen alle gleich aus und da steht auch nicht welche es sind. Und die Namen sind alle 2x vorhanden. Wenn ich die öffne kommt da nur der Editor wodurch ich auch nicht rausfinde um welche es sich genau handelt.
Bitte um Hilfe :D
 

sourcefreak

Commander
Dabei seit
Juli 2006
Beiträge
3.038
Arbeitsplatz > Extras > Ordneroptionen > Ansicht > Erweiterung bei Bekannten Dateitypen ausblenden ...

Das zeigt dir die Dateierweiterung an.
 

Rosicky

Lieutenant
Dabei seit
Feb. 2005
Beiträge
605
habe auch meine X1950XT erhalten gleiche probleme wie beschrieben, die treiber von cd funzen, aber nur wenn ich VGA kabel dran habe bei DVI komm ich nicht mal ins windows.

was kann ich machen? oder wo liegt da der fehler?
 

Kaywalker

Ensign
Dabei seit
Jan. 2006
Beiträge
229
Hi,
kleines Update für alle Sapphire Freunde:
Auf deren HP gibt es Treiber die endlich mit der X1950XT gehen!
*klick*

Bringen in 3dMark06 ca 100 Punkte mehr...


Mfg
Kaywalker
 
Top