Zählen mit mehren Bedingungen funktioniert nur eingeschränkt

Nico_B

Lt. Junior Grade
Dabei seit
Sep. 2010
Beiträge
336
Hallo.

Ich habe zwei Tabellenblätter. Auf Tabellenblatt 1 erfolgt die Eingabe/Erfassung. Dieses Trägt auch den Namen Tabellenblatt Erfassung.

Tabellenblatt 2 trägt den Namen Auswertung.

Nun soll die Anzahl zu der Kombination von zwei Kriterien auf Tabellenblatt Erfassung bestimmt werden. Betroffen sind die Spalten E und F.

Mit folgenden Formel wird die Anzahl korrekt ermittelt:
=SUMME(WENN((Erfassung!$E$4:$E$200=(ZEILE()-4))*(Erfassung!$F$4:$F$200=F$4);1))
=SUMME(WENN((Erfassung!$E$4:$E$200=1)*(Erfassung!$F$4:$F$200=F$4);1))

jeweils als Array-Formel.

Wenn ich jedoch stattdessen folgendes eingebe:
=SUMME(WENN((Erfassung!$E$4:$E$200=$A5)*(Erfassung!$F$4:$F$200=F$4);1))
ebenfalss als Array-Formel (In A5 steht eine 1)

dann kommt als Ergebnis immer Null raus. Das verstehe ich nicht. Wo ist der Fehler???

Version ist Excel 2000.
 

OhNoIKilledMyHD

Lieutenant
Dabei seit
Sep. 2010
Beiträge
758
Die Vergleiche innerhalb einer mathematischen Formel sind mindestens ungewöhnlich.
Mit dem Wert WAHR/FALSCH kannst Du so wie Du es machst als Zahl nicht einfach rechnen.

WAHR ist nicht gleich 1 und umgekehrt, die Sonst-Zweige in den Wenn-Bedingungen lässt Du ganz
weg. Könntest Du Dein Tabellenblatt hochladen und den Link posten?

Mir wird so nicht ganz klar, worauf Du hinaus willst.
Sicher, dass Du SUMME(WENN...) verwendest und nicht SUMMEWENN(....)?
 
Top