Anonymer Zugriff auf Netzwerkshare zwischen XP und 7

2TAKTER

Lt. Junior Grade
Dabei seit
Okt. 2005
Beiträge
399
Hallo,

ich versuche derzeit eine auf Windows 7 Professional freigegebene Share unter XP u erreichen.

Auf Win7 habe ich den Ordner freigegeben und die permissions für "everyone" auf vollzugriff gesetzt. Ich habe das Gastkonto deaktiviert und unter den Local Security Policies > User Rights Assigment > Deny access to this computer to the network den Gastaccount raus genommen.

Unter XP hat das gereicht, damit der Gast account ohne Passwort auf eine share zugreifen kann. Windows 7 sperrt sich dagegen. Es ist allerdings wichtig, dass der Zugriff komplett anonym von jedem Computer ohne Anmeldung funktioniert.

Bin für jede Hilfe dankbar.

Gruß

EDIT: http://technet.microsoft.com/en-us/library/cc772211.aspx hat nichts geholfen
 
Zuletzt bearbeitet:

Wilhelm14

Fleet Admiral
Dabei seit
Juli 2008
Beiträge
19.053
In den Erweiterten Freigabeeinstellungen von Win 7:

Netzwerkkennung einschalten
Datei- und Druckfreigabe aktivieren
Kennwortgeschütztes Freigeben ausschalten
Benutzerkonten und Kennwörter zum Herstellen von Verbindungen mit anderen Computern verwenden. (Nicht Heimnetzgruppen...)

So kann XP auf Win 7 zugreifen, wenn bei Win 7 die Freigabe auf Jeder steht. Ganz blind, ohne Anmeldedaten.

PS: Wie weit kommt denn XP? Kann XP den Win 7 PC in der Netzwerkumgebung sehen? Kann man die Freigaben sehen?
 

Schildkröte09

Admiral
Dabei seit
Nov. 2009
Beiträge
7.233
Hallo,

es muss NICHT auf "JEDER" eingestellt werden (weil Risiko zu groß), wenn Benutzerkonten auf beiden PC´s identisch angelegt sind, d.h. das Benutzerkonto wie unter XP auch auf Windows 7 MIT PASSWORT einrichten und umgekehrt das Benutzerkonto wie in Windows 7 auch auf dem PC mit XP.

Beispiel: Auf PC 1 unter Windows 7 wird das Benutzerkonto : PC1 mit Passwort verwendet.
Auf PC 2 unter XP wird das Benutzerkonto : PC2 mit Passwort verwendet.
Unter Windows 7 wird nun ein neues Benutzerkonto mit PC2 und das Passwort wie unter XP angelegt
Unter XP wird nun ein Benutzerkonto mit PC1 und das Passwort wie unter Windows 7 angelegt.
Danach werden auf beiden PC´s die Freigaben eingerichtet für jeweils den anderen Benutzerkontoname.

Die Benutzerfreigaben beziehen sich dann jeweils auf das andere Benutzerkonto. So können NUR die beiden PC´s miteinander austauschen und nicht JEDER. Außerdem kann man mit JEDER NUR auf die öffentlichen Bibliotheken zugreifen. (Bin mir aber nicht ganz sicher).

Der Netzwerkverkehr muss separat in der Firewall eingestellt und freigegeben werden. Bei der Windows eigenen brauch nichts weiter eingestellt werden. Allerdings sind die Einstellungen wie Wilhelm14 gepostet hat, ebenfalls so vorzunehmen.

Heimnetzgruppen unter Windows 7 dienen NUR dem Netzwerkverkehr zwischen/unter WINDOWS 7 PC´s, also KEINE Heimnetzgruppe auf dem Windows 7 PC einrichten, wenn auf einen XP PC zugegriffen wird.

Viele Grüße auch an Wilhelm14
 
Zuletzt bearbeitet:

Wilhelm14

Fleet Admiral
Dabei seit
Juli 2008
Beiträge
19.053
Hallo Schildkröte09! :)

Es ist allerdings wichtig, dass der Zugriff komplett anonym von jedem Computer ohne Anmeldung funktioniert.
Man kann ja Jeder auf Lesen stellen. So kann jeder z.B. MP3s hören. Auf Support-Webseiten sind z.B. PDF-Handbücher auch für Jeden lesend zu erreichen. Zumindest habe ich den ersten Post so verstanden, dass so zugegriffen werden soll.
 

Schildkröte09

Admiral
Dabei seit
Nov. 2009
Beiträge
7.233
das stimmt Wilhelm14. Liebe Grüße ;) Ich bin mir nur nicht ganz sicher, ab das auch Ordner/Dateien außerhalb der Bibliotheken betrifft. Es könnte sein, das es funktioniert vom Windows 7 PC auf den XP PC, aber nicht / oder, umgekehrt. Es kommt dann eine Fehlermeldung das die Berechtigungen fehlen, (bei jedem Zugriff auf einen Ordner/Datei), da man bei XP von Haus auf auf die Benutzerkonten setzte.

Welche Firewall wird eingesetzt ? Bei NORTON INTERNET SECURITY oder KASPERSKY kann ich helfen einzurichten.
 
Zuletzt bearbeitet:

2TAKTER

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Okt. 2005
Beiträge
399
Danke für eure Antworten. Ich habe inzwischen den Fehler gefunden und musste mir selbst vor lauter Blödheit ins Gesicht schlagen.

Das Netzwerk und die Nutzerrechte für die Freigabe waren komplett richtig eingerichtet. Allerdings die Sucirty Options im lokalen Dateisystem kannten "Jeder" nicht :freak:

Ich danke euch für die Mühe
 

Wilhelm14

Fleet Admiral
Dabei seit
Juli 2008
Beiträge
19.053
Bibliotheken nutze ich nicht und der Öffentliche Ordner ist deaktiviert.

Rechtsklick auf den Ordner MP3, freigeben für... bestimmte Personen..., aus der Liste Jeder auswählen, Hinzufügen klicken. In der Liste steht nun Jeder mit Lesen. So greift ein Partykellerrechner mit XP auf eine Windows 7 Freigabe zu. XP sieht den Win 7 PC in der Netzwerkumgebung, geklickt erscheint der Ordner MP3, geklickt kann man darin navigieren. Alles ohne Anmeldung. Lesend werden so zu später Stunde keine Alben aus Versehen verschoben. :)

PS: Tippe zu langsam, klappt ja nun. Mir ist es auch schon passiert, zu vergessen auf "Hinzufügen zu klicken. "Jeder" muss ja dadurch hinzu geklickt werden. Und "Übernehmen" klicken (habe ich auch schon mal vergessen). :)


Edit: Übrigens den Kram mit gpedit und Gastkonto an/aus und co. habe ich noch nie benutzt. Hier geht es so.

Edit 2: Die Fehlermeldung, die Schildkröte09 meint kommt, wenn man das Kennwortgeschütze Freigeben einschaltet.
Wenn das kennwortgeschützte Freigeben aktiviert ist, können nur Benutzer, die ein Benutzerkonto und ein Kennwort für diesen Computer besitzen, auf freigegebene Dateien, ...zugreifen. Sie müssen das kennwortgeschützte Freigeben deaktivieren, um anderen Benutzern Zugriff zu geben.

Viel Spaß nun, 2TAKTER!
 

Anhänge

Zuletzt bearbeitet:
Top