avidemux - nie synchron

ed_lumen

Commander
Dabei seit
März 2008
Beiträge
2.745
warum bloß ist es scheinbar unmöglich, mit avidemux selbst "simple" schnitte (anfang einer aufzeichnung weg, ein paar minuten vom schluß) hinzubekommen, ohne daß bild und ton total auseinanderlaufen? egal ob mpg oder ts-datei: im copy-modus auf mpeg-ps (a+v) mit 2.5.4 - egal ob mit jeder beliebigen shift-einstellung oder ohne, es wird nicht synchron. gibt es dafür wirklich kein einziges simples programm? geht es nur mit der kombination diverser programme und zahllosen arbeitsschritten?
 

Dimpel

Cadet 4th Year
Dabei seit
Mai 2010
Beiträge
76
Hi,

ist der Ton willkürlich auseinander ?
oder nur um weiß ich ~250ms vor oder zurück ?

Gruß Dimpel
 

-Nante-

Commodore
Dabei seit
Dez. 2006
Beiträge
4.693
für mpeg nutze ich pvastrumento + mpeg2schnitt . für ne .ts tssniper .
 

ed_lumen

Commander
Ersteller dieses Themas
Dabei seit
März 2008
Beiträge
2.745
der ton ist um gefühlt halbe bis ganze sekunde ähhh zurück glaub ich ... jedenfalls nicht völlig weg.
 

Dimpel

Cadet 4th Year
Dabei seit
Mai 2010
Beiträge
76
Hi,

dann benutz (d)noch den Delay und setz es auf 1000ms für vor (in diesem Fall wenn der Ton zu früh kommt) und falls minus -1000ms (wenn der Ton zu spät kommt)

Gruß Dimpel
 

TBMule

Lt. Commander
Dabei seit
Mai 2006
Beiträge
1.156
AviDeMux liest nicht die Delayeinstellungen der TS mpeg u.ä. Dateien ein, da mußt Du vorher per MediaInfo selber gucken wieviel Verzögerung bei AVIDeMux ->Delay eingegeben werden muß.

AVIdeMux 2.5.4 r6854 läuft gut.
 
Zuletzt bearbeitet:

ed_lumen

Commander
Ersteller dieses Themas
Dabei seit
März 2008
Beiträge
2.745
genau die ist die version, die ich benutze, rev. wird nicht angegeben.

danke für deinen tip. beispiel:
video von 10:45.560
audio von 10:46.560
differenz: -451

das eingegeben bei audio-shift, während v + a auf copy stehen. dieselbe asynchronizität wie immer.
 

TBMule

Lt. Commander
Dabei seit
Mai 2006
Beiträge
1.156
nene das ist falsch nicht den rechnerischen Wert eingeben, sondern siehe Screenshot.
Und nicht vergessen das richtige Format VOR dem Schneiden auswählen!
 

Anhänge

  • MEPG-TS-Verzoegerung.jpg
    MEPG-TS-Verzoegerung.jpg
    205,3 KB · Aufrufe: 1.633

Dimpel

Cadet 4th Year
Dabei seit
Mai 2010
Beiträge
76
Hi,

es sind auch einige Merkmale zu beachten.
Du hast es nachhinein asynchron nach dem es fertig zusammengeschnibbelt ist.
Also den Delay Wert nicht beim erneuten zusammenbasteln nehmen sondern wenn es fertig vorliegt.
Mit Avidemux die fertig geschnibbelte Datei öffen, Video und Audio auf Copy setzen (liegt meistens direkt vor) den Delay aktivieren und die neue Verzögerung eingeben und erneut ablegen/abspeichern.

MediaInfo -> Ansicht -> Baumstruktur/Text oder MPC-HC -> Datei öffnen -> shift + f10 -> MediaInfo

Gruß Dimpel
 

ed_lumen

Commander
Ersteller dieses Themas
Dabei seit
März 2008
Beiträge
2.745
hab ich das richtig verstanden: in avidemux wegschneiden, was ich nicht brauch, gespeicherte datei wieder in a öffnen und den delay eingeben und unter neuem namen erneut speichern (bei gleichem namen versagt das programm)?

nun hab ich auch richtig geraten, daß mediainfo ein programm ist. das zeigt hier bei der ungeschnittenen datei -394 an. bei der geschnittenen datei zeigt er nichts dergleichen an.

ich öffne also die geschnittene erneut, gebe den bei der ungeschnittenen datei abgelesenen wert ein, speichere erneut, öffne in powerDVD und alles ist schlimmer als zuvor... :-(
 

TBMule

Lt. Commander
Dabei seit
Mai 2006
Beiträge
1.156
Das ist falsch was Dimpel gesagt hat, Du mußt schon VOR dem Schneiden den Delay-Wert der original Datei angeben, der mit dem Programm Media Info auszulesen ist.
also Schritt für Schritt:
1. Rechtsklick auf OriVideo Datei und aus dem Kontextmenu ->MediaInfo Eintrag raussuchen.
2. Format ermitteln (erster Screenshot) -> MPEG-PS in diesem Fall
3. Videoverzögerung ermitteln (2ter Screen) -> hier -104 ms
4. Orig. Video in AviDemux einladen, Frage "soll Index erstellt werden" mit ja beantworten
5. Auf Format MPEG-PS (A+V) stellen
6. Haken setzen bei DELAY
7. Videoverzögerung eintragen : hier -104 ms (siehe Screen 3)
8. Schneiden
9. Speichern unter Namen z.b. BSG-EDIT.vob (Endung nicht vergessen!)

Danach ist alles synchron und kann direkt auf Video-DVD gebrannt werden.
 

Anhänge

  • MPEG-Format-Angabe.jpg
    MPEG-Format-Angabe.jpg
    106 KB · Aufrufe: 996
  • MPEG-Format-Videodelay.jpg
    MPEG-Format-Videodelay.jpg
    34,8 KB · Aufrufe: 855
  • einstellungAVIdeMux.jpg
    einstellungAVIdeMux.jpg
    51,7 KB · Aufrufe: 755

ed_lumen

Commander
Ersteller dieses Themas
Dabei seit
März 2008
Beiträge
2.745
schön, danke. leider schreibst du nicht die konsequenz aus dem ermitteln des o-formats. hier liegt also bspw. ein .ts vor. ich ermittle: -394 delay. v+a auf copy, delay angelegt, speichere als mpg a+v. ergebnis: daneben. aber auch wenn ich den cut als .ts speichere: alles egal, nichts wird synchron :-(
 

TBMule

Lt. Commander
Dabei seit
Mai 2006
Beiträge
1.156
Ich habe keine Datei im mpeg-ts format vorliegen, sonst hätte ichs damit getestet. Ansonsten hier AviDeMux Forum nachfragen
 
Top