Excel 2010: Wenn, dann, und, sonst - Problem

DIDO666

Cadet 4th Year
Registriert
Jan. 2009
Beiträge
123
Hallo zusammen,

ich suche die korrekte Formel für folgendes in der Spalte B2 bis B20 sind die Noten von Schülern eingetragen im folgenden Format 1.0 bis 5.9 bzw. 6.0. In C2 bis C20 soll nun folgendes stehen, je nachdem welche Note der Schüler hat. 1.0 = Super! zw. 3 und 4 Kontrolle! größer 4 = Nachsitzen und sonst OK!

Danke für eure Hilfe!
 
Code:
=WENN(UND(A1>=1;A1<3);"Super!";WENN(UND(A1>=3;A1<4);"Kontrolle!";"Nachsitzen"))
Was heißt "und sonst ok"? Oben ist
  • 1 < x < 3 = Super!
  • 3 <= x < 4 = Kontrolle!
  • 4 <= x <= 6 = Nachsitzen
Meinst du damit 2 = Ok oder wie?
 
Verschachtelte WENN-Bedingungen...

Z.B: Es gibt nur 1.0 = Super und 3-4 = Kontrolle.

=WENN(B2=1; "Super!"; WENN(UND(B2>=3; B2<=4); "Kontrolle!"; "nix"))
 
Ich biete Folgendes:

=WENN(B2=1;"Super!";WENN(UND(B2>1;B2<3);"OK!";WENN(UND(B2>2,9;B2<4,1);"Kontrolle!";"Nachsitzen!")))

Wenn die Noten nicht nur 1, 2, 3 etc. sondern auch die Werte 1,1, 1,2 etc. haben können.
 
Vielen Dank für eure Anregungen.

Diese Übung ist eine klassische Aufgabe in der Abschlussprüfung der IHK in kaufmännischen Berufen.

Und die IHK akzeptiert nur eine, ihrer Meinung nach, richtige Lösung!

Werd ich also noch ein bissel tüfteln müssen.

@Tunguska: Deine Variante ist genau die, die ich brauchte. Vielen Dank.
 
Guten Tag,
ich komme gerade in Excel nicht weiter. Vielleicht kann mir jemand helfen.

Ich möchte eine Datei durch Wenn dann Funktionen "automatisieren".
Zunächst die Grundlagen:

Ich habe in Spalte B folgende Kategorien (1./2./3./Sonderpreis)
In Spalte C folgende Kriterien (Fuß/Kombi/Jugend)

Nun zu meinem Problem
Wenn in einer Zelle in Spalte B z.B. „1.“ Steht UND in Spalte C „Fuß“ dann soll diesem ein bestimmter Wert zugewiesen werden. Wenn allerdings zB. in Spalte B "1." steht UND in Spalte C "Kombi" dann sollte ein anderer Wert ausgegeben werden.
Bedeutet im Klartext:
1. Kombi = 250
2. Kombi = 200
3. Kombi = 150
Sonderpreis Kombi = 300

1. Fuß = 150
2. Fuß = 100
3. Fuß = 50
Sonderpreis Fuß= 200

usw.


Ich habe das ganze bereits mit der Kombination Fuß durchgespielt. Hier meine Formel:

=WENN(C3="Fuß";WENN(B3="1.";150;WENN(B3="2.";100;WENN(B3="3.";50;WENN(B3="Sonderpreis";200;)))

Jetzt will ich die gleichen Bedingungen anhänge falls in der Spalte C Kombi steht bzw. Jugend.

Vielen Danke im Voraus!
 
Ich würde keine Wenn Formel verschachteln, bau dir lieber ne kleine Datentabelle in Excel, dann gehts auch per SVERWEIS.

Siehe Beispiel:
 

Anhänge

  • Beispiel.xls
    24,5 KB · Aufrufe: 206
Zurück
Oben