Explorer stürzt durch Videovorschau ab - bei MPEG Dateien

Valkysas

Lt. Junior Grade
Dabei seit
Juni 2004
Beiträge
267
Hallo,

das Problem ist sicherlich bekannt: die Videovorschau im Explorer kann selbigen zum Absturz zwingen (ich dachte immer solche Fehler müssen abgefangen werden :rolleyes: MS halt)
Der Absturz passiert bei mir ca. bei der häfte aller MPEG1 Dateien...
Auch alle Videoabspielprogramme stürzen mit den Videos ab - bis auf den VLC Player.. der kann die Dateien - ohne zu murren - abspielen

normalerweise sollte man den/die Codecs Deinstallieren und einfach einen anderen/neuen Probieren... jedoch ist die MPEG Videounterstützung anscheinend nicht überauswechselbare Codecs implementiert... wie kann ich das MPEG System neu installieren?

Folgendes habe ich bereits ausprobiert:
-versch. Codecpacks (zB Nimo) installiert
-Windows MEdia Encoder installiert
-MPEG2 Software installiert (Pinnacle Studio, Power DVD) -

nix hilft bis jetzt

Danke für Eure Hilfe,

Valkysas
 

Enigma

Captain
Dabei seit
Apr. 2004
Beiträge
3.211
regsvr32 /u shmedia.dll (Schaltet Videovorschau aus)
 

davidbaumann

Commodore
Dabei seit
Aug. 2004
Beiträge
4.864
Das mit den Videocodecs wäre jetzt auch meine erste Idee gewesen...
Klingt vl komisch: DirectX auf dem aktuellen Stand?
Grafiktreiber? Die werden nämlich beide "beansprucht"

David

ot: VLC ist OpenSource, ausserdem verwendet er eigene Codecs und nicht die von Windows, aus dem Grund läuft er so gut, spielt (fast) jedes Format ohne manuelle installation des Codecs ab usw

*g* Post 500
 

Starsurfer

Lieutenant
Dabei seit
Mai 2003
Beiträge
646
Ich schließe mich dem Problem auch an. Bei mir paasiert das wenn ich im Browser ein Film abspielen will von ner I-net site etc. sobald ich draufklicke verursacht mein explorerne auslastung von 99,9%. Habe auch schon veruscht jegliche Codecs zu installieren. Das komische ist, wenn ich die mpg datein von Festplatte oder CD spiele das geht ohne Probleme nur über i-net nicht.
 

Valkysas

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2004
Beiträge
267
danke für den Ausschaltbefehl.. naja langsam fühl ich mich zu Win98 zurückversetzt.. hab die AutoExplorerVorschau der Bilder schon so deaktiviert, jetzt auch keine Videovorschau mehr.. dafür kann ich wieder besser arbeiten :)
Divx ist aufm neuesten Stand, Grakatreiber auch erst vor 2 Wochen aktualisiert

Gibts keine Möglichkeit neue MPEG1 Codecs einzuspielen?

Valkysas

PS: der VLC is wirklich gut.. nicht der schönste aber das is ja egal
 

herja

Commodore
Dabei seit
Mai 2004
Beiträge
4.113
Zitat von Valkysas:
Folgendes habe ich bereits ausprobiert:
-versch. Codecpacks (zB Nimo) installiert
-Windows MEdia Encoder installiert
-MPEG2 Software installiert (Pinnacle Studio, Power DVD) -

nix hilft bis jetzt
Hi,

so, wird das auch nie etwas werden!

Da du insbesondere versch. Codecpacks installiert hast, hast du jetzt einen Codeckonflickt der dein System abstürtzen lässt.
Du solltest alle Codecs aus deinem System entfernen und dann nur die Codecs aufspielen, die wirklich gebraucht werden.
In der SuFu kannst du das nachlesen.
Benutze mal GSpot, der kann dir zeigen welche/wieviele Codecs auf deinen Rechner installiert sind ... du wirst dich wundern ... :freak:
 

Valkysas

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2004
Beiträge
267
alle AVI Codecs arbeiten korrekt, da habe ich keine Probleme und die sind es ja normalerweise die solche Fehler verursachen und auch von den Codec Packs installiert werden;
Habe schon mit 2 Codec Sniffer Programmen die Dateien analysiert... es sind ganz normale MPEG Dateien die eigentlich jeder ohne Probleme abspielen sollte.. Codecs habe ich auch schon alle deinstalliert natürlich insbesonders vor dem installieren eines neuen Codecpacks;
 

herja

Commodore
Dabei seit
Mai 2004
Beiträge
4.113
wenn es so wäre, wie du sagst, gäbe es keine Probleme bei dir.
Es giebt keine "normalen MPEG-Dateien". Stelle fest, welche das genau sind. Ermittele den Codec dazu und deinstalliere ihn. Kontrolliere das Ganze mit GSpot.

Zitat von Valkysas:
Codecs habe ich auch schon alle deinstalliert natürlich insbesonders vor dem installieren eines neuen Codecpacks;
Das bezweifele ich sehr stark!
 
Zuletzt bearbeitet:

Valkysas

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2004
Beiträge
267
keine Ahnung warum Du das jetzt bezweifelst...
das Problem trat ja auf bevor ich die Codec Packs installiert habe..:rolleyes:

wie auch immmer nochmal alles deinstalliert.. trotzdem bleiben unter Codecs in der Systeuerung Einträge

dier Fehlerhafte Datei hat als Codec: MPEG1_Payload video codec and MPEG-1 Layer 2 audio codec
wie kann ich denn den MPEG Codec ersetzten/deinstallieren?
 

herja

Commodore
Dabei seit
Mai 2004
Beiträge
4.113
Zitat von Valkysas:
wie auch immmer nochmal alles deinstalliert.. trotzdem bleiben unter Codecs in der Systeuerung Einträge
genau deshalb meine Zweifel ...

Mit dem Entfernen aus der Systemsteuerung sind sie eben nicht immer deinstalliert. Es gibt eben für viele Codecs keine allgemein gültige Deinstallation. Das ist auch das Problem.

Am besten ist es, wenn du ein System-Image besitzt, welches du jetzt aufspielen kannst.
Wenn nicht, solltest du eine Systemneuinstallation ins Auge fassen. (Geht am schnellsten)

Wenn du das auch nicht möchtest, bist du gezwungen den Störenfried zu finden und das kann richtig Arbeit machen.

Installiere GSpot. Damit kannst du ermitteln welche Codecs auf deinem System (immer noch) installiert sind. Klicke auf System --> List Codecs... in dem folgenden kleinen Fenster werden deine Codecs gelistet. (rot=Problem) Unter Tables findest du weitere Infos zu deinen Codecs.
Jetzt solltest du alle Programme deininstallieren die diesen Codec mitbringen könnten: z.B. Brennprogramme, (Nero) Player, Videoprogramme, usw.

Das Ganze ist so lange durchzuführen bis du den Übeltäter erwischt hast ...
 

Valkysas

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2004
Beiträge
267
die GSpot Auflistung hab ich schonmal durchgeführt... alle roten Einträge waren "broken Links", also Einträge den kein Code gegenübersteht.. wie alte RegistryEinträge.. dürfte also im System nicht viel ausmachen.. werde trotzdem alle Einträge einzeln durchgehen

hab n Norton Ghost Image... hab aber irgendwie keine Lust auf das ganze Prozedere... hab auch noch ein 2. OS nebenher laufen aber ich würd einfach zugern das problematische Teil finden..
Hab mir auch mal den Direct Show Filter Manager runtergeladen.. muß sagen: Hammer Teil; Also wer auch noch ein Filter Problem hat kann mit dem Prog viel wieder gut machen - leider aber sein System auch komplett zerschiessen :D
 

herja

Commodore
Dabei seit
Mai 2004
Beiträge
4.113
naja, jeder wie er will ...

Dann würde ich Empfehlen die Registry mal zu säubern, dafür benutze ich "Registry First Aid"
Wenn du Glück hast ... liegt das Problem dort begraben ...
 

Valkysas

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2004
Beiträge
267
hab ich vorhin mit den Tune Up Utilities gemacht, schau mir aber auch mal Dein Prog an..
laut dem Direct Show Filter Prog haben5 Programme (u.a. SoundForge, Adobe Encore, Pinnacle Studio) alle einne MPEG1 Filter installiert...nach dem löschen hat sich zwar nix verändert aber vielleicht liegt ja da der Hund begraben
 

herja

Commodore
Dabei seit
Mai 2004
Beiträge
4.113
wäre nett von dir, wenn du mal kurz mitteilen würdest, ob und wie du das Problem gelöst hast.
 

Valkysas

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juni 2004
Beiträge
267
Kommando zurück... anscheinend hab ichs geschafft! Yeah.. alle Ordner lassen sich MIT Vorschau laden und zwar ohne abzustürzen... nach nem Neustart gings einfach!
Erkenntnis 1: Lösch lieber mehr Filter als weniger
Erkenntnis 2: obwohl ich alle Codec Packs und viele einzelne Codecs Deinstalliert hab kann ich immer noch alles anschauen... diese Packs braucht wirklich kaum jemand

für alle die das Problem hatten:

was muß man machen?

Stufe 1:
Gspot -> Video laden und Filter rausfinden
-> diesen Deinstallieren

wenn das nicht hilft
Stufe 2:
Alle Codecs Deinstallieren incl Packs etc
Registrysäuberung durchführen um Leerverweise loszuwerden

wenn das nicht hilft
Stufe 3:
den Direct Show Filter Manager runterladen (zB. von hxxp://www.softella.com/dsfm/index.en.htm)
Alle Codecs lassen sich hier Deregistrieren oder die Priorität ändern (!ACHTUNG!)
Bemerkung: Verschiedene Applikationen schaufeln zu gleichen Standarts verschiedene Codecs auf das System
Unbedingt zusätzlich unter Troubleshooting alle DirectX Filter zurücksetzten
Neustart

Ich mußte bis zur Stufe 3 gehen aber dann hats gekplatt

Danke nochmal an herja für die Hilfe

Valkysas
 
Top