Fehlerbehebung Explorerabstürze mit SearchApp.exe und KERNELBASE

Sebbi

Admiral
Registriert
März 2002
Beiträge
9.673
Hallo zusammen,

Anbei ein Lösung, wie man ohne Fehlermeldungen ohne spielereien in der Config via Powershell Systemapps reparieren kann:

Hintergrund in vielen Foren wird bei Abstürzen mit der folgenden Fehlermeldung im Ereignisslog

Name der fehlerhaften Anwendung: SearchApp.exe, Version: 10.0.19041.1620, Zeitstempel: 0x4ba4e375
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 10.0.19041.1645, Zeitstempel: 0x630193b4
Ausnahmecode: 0xc0000409
Fehleroffset: 0x000000000010b362
ID des fehlerhaften Prozesses: 0xb88
Startzeit der fehlerhaften Anwendung: 0x01d85f26107106e1
Pfad der fehlerhaften Anwendung: C:\WINDOWS\SystemApps\Microsoft.Windows.Search_cw5n1h2txyewy\SearchApp.exe
Pfad des fehlerhaften Moduls: C:\Windows\System32\KERNELBASE.dll
Berichtskennung: ff1f7b04-71fa-4eb3-8806-c74146219202
Vollständiger Name des fehlerhaften Pakets: Microsoft.Windows.Search_1.14.4.19041_neutral_neutral_cw5n1h2txyewy
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: CortanaUI


oder

Name der fehlerhaften Anwendung: Explorer.EXE, Version: 10.0.19041.1645, Zeitstempel: 0x7c06cc0e
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 10.0.19041.1645, Zeitstempel: 0x630193b4
Ausnahmecode: 0xc0000409
Fehleroffset: 0x000000000010b362
ID des fehlerhaften Prozesses: 0x28c4
Startzeit der fehlerhaften Anwendung: 0x01d854ef6c02caca
Pfad der fehlerhaften Anwendung: C:\Windows\Explorer.EXE
Pfad des fehlerhaften Moduls: C:\Windows\System32\KERNELBASE.dll
Berichtskennung: 47b3f998-35ac-443e-9d68-f9d082fc131a
Vollständiger Name des fehlerhaften Pakets:


empfohlen, die Systemapps mit folgenden Powershell Befehl in einer administrativen Powershell

Get-AppXPackage -AllUsers |Where-Object {$.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

€dit 01.09.2022
Aufgrund von Änderungen an Powershell neue Syntax nötig:


Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

€dit 04.09.2022

ok, scheinbar hat die Forensoftware seit dem Erstellen des Postes ein dezentes Problem mit dem Code bekommen hat (ich hatte den ersten Befehl damals extra verifiziert) das ganze nochmal als in Code Tags. Thanks @wd4107

Code:
Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "*SystemApps*"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}


zu korrigieren.

Dabei kommt es aber zu den folgenen Fehlermeldungen:

Code:
Add-AppxPackage : Fehler bei Bereitstellung. HRESULT: 0x80073D02, Das Paket konnte nicht installiert werden, da die     davon geänderten Ressourcen derzeit verwendet werden.                                                                   Fehler 0x80073D02: Installation nicht möglich, da die folgenden Apps geschlossen werden müssen:                         Microsoft.Windows.StartMenuExperienceHost_10.0.19041.1023_neutral_neutral_cw5n1h2txyewy.                                HINWEIS: Wenn Sie weitere Informationen wünschen, suchen Sie im Ereignisprotokoll nach [ActivityId]                     6095902f-54ef-0004-2122-ae60ef54d801, oder verwenden Sie die Befehlszeile Get-AppxLog -ActivityID                       6095902f-54ef-0004-2122-ae60ef54d801                                                                                    In Zeile:1 Zeichen:94                                                                                                   + ...  | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...                                         +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                                                 + CategoryInfo          : NotSpecified: (C:\Windows\Syst...ppXManifest.xml:String) [Add-AppxPackage], Exception         + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand             

Add-AppxPackage : Fehler bei Bereitstellung. HRESULT: 0x80073D02, Das Paket konnte nicht installiert werden, da die     davon geänderten Ressourcen derzeit verwendet werden.                                                                   Fehler 0x80073D02: Installation nicht möglich, da die folgenden Apps geschlossen werden müssen:                         Microsoft.Windows.ShellExperienceHost_10.0.19041.1320_neutral_neutral_cw5n1h2txyewy.                                    HINWEIS: Wenn Sie weitere Informationen wünschen, suchen Sie im Ereignisprotokoll nach [ActivityId]                     6095902f-54ef-0010-e94a-dc60ef54d801, oder verwenden Sie die Befehlszeile Get-AppxLog -ActivityID                       6095902f-54ef-0010-e94a-dc60ef54d801                                                                                    In Zeile:1 Zeichen:94                                                                                                   + ...  | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...                                         +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                                                 + CategoryInfo          : NotSpecified: (C:\Windows\Syst...ppXManifest.xml:String) [Add-AppxPackage], Exception         + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand             

Add-AppxPackage : Fehler bei Bereitstellung. HRESULT: 0x80073D02, Das Paket konnte nicht installiert werden, da die     davon geänderten Ressourcen derzeit verwendet werden.                                                                   Fehler 0x80073D02: Installation nicht möglich, da die folgenden Apps geschlossen werden müssen:                         MicrosoftWindows.Client.CBS_120.2212.4170.0_x64__cw5n1h2txyewy.                                                         HINWEIS: Wenn Sie weitere Informationen wünschen, suchen Sie im Ereignisprotokoll nach [ActivityId]                     6095902f-54ef-000d-7ab3-9560ef54d801, oder verwenden Sie die Befehlszeile Get-AppxLog -ActivityID                       6095902f-54ef-000d-7ab3-9560ef54d801                                                                                    In Zeile:1 Zeichen:94                                                                                                   + ...  | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...                                         +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                                                 + CategoryInfo          : NotSpecified: (C:\Windows\Syst...ppXManifest.xml:String) [Add-AppxPackage], Exception         + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand


da die Prozesse noch laufen.

Es wird hier dann empfohlen, in MS Config alle nicht notwendigen Dienste etc zu deaktivieren und nach einen Neustart des Rechners den Befehl erneut auszuführen.

siehe https://answers.microsoft.com/en-us...ll-error/7b6a225d-5ddf-45da-8297-ebdf1cce8d55

Dies ist aber sehr umfangreich und kann ggf vorher getroffene Einstellungen, wenn man bestimmte Dienste oder Programme nicht mit starten will, zerstören.

Es geht aber auch anders und das beschreibe ich euch hier:

Der Taskmanager ist hier keine große Hilfe, dafür aber der Prozess Explorer von Sysinternals.
Mit diesen lassen sich die Handles MicrosoftWindows.Client.CBS, Microsoft.Windows.StartMenuExperienceHost und Microsoft.Windows.ShellExperienceHost finden (Fernglassymbol)

Microsoft.Windows.StartMenuExperienceHost -> explorer.exe beenden, hier empfehle ich vorher den Taskmanager aufzurufen, damit ihr den damit dann wieder starten könnt über Daten -> Ausführen -> "explorer.exe"
MicrosoftWindows.Client.CBS -> TextInputHost.exe beenden
Microsoft.Windows.ShellExperienceHost -> dieser Thread ist etwas tricky, da er in 2 Threads auftritt. 1x ShellExperienceHost.exe. welcher beendet werden kann, 1x sihost.exe, der aktiv bleiben muss, da dieser die Verarbeitung händelt von der Bereitstellung.

Danach sollten die Apps korrigiert sein und zufällige Abstürze des Explorers nicht mehr auftreten. Den Explorer könnt ihr dann wie oben beschrieben wieder starten. Im gleichen Zuge werden auch die geschlossenen Threads wieder geöffnet.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Phrasendreher
Danke für Deinen Post.
Hint:
Auch im Process Explorer kann man schnell und einfach den Explorer und andere Tasks starten (killen/neu starten...)
1651873308967.png
 
  • Gefällt mir
Reaktionen: Sebbi
Hallo Sebbi
sehr interessante Anleitung oben.
Ich habe jeden Tag oder alle paar Tage (Windows 10 Pro 21H2, neuester Stand) das Problem:
"windows search stopped responding and was closed" im Zuverlässigkeitsverlauf.
Interessanterweise läuft Search danach weiter.

Deine Anleitung ist soweit klar, nur ein Punkt ist offen:
Muss hinter deinen Schritten der Befehl Get-AppXPackage -AllUsers ... noch ausgeführt werden, oder ist es mit den Schritten deiner Anleitung schon getan.
Ich vermute: Muss noch ausgeführt werden, bin mir aber nicht sicher.
 
wd4107 schrieb:
Muss hinter deinen Schritten der Befehl Get-AppXPackage -AllUsers ... noch ausgeführt werden, oder ist es mit den Schritten deiner Anleitung schon getan.

wenn du die Prozesse, die blockieren, beendet und den entsprechenden befehl noch einmal erfolgreich ausgeführt hast, sollte es damit getan sein.

Es müssen nur eben die Prozesse vorher beendet werden, wenn es zu Fehlermeldungen, wie ich auch geschildert habe, kommt. Dann muss der Befehl erneut ausgeführt werden, damit er seine Arbeit fehlerfrei durchführen kann.
 
Vielen Dank für die prompte Antwort.
In der Powershell mit Administrator-Rechten habe ich das "Get-AppXPackage -AllUsers ..." Kommando laufen lassen, zunächst einmal ohne Prozesse zu beenden:
Get-AppXPackage -AllUsers |Where-Object {$.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

Es kommen leider sehr viel gleiche Fehlermeldungen (alles rot) vom Typ:
$.InstallLocation : Die Benennung "$.InstallLocation" wurde nicht als Name eines Cmdlet, einer Funktion, einer
Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad
korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.
In Zeile:1 Zeichen:42
  • Get-AppXPackage -AllUsers |Where-Object {$.InstallLocation -like "Sys ...
  • ~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: ($.InstallLocation:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException


Eine Idee wäre prima
Ergänzung ()

Hier könnte das Problem liegen:
Get-ExecutionPolicy -List
Scope ExecutionPolicy
----- ---------------
MachinePolicy Undefined
UserPolicy Undefined
Process Undefined
CurrentUser Undefined
LocalMachine Undefined
 
Zuletzt bearbeitet:
Scope ExecutionPolicy geändert:
Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope LocalMachine
Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope CurrentUser
Ergänzung ()

PS C:\Windows\system32> Get-ExecutionPolicy -List
Scope ExecutionPolicy
----- ---------------
MachinePolicy Undefined
UserPolicy Undefined
Process Undefined
CurrentUser RemoteSigned
LocalMachine RemoteSigned
Ergänzung ()

Allerdings: Die Fehlermeldungen bleiben
 
Zuletzt bearbeitet:
wd4107 schrieb:
Es kommen leider sehr viel gleiche Fehlermeldungen (alles rot) vom Typ:
$.InstallLocation : Die Benennung "$.InstallLocation" wurde nicht als Name eines Cmdlet, einer Funktion, einer
Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad
korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.
In Zeile:1 Zeichen:42


die Syntax in der Powershell wurde anscheindend geändert, vorher funktionierte es ohne diese Änderung:

der Befehl lautet nun:

Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}


es ist wohl nun erforderlich, ein _ hinter dem $ Zeichen zu setzen wenn InstallLocation mit Werten genutzt wird
 
Zuletzt bearbeitet:
OK, vielen Dank für die Klarstellung!!!
Ich hatte in meinen Recherchen diese andere Variante auch gesehen, mich gewundert, habe sie aber nicht ernst genommen, weil sie wesentlich weniger vorkam als die andere.
Niemals sah ich eine Gegenüberstellung ALT NEU wie jetzt hier.
Das wird anderen auch sehr helfen.
Werde morgen testen.
 
Habe jetzt das Kommando wie folgt laufen lassen, zunächst ohne Dienste vorher zu beenden:

PowerShell als Administrator

Kommando:
Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

Dump der PowerShell Konsole:
Windows PowerShell
Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.

Lernen Sie das neue plattformübergreifende PowerShell kennen – https://aka.ms/pscore6

PS C:\Windows\system32> Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

PS C:\Windows\system32>

Ergebnis:
Keine Fehlermeldung
Keine Rückmeldung über erfolgreiche Ausführung.

Frage: Alles OK, trotz keiner positiven Rückmeldung?
 
wd4107 schrieb:
Frage: Alles OK, trotz keiner positiven Rückmeldung?

es sollte erfolgreich dann ausgeführt werden - aber beachte bitte einmal das Fehlerlog, ob die Fehler noch auftauchen.
 
Vielen Dank, klar Fehlerlog wird regelmäßig geprüft.
Bisher ist es gut. Jeden Tag kam der Fehler gegen 11:00, jetzt ist 13:00, alles gut
Ergänzung ()

Frage: Gibt es eine aktuelle Anleitung um den Windows 10 Store zurückzusetzen. Macht auf anderem Rechner Schwierigkeiten. Bordmittel helfen nicht.
 
Hallo @Sebbi
Der Fehler trat wieder auf:
"windows search stopped responding and was closed" im Zuverlässigkeitsverlauf.
Ergänzung ()

wd4107 schrieb:
Habe jetzt das Kommando wie folgt laufen lassen, zunächst ohne Dienste vorher zu beenden:

PowerShell als Administrator

Kommando:
Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

Dump der PowerShell Konsole:
Windows PowerShell
Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.

Lernen Sie das neue plattformübergreifende PowerShell kennen – https://aka.ms/pscore6

PS C:\Windows\system32> Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

PS C:\Windows\system32>

Ergebnis:
Keine Fehlermeldung
Keine Rückmeldung über erfolgreiche Ausführung.

Frage: Alles OK, trotz keiner positiven Rückmeldung?
!!!!!!!!! !!!!!!!!!
Das hatte leider keine Wirkung. Das Kommando schien in die Nirvana zu gehen
 
Ich habe weiter gesucht und ein drittes Kommando gefunden, das sich minimal von dem Letzten unterscheidet:

Get-AppXPackage -AllUsers |Where-Object {$.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}
Ergänzung ()

Dieses Kommando zeigt Wirkung.
Es laufen länger sehr viele Meldungen über die Konsole, man sieht es arbeiten.
Zu Schluss zeigt die Konsole dann Folgendes:

PS C:\> Get-AppXPackage -AllUsers |Where-Object {$.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

Add-AppxPackage : Fehler bei Bereitstellung. HRESULT: 0x80073D02, Das Paket konnte nicht installiert werden, da die
davon geänderten Ressourcen derzeit verwendet werden.
Fehler 0x80073D02: Installation nicht möglich, da die folgenden Apps geschlossen werden müssen:
MicrosoftWindows.Client.CBS_120.2212.3530.0_x64__cw5n1h2txyewy.
HINWEIS: Wenn Sie weitere Informationen wünschen, suchen Sie im Ereignisprotokoll nach [ActivityId]
1a0977f8-c02b-0000-239f-091a2bc0d801, oder verwenden Sie die Befehlszeile
Get-AppxLog -ActivityID 1a0977f8-c02b-0000-239f-091a2bc0d801
In Zeile:1 Zeichen:94


    • ... | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...
    • Code:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      + CategoryInfo  : NotSpecified: (C:\Windows\Syst...ppXManifest.xml:String) [Add-AppxPackage], Exception
      + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
      
      
      Add-AppxPackage : Fehler bei Bereitstellung. HRESULT: 0x80073D02, Das Paket konnte nicht installiert werden, da die
      davon geänderten Ressourcen derzeit verwendet werden.
      Fehler 0x80073D02: Installation nicht möglich, da die folgenden Apps geschlossen werden müssen:
      Microsoft.Windows.StartMenuExperienceHost_10.0.19041.1023_neutral_neutral_cw5n1h2txyewy.
      HINWEIS: Wenn Sie weitere Informationen wünschen, suchen Sie im Ereignisprotokoll nach [ActivityId]
      1a0977f8-c02b-0001-1da3-091a2bc0d801, oder verwenden Sie die Befehlszeile
      Get-AppxLog -ActivityID 1a0977f8-c02b-0001-1da3-091a2bc0d801
      In Zeile:1 Zeichen:94
      + ... | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...
      +   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (C:\Windows\Syst...ppXManifest.xml:String) [Add-AppxPackage], Exception
+ FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand


Add-AppxPackage : Fehler bei Bereitstellung. HRESULT: 0x80073D02, Das Paket konnte nicht installiert werden, da die
davon geänderten Ressourcen derzeit verwendet werden.
Fehler 0x80073D02: Installation nicht möglich, da die folgenden Apps geschlossen werden müssen:
Microsoft.Windows.ShellExperienceHost_10.0.19041.1023_neutral_neutral_cw5n1h2txyewy.
HINWEIS: Wenn Sie weitere Informationen wünschen, suchen Sie im Ereignisprotokoll nach [ActivityId]
1a0977f8-c02b-0001-44a3-091a2bc0d801, oder verwenden Sie die Befehlszeile
Get-AppxLog -ActivityID 1a0977f8-c02b-0001-44a3-091a2bc0d801
In Zeile:1 Zeichen:94


    • ... | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...
    • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (C:\Windows\Syst...ppXManifest.xml:String) [Add-AppxPackage], Exception
+ FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

PS C:\>
Ergänzung ()

Ich fasse meine 3 Versuche zusammen:

Erster Versuch, bringt jede Menge Fehlermeldungen, veraltet, wie @Sebbi sagt:
Get-AppXPackage -AllUsers |Where-Object {$.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

Zweiter Versuch, Kommando hier vom Thread von @ Sebbi, geht in die Nirwana, nichts passiert:
Get-AppXPackage -AllUsers |Where-Object {$_.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}

Dritter Versuch, im Web gefunden, die tut etwas, läuft offenbar:
Get-AppXPackage -AllUsers |Where-Object {$.InstallLocation -like "SystemApps"} | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($.InstallLocation)\AppXManifest.xml"}
Ergänzung ()

1662278941023.png

Ergänzung ()

Jetzt hat auch noch die Foren-Software ein Problem und verändert Kommandos!!!
Siehe Screenshot oben
Wenn andere Foren-Software das gleiche Problem hat, würde es das Durcheinander erklären!!!!!
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Sebbi
wd4107 schrieb:
Jetzt hat auch noch die Foren-Software ein Problem und verändert Kommandos!!!

Danke,

hab dies nun in CodeTags oben den funktionierenden Befehl noch einmal reineditiert

ich glaube hier hat die Software irgendwie nen Bug neu bekommen bzw verursacht ein Bugfix ein Anzeigeproblem und zeigt den nun Orginalbefehl, den ich gepostet hatte, nicht mehr korrekt an.

Denn ich hatte damals den Befehl extra nocheinmal verifiziert (sprich aus dem geposteten Betrag rauskopiert und in die PS eingefügt), da hatte alles funktioniert
 
Danke dir @Sebbi
Es ist erstaunlich, dass in einen IT-Forum Kommandos verändert werden. Echt krass.

Deine Version zeigt bei mir allerdings keinen Effekt. Geht in die Nirvana.
Ich werde jetzt einen Screenshot aller 3 Versionen posten:
Ergänzung ()

1662317038178.png

Ergänzung ()

Nur die letzte Version des Screenshot läuft bei mir unter Windows 10 Pro 21H2, neuester Stand
SystemApps ist nicht nur mit Anführungszeichen, sondern auch mit Sternen umschlossen. Scheint wichtig zu sein, zumindest für Windows 10 Pro 21H2, neuester Stand
 
Zuletzt bearbeitet:
wd4107 schrieb:
Deine Version zeigt bei mir allerdings keinen Effekt. Geht in die Nirvana.

hast du die aus dem Codefenster rauskopiert? denn die ist exakt die, die du auch als working bei dir im Screenshot hast.
 
Nein, ich habe zum finalen Test alle noch einmal aus dem Editor (Screenshot) kopiert und in der Powershell mit Administrator-Rechten laufen lassen.
Nur die Letzte läuft. Bei den anderen ist das Verhalten wie beschrieben.
Die zweite (von dir, @Sebbi) hat zwar den Underscore, aber nicht die Sterne. Offenbar ist beides wichtig: Underscore und Sterne, zumindest in meiner Windows Version 10 Pro 21H2
 
Zuletzt bearbeitet:
wd4107 schrieb:
Die zweite (von dir, @Sebbi) hat zwar den Underscore, aber nicht die Sterne. Offenbar ist beides wichtig: Underscore und Sterne, zumindest in meiner Windows Version 10 Pro 21H2

der ist nicht umsonst nun durchgesprichen ;) dafür ist nun der in der Codebox da, wo ich hoffe, das die nicht verändert wird.
 
Zurück
Oben