Frage, Notepad++ und Leerzeilen

Domi83

Commodore
Dabei seit
Feb. 2010
Beiträge
4.225
Hallo Leute, ich habe da mal eine kleine Frage an Euch.
Ich bin mir jetzt nicht sicher, ob das eher eine Frage für das Forum "Programmieren" wäre aber ich versuche es mal.

Ich verwende eigentlich schon seit ein paar Jahren den Editor Notepad++ und bin damit sehr zufrieden. Diesen verwende ich für HTML, CSS, PHP und JS, was auch sehr gut funktioniert. Jetzt kommt das aber... wenn ich meine Dateien via FlashFXP vom WebSpace herunter lade und dann im Editor öffne, kommt es manchmal vor das mir dieser alle Inhalte mit einer zusätzlichen Leerzeile anzeigt.

Das "Format Zeilenende" hat er mir dann auch in Macintosh geändert. Keine Ahnung ob es genau daran liegt, aber es stört mich schon das ich jedes mal wieder alle zusätzlichen Leerzeilen entfernen darf um wieder meinen Quellcode überblicken zu können. Habt Ihr das auch, oder ist Euch das auch schon einmal aufgefallen?

Ich versuche mal ein Beispiel zu zeigen...
Code:
<!DOCTYPE html>

<html>

 <head>

  <base href="">

  <meta charset="utf-8">

  <title></title>

  <meta name="description" content="">

  <meta name="keywords" content="">

  <meta name="robots" content="">
so sieht dann ganz gerne mal der Quellcode aus, wenn ich diesen öffne und das ist falsch.

Gruß, Domi
 

dreamy_betty

Lt. Commander
Dabei seit
Juni 2006
Beiträge
1.127
Nun, dass dies nur mit einigen Dateien passiert liegt ganz einfach daran, dass die Zeilenenden darin in einem anderen Format gespeichert wurden. Wenn du zur Bearbeitung ein Programm oder Skript auf dem Server verwendest, ist dies zweifelsohne der Übeltäter. Für die Zukunft kannst du dies ganz einfach ändern, indem du im Notepad++ Menü -> Bearbeiten -> Format Zeilenende -> Konvertiere zu ... auswählst. Nur als Anmerkung: der Editor sollte danach eigentlich wissen, dass dieselbe Datei immer im gewünschten Zeilenformat gespeichert wird.

Um die überflüssigen Zeilen aus deinem Dokument zu entfernen kannst du entweder das umfangreichere Text FX Plugin (im Bereich Text FX Edit) verwenden, oder du gehst im Menü auf -> Bearbeiten -> Zeilen -> remove empty lines. Dieser Befehl ist bestimmt schon eingedeutscht worden, in meiner älteren Notepad++ Version ist er aber noch in Englisch. Ich hoffe du verstehst trotzdem was gemeint ist.
 

SaxnPaule

Commodore
Dabei seit
Okt. 2010
Beiträge
4.272
Das liegt vermutlich am Transfer. Schau mal im FlashXP nach, ob es da eine Option wie "End-of-line characters" gibt. Hatte schon öfter das Problem, dass beim Dateitransfer Encodings oder Line Endings zermanscht wurden.
 

Domi83

Commodore
Ersteller dieses Themas
Dabei seit
Feb. 2010
Beiträge
4.225
Moin Ihr beiden... Was den Transfer angeht, kann man im FlashFXP folgendes wählen...
- Auto (Standard)
- Binary
- ASCII

verändert habe ich das nie und es steht immer auf Auto. Sowohl im Büro als auch Zuhause verwende ich Notepad++ und FlashFXP mit den exakt identischen Einstellungen, da beides als Portable-Version in meiner OwnCloud liegt. Es wundert mich halt nur immer wieder das ich diese Leerzeilen im Quellcode habe.

Ich mache die Zeilen immer wieder raus, bearbeite den Quellcode, lade die Datei hoch und alles funktioniert. Ich lade die Datei herunter und alles ist noch so wie vorher. Tage später, wenn ich die Datei dann noch einmal vom Server lade und den Quellcode öffne, ist er wieder mit Leerzeilen versehen :freak:

Im ganz normalen notepad ist allerdings alles ganz normal, dass hatte ich vorhin einfach einmal nachgeschaut. Ich muss sogar immer wieder darauf achten, dass meine Dateien UFT8 ohne BOM sind. Ganz oft sind die umgestellt worden in ANSII :rolleyes:

Gruß, Domi
 
Top