CSS IE7 hat falschen Abstand

krizzelfix

Commander
Dabei seit
Sep. 2005
Beiträge
2.626
Hallo zusammen,

ich bin garde dabei einen Bestellvorgang umzusetzen.
Nur der IE7 macht nicht das was ich will.
Wie im Screenshot zu sehen ist, ist um den Buttons für den nächsten Schritt ein roter Rand.
Habe es schon mit Browserweichen probiert hinzubekommen.

Dass sind die Styles die für die Buttons relevant sind:
HTML:
.separator {
	display: block;
	/*background-color: #E0DFE3;*/
	background-color: #ff0000;
	margin: 0 0 10px 0;
	line-height: 20px;
	padding: 0px;
}

.separator input {
	border: 0px;
	margin: 0px;
	display: block;
}
a.next_step, input.next_step, a.prev_step, input.prev_step {
	width: 160px;
	padding: 1px 5px;
	height: 20px;
	text-transform:uppercase;
	background-repeat: no-repeat;
	color: #fff;
}
//IE7 Weiche
*:first-child+html input.next_step, *:first-child+html input.prev_step {
	height: 20px;
	line-height: 20px;
}

.separator input.next_step {
	background-image: url('../images/shop/arrow_right.gif');
	background-position: right center;
	float: right;
	width: 180px;
	border-left: 20px #fff solid;
}
Bin für jede Hilfe dankbar.

Mit freundlichen Grüßen

krizzel
 

Anhänge

fullarockt

Cadet 1st Year
Dabei seit
Mai 2008
Beiträge
13
Mh spontan fällt mir da eigentlich nur {border:none} ein.schonmal damit getestet?:baby_alt:
 

krizzelfix

Commander
Ersteller dieses Themas
Dabei seit
Sep. 2005
Beiträge
2.626
Steht doch schon in der Klasse ".separator input".
Und ein Rand kann das ja auch nciht sein, da es die Hintergrundfrabe von dem separator ist. Würde also eher auf einen MArgin deuten, der aber auch schon auf 0 steht.

Grüße

krizzel
 

[o.0]

Lt. Commander
Dabei seit
Apr. 2008
Beiträge
1.037
HTML:
.separator {
	display: block;
	/*background-color: #E0DFE3;*/
	background-color: #ff0000;
	margin: 0 0 10px 0;
	line-height: 20px;
	padding: 0px;
}
Da das background-color, oder? Kommt ja auch nirgends anderst Rot vor :freak:
 

krizzelfix

Commander
Ersteller dieses Themas
Dabei seit
Sep. 2005
Beiträge
2.626
Richtig...habe das zu testen auf Rot gestellt damit ich meine Augen nicht so anstrengen muss.;)
Und sonst gibt es nur Weis, Blau und Grau töne auf der Seite.

//Edit: Hat niemand noch eine Idee, woran es liegen könnte?

//Edit2: Mir ist grade mal aufgefallen, das wenn icht mit der Maus über den Button fahre, verschwindet der rote rand.:confused_alt:

//Edit3: Habs gelöst. Wenn man um den Button einen Border in der Hintergrundfarbe macht, sieht es ganz akzeptabel aus.
 
Zuletzt bearbeitet:
Top