[JSF] Probleme bei integration in eclipse 3.6

Black_Panter

Ensign
Dabei seit
Mai 2006
Beiträge
197
Hi,

ich versuche gerade JavaServer Faces in eclipse zu integrieren.
Über Netbeans habe ich schon einen Glasfisch Server installiert, und diesen habe ich auch als Runtime Environmental eingebunden.
Jedoch wird der import javax.face nicht gefunden und ich find auch über google (oder ich such nach den falschen Begriffen) nichts brauchbares.
In den Anleiungen die ich finde, steht was davon, das in den "preferences" unter "Web und XML" (bei mir sind Web und XML 2 unterschiedliche Punkte) ein Eintrag JSF libarys sein soll. Dieser fehlt bei mir.
Über Install new Software find ich auch nichts, womit ich JSF nachinstallieren könnte.

Was muss ich tun, das sich der Nebel lichtet?

Grüße
Sören
 

Black_Panter

Ensign
Ersteller dieses Themas
Dabei seit
Mai 2006
Beiträge
197
Also ich habe jetzt ein "New Dynamic Web Project". Beim Punkt JSF Capabilities bekomm ich die Fehlermeldung "A least one user libary must be selected."
Im Typ Auswahlfeld habe ich "User Libary" und "Disable Libary Configuration".
Jedoch steht bei "User Libary" kein eintrag.
Rechts von dem Feld gibt es einen Button "Download libary". ANbieten tut er mir 2 mal JSF 2.0. Einmal von Apache myface JSF Core-2.0 API 2.0.2 und einmal Mojarra 2.0.3-FCS
Welche der beiden ist die richtige?
 
Top