Lässt sich unter Win8 der von Win7 bekannte Anmeldebildschirm wiederherstellen?

hering69

Cadet 4th Year
Dabei seit
Apr. 2004
Beiträge
120
Hallo, wir nutzen in unserer Familie ein Laptop mit mehreren lokalen Benutzerkonten.
Leider "merkt" sich Windows 8 immer den letzten Benutzer und wählt beim erneuten Start diesen automatisch aus. Ein Konto ohne Kennwort wird dann direkt gestartet. Wurde das Konto mit Kennwort versehen wird zunächst nur dieses angezeigt.
Ich möchte nun gerne bei jedem Neustart den Anmeldebildschirm mit der Benutzerwahl erhalten.
Weiß jemand wie ich dies erreichen kann???
Viele Grüße
Markus
 

Xedos99

Commander
Dabei seit
Aug. 2007
Beiträge
2.938
Na klar mit Easy BCD..:D(aktuell Ver. 2.2)Habs vorige Woche erst gemacht.
 

NiFu

Lt. Junior Grade
Dabei seit
März 2012
Beiträge
435
Leider "merkt" sich Windows 8 immer den letzten Benutzer und wählt beim erneuten Start diesen automatisch aus.
Hm, ist mir noch gar nicht aufgefallen. Aber du hast Recht - ist bei mir genauso. Ich meine mich zu erinnern, dass es bei der Release Preview noch funktioniert hat.

Als Tipp liest man überall:
Das Programm "netplwiz" starten und einen Haken rein machen bei:
"Benutzer müssen Benutzername und Kennwort eingeben".
Der Haken war bei mir schon drin. Und ob mit oder ohne Haken - Windows loggt sich immer automatisch mit dem zuletzt verwendeten Benutzer ein.

Dann gibt's noch den Tipp, dass man "secpol.msc" starten soll und dort unter
"Lokale Richtlinien -> Sicherheitsoptionen -> Interaktive Anmeldung: Letzten Benutzernamen nicht anzeigen -> aktivieren" soll.
Das funktioniert zwar. Aber dann erhält man immer einen Anmeldescreen ohne Benutzernamen und muss diesen immer manuell eintippen. Auch keine schöne Lösung.
 

hering69

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Apr. 2004
Beiträge
120
@NiFu, ja eben... für mich bieten zumindest diese Tipps keine annehmbare Lösung :grr:

@Xedos99, danke für Deine Hilfe - Wenn EasyBCD diese Option wirklich bietet, sollte das Ganze ja auch einfach per Registry-Eintrag funktionieren, oder?!
Wäre mir auf jeden Fall lieber, als irgendein unbekanntes Tool zu installieren!

***EDIT
Hab' EasyBCD eben mal installiert.
Das Programm ist ein Bootmanager und nicht sonderlich hilfreich bei o.a. Problematik!

Markus
Ergänzung ()

So, nachdem ich die registry ein wenig durchforstet habe, kann ich nun wenigstens einen Teilerfolg vermelden.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch]
"Enabled"=dword:00000000

Wenn man diesen Schlüssel auf 1 ändert erhält man beim nächsten Systemstart die Benutzer-Auswahl.
Leider wird der Wert beim Start automatisch wieder auf 0 zurückgesetzt. :grr:

Vielleicht hat jemand eine Idee wie sich dies verhindern lässt???
 
Zuletzt bearbeitet:

NiFu

Lt. Junior Grade
Dabei seit
März 2012
Beiträge
435
So, nachdem ich die registry ein wenig durchforstet habe, kann ich nun wenigstens einen Teilerfolg vermelden.
Code:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch]
 "Enabled"=dword:00000000
Wenn man diesen Schlüssel auf 1 ändert erhält man beim nächsten Systemstart die Benutzer-Auswahl.
OK - danke für das Auffinden des Schlüssels. Funktioniert jetzt bei mir ebenso wie bei dir. Damit kann man doch weitermachen.

Leider wird der Wert beim Start automatisch wieder auf 0 zurückgesetzt. :grr:
Vielleicht hat jemand eine Idee wie sich dies verhindern lässt???
Wenn man mit der rechten Maustaste auf "UserSwitch" und dann auf "Berechtigungen" klickt, dann sieht man, dass der Benutzer "System" die vollen Rechte an "UserSwitch" und deren Unterschlüssel besitzt.
  • Zuerst habe ich beim Benutzer "System" die Vererbung der Rechte aus übergeordneten Schlüsseln abgeschaltet.
  • Dann habe ich der Benutzergruppe "Administratoren" die Besitzrechte an diesem Schlüssel erteilt (war vorher der Benutzer "System") und ihr den "Vollzugriff" erlaubt.
  • Da aber wohl auch der Benutzer "System" zur Benutzergruppe der "Administratoren" gehört, habe ich dem Benutzer "System" die "Schreibrechte" explizit verweigert. Anmerkung: Wenn man dem Benutzer "System" den Vollzugriff verweigert, dann kann er beim Booten auch nicht lesend auf den Schlüssel "UserSwitch" zugreifen, hält damit den Wert für "0" ...






Damit habe ich es dann hinbekommen, dass der einmal eingestellte Wert "1" für "UserSwitch" -> "Enabled" nicht mehr von "System" verändert werden kann und dauerhaft erhalten bleibt.

Keine Ahnung, warum das so schwierig zu konfigurieren ist.
 

hering69

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Apr. 2004
Beiträge
120
@NiFu, vielen Dank für Deine Mühe und Deine detailierten Ausführungen! :schluck:

Das ist ja schon mal ein Ansatz!
Ein einfacher Registry-Eintrag oder eine Änderung mittels Gruppenrichtlinien-Editor würde ich persönlich noch besser finden!

Naja, vielleicht wird's ja noch... :rolleyes:
 

hering69

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Apr. 2004
Beiträge
120
OK, hab's nun auch so umgesetzt und bin recht zufrieden mit dieser Lösung!
Da ich mich mit Berechtigungen nicht auskenne, gebe ich den kompletten Vorgang mal mit meinen eigenen Worten wieder.

Also, ich habe zunächst mit dem Registry-Editor den Wert
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Logo nUI\UserSwitch] "Enabled"=dword:00000000 auf 1 geändert.
Anschließend habe ich die Vererbung der Rechte aus übergeordneten Schlüsseln abgeschaltet und die Rechte für diesen Container in lokale Berechtigungen umgewandelt.
Danach konnte ich unter erweiterte Sicherheitseinstellungen für den Benutzer "System" explicit "Wert festlegen" verweigert.
Weitere Veränderungen waren nicht notwendig!

@NiFu, vielen Dank noch mal für Deine Hilfe! :schluck:
 
Zuletzt bearbeitet:

Feuerferkel

Banned
Dabei seit
Juli 2008
Beiträge
2.611
Also momentan bin ich zu doof dafür. Ich behalte das hier im Auge und melde mich heute Abend nochmal...

Tja, nun ist es mir gelungen alles so einzustellen wie von NiFu erklärt aber leider keine Nutzerauswahl beim Start. Immer nur der zuletzt angemeldete wird angezeigt...
Ergänzung ()

Hmm, nun nach dem dritten Neustart funktioniert es.

Ich habe diesmal nur der Gruppe System keine Rechte entzogen. Der Rest ist wie gesagt NiFu "gleich".

snip.JPG
 
Zuletzt bearbeitet:

RechtsAussen

Newbie
Dabei seit
Dez. 2012
Beiträge
1
Bin absolut neu hier und habe euch nach tagelanger Suche endlich gefunden :)

@hering69 und @NiFu: Super Lösung, kurz, schmerzlos und leicht umzusetzen. Funzte auf Anhieb :daumen:

Beste Grüße
Ralle
 

JimPanse1984

Commander
Dabei seit
Jan. 2008
Beiträge
2.890
Das gleiche geht viel einfacher über gpedit.msc dank Gruppenrichtlinien, wie schon immer unter Windows ;)
 

A8NSLIDELUXE

Newbie
Dabei seit
Mai 2011
Beiträge
2
Ich habe ein ähnliches Problem. Ich habe meinen PC mal testweise an einem Homeserver angemeldet mittels einer unter WSE2012 erstellten Exe-Datei. Nun ist der PC wieder aus der Domäne entfernt. Wenn ich Win 8 starte, muss ich nun jedesmal meinen lokalen Benutzernamen eingeben. Ein Passwort habe ich nicht.

Wie kann ich einstellen, dass Windows 8 wieder automatisch mit meinem Benutzernamen anmeldet?
 

maxim23

Ensign
Dabei seit
Aug. 2006
Beiträge
184
möchte dasgleiche mit dem windows 10 pro machen, finde jedoch userswitch nicht. wo versteckt sie sich. google hilft auch nicht
 

maxim23

Ensign
Dabei seit
Aug. 2006
Beiträge
184
bei dieser lösung werden leider keine usernamen angezeigt, dieser müsste man selbst eintragen, was den vorgang verlängert
 
Zuletzt bearbeitet:
Top