MS Office 2000 (Excel): Negative Uhrzeiten?

2TAKTER

Lt. Junior Grade
Dabei seit
Okt. 2005
Beiträge
399
Hallo

Ich habe ein Exceltabelle mit drei Uhrzeiten im benutzerdefinierten Format hh:mm
Zelle A1: 08:40
Zelle A2: 00:20
Zelle A3: 01:00
Zelle A4: =SUMME(A1:A3) - dies ergibt dann richtiger Weise 10:00

Nun habe ich allerdings auch gelegentlich negative Uhrzeitwerte, welche allerdings von Excel als ungültig definiert werden.
Zum Beispiel:
Zelle A1: 08:40
Zelle A2: -00:20
Zelle A3: 01:00
Zelle A4: =SUMME(A1:A3)
Im Format hh:mm wird der Wert in der zweiten Zelle nicht angenommen. Im Textformat kann nicht damit gerechnet werden. So kommt entweder gar kein Ergebnis zu stande oder eben 09:40, was aber falsch ist.
Richtig wäre 09:20.

Kann mir jemand hierfür eine Lösung bringen?

Danke im Voraus
 

moquai

Banned
Dabei seit
Apr. 2004
Beiträge
16.762
Hallo,

geändert wegen der Lösung von metchrishw:

Die Hilfspalte ist zwar nicht nötig, aber wahrscheinlich einfacher für 2TAKTER.
Die einfachste Lösung: Umstellen auf das 1904 Datumsformat, sofern man den "Nachteil" verschmerzen kann.
 
Zuletzt bearbeitet:

netchrishw

Lt. Junior Grade
Dabei seit
Okt. 2006
Beiträge
311
Hallo,

das ist ein wenig lästig aber es funktioniert !

Negative Uhrzeit gibt es nicht bei Excel. Du mußt die Inhalte der Zellen in eine weitere Tabelle übertragen und dort die angegeben Zeiten im normalformat darstellen lassen ! Die positiven Zeiten läßt du, die negativen multiplizierst du mit -1.

In dieser Tabelle läßt du dann die Summern rechnen und überträgst das Ergebnis in die Grundtabelle !

Habe es gerade getestet ! Das funktioniert !

Ich hoffe ich konnte Dir helfen !:)
 

moquai

Banned
Dabei seit
Apr. 2004
Beiträge
16.762
Zuletzt bearbeitet:

2TAKTER

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Okt. 2005
Beiträge
399
gut ok das klappt jetzt erst mal... danke für eure hilfe :)
 
Top