nach 1511 Upgrade Drucken über Parallelport nicht möglich

dr_lupus_

Lieutenant
Registriert
Mai 2015
Beiträge
847
Nach dem upgrade auf Win 10 1511 (4711) liefen meine Drucker nicht mehr (u.a. Laserjet 4000 in Vollausbau). Da neuere Boards (aktuell Gigabyte Z97X-UD5H mit 4790K und 32 GB) keinen Parallelport mehr besitzen, waren zwei davon über eine LogiLink-Karte nachgerüstet worden. Die funktionierten auch einwandfrei, bis eben zu 1511. Gerätemanager sagte: Karte prima, Ports prima, alles Prima, aber alle Druckaufträge endeten mit der Fehlermeldung: Konnte nicht gedruckt werden. Nach zwei Stunden rumprobieren hatten wir "dSv". Wir haben dann auf einem älteren Rechner mit Parallelport auf dem Board (Sockel 775 Gigabyte EP35-DS4 Q9650) das gleiche Spiel erlebt: Gerätemanager sagt alle ist prima, aber jeder Druckjob endete mit "Konnte nicht gedruckt werden" (leider ohne weil ...). Den Kontakt mit dem LogiLink-Support hätten wir uns sparen können.

Funktioniert hat dann alles wieder, als wir ein Parallel auf USB-Kabel benutzt haben.

Hat noch jemand diese Erfahrung gemacht. Und gibt es eine Lösung, die wir übersehen haben? Denn irgendetwas müssen wir bei den Parallelports übersehen haben, denn mit dem Parallel-USB-Kabel funzt ja alles an jedem Rechner, den wir probiert haben.
 
Parallel-Port ist seit 1511 nicht mehr funktionsfähig - Lösung gibt es bisher keine und ob es wieder kommt kann nur MS sagen.
Echten Legacy Support gab es sowieso nur bis Vista SP2.
 
Ok alles klar, 1511 hat einen bug im Parallelport.

ABER, wie erfahre ich, ob der beseitigt wurde? Ich kann ja kaum alle 14 Tage probieren, ob sich MS entschlossen hat, da was zu tun ....
 
dr_lupus_ schrieb:
Ok alles klar, 1511 hat einen bug im Parallelport.

ABER, wie erfahre ich, ob der beseitigt wurde? Ich kann ja kaum alle 14 Tage probieren, ob sich MS entschlossen hat, da was zu tun ....

Ich glaube, hier kann ich Dich beruhigen.
Der Fehler wurde von Microsoft bewusst in den Treiber eingebaut, um die Leute mit sanftem Druck zum Kauf eines neuen Druckers oder zumindest eines Parallel-auf-USB-Adapters zu bewegen. Man kann also davon ausgehen, dass er in zukünftigen Updates nicht beseitigt wird.

Im Moment funktioniert noch folgender Workaround:

Im Geräte-Manager für den Drucker-Port (LPT1) Folgendes einstellen:
LPT_1.PNG
Alles speichern. Nach jedem Neustart von Windows 10 muss der Parallel-Port im Geräte-Manager deaktiviert und anschließend wieder aktiviert werden.
Wem das zu nervig ist, der kann sich das automatisieren.

1. DevCon.Exe (muss passen zum System, also entweder 32 bit oder 64 bit) herunterladen: https://msdn.microsoft.com/de-de/library/windows/hardware/ff544707(v=vs.85).aspx (ist Bestandteil des Windows SDK, dieses herunter laden und entpacken)
2. Ein Script mit folgendem Inhalt schreiben:
Code:
@echo off
cd /d %~dp0
devcon disable *PNP0401
timeout /t 1
devcon enable *PNP0401
3. Dieses Script zusammen mit passender DevCon.Exe in einem separaten Verzeichnis abspeichern (z.B. C:\printer
4. Eine geplante Aufgabe erstellen (kommandozeile mit Administratorrechten):
Code:
schtasks /create /tn "Fix Printer" /tr c:\printer\printer.cmd /sc BEIANMELDUNG /ru SYSTEM

Das ist seit einiger Zeit bei mir so im Einsatz und funktioniert einwandfrei. Wie oben gesagt, ist es jedoch Microsofts Ziel, die Unterstützung für "Legacy"-Schnittstellen (parallel und seriell) früher oder später ganz zu entfernen. Deshalb ist es möglich, dass dieser Workaround mit dem nächsten Windows-10-Update bereits nicht mehr funktioniert.

Ergänzung: Im Win-10-Forum (nicht zu verwechseln mit dem Windows-10-Forum ;) )wurde der Tipp gegeben, die automatische Konfiguration des Parallel-Ports auszuschalten und diesen manuell einzurichten:
LPT_2.PNG

Beste Grüße
DAC324
 
Zuletzt bearbeitet:
Zurück
Oben