NAS auf Debian 10 aufsetzten Datigruppenproblem

Status
Es sind keine weiteren Antworten möglich.

AMDHippster

Lt. Junior Grade
Dabei seit
Sep. 2015
Beiträge
440
Hallo zusammen,

ich habe samba auf einem PC mit dem neuesten Debian 64 Bit installiert. Ich habe folgende Konfiguration in der smb.conf:

[global]
workgroup = smb
security = user
map to guest = Bad Password

[homes]
comment = Home Directories
browsable = no
read only = no
create mode = 0750

[public]
path = /home/itazubi/Bilder
public = yes
writable = yes
comment = smb share
printable = no
guest ok = yes


Mein Problem ist:

  • Von einem anderen PC mit Ubuntu 20.04 wird über den Dateiexplorer das Netzlaufwerk gemountet
  • Anmeldung erfolgt als Anonymer Nutzer
  • Wenn ich eine Datei von dem Ubuntu Client auf das Netzlaufwerk lade zeigt nur dieser eine Gruppenzugehörigkeit an.

Debain Server:
vor chmod.png


nachchmod.png



Ubuntu Client:

client.png


Wieso werden Gruppen nur auf dem Client der auch die Datei hochgeladen hat korrekt angezeigt?
 

Sykehouse

Lt. Commander
Dabei seit
Aug. 2018
Beiträge
1.124
Welcher User und Group sollen denn auf dem Server verwendet werden? itazubi oder billgates?

Für ersteres kannst du z.B.
Code:
force user = itazubi
force group = itazubi
in die Samba Config des Shares aufnehmen.

Für zweiters muss der User halt auf dem Server existieren und sich auch als solcher anmelden.
 

kartoffelpü

Lt. Junior Grade
Dabei seit
Juni 2018
Beiträge
448
Zwar nichts zum eigentlichen Problem: Aber nutzt du nur Linux-Systeme? Dann würd ich eher mit NFS statt SMB arbeiten.
 

AMDHippster

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Sep. 2015
Beiträge
440
Welcher User und Group sollen denn auf dem Server verwendet werden? itazubi oder billgates?
Der Server soll nur als Dateiablage dienen. Der Nutzeraccount des Clients heißt eben billgates und beim Server itazubi. Ich habe mich jetzt auch mal nicht als annonymer Nutzer sondern als itazubi an der smb Freigabe angemeldet aber im Terminal des Clients wird immer noch billgates als Nutzer und Gruppe angezeigt. Ich habe da auch mal einen neuen leeren Ordner angelegt, der aber auf dem Server auch mit nogroup gelistet ist.

Aber nutzt du nur Linux-Systeme? Dann würd ich eher mit NFS statt SMB arbeiten.
Nein, das war jetzt erst ein Test unter Linux. Da sollen noch Windows Clients ran.


Ich habe jetzt auch die Zeilen in die smb.conf reingeschieben, jetzt werde ich gar nicht mehr nach einem Nutzer beim Verbindungsaufbau gefragt. Aber im Client steht dennoch immer billgates als Gruppe.
 

cgs

Lt. Junior Grade
Dabei seit
Juni 2020
Beiträge
290
Was ist das hier:
  • IT AZUBI
  • Bill Gates
Sollen wir Deine Arbeit machen?
 

snaxilian

Commodore
Dabei seit
Jan. 2016
Beiträge
4.764
Das riecht nach Hausaufgabe/Azubi-Aufgabe.
Wenn dir https://wiki.ubuntuusers.de/Samba/ und die dort verlinkten Seiten nicht weiter hilft wäre der erste und korrekteste Ansprechpartner dein Ausbilder. Aber auch dieser wird dir (hoffentlich) nicht die Lösung präsentieren sondern dir dabei helfen, dem Fehler auf die Spur zu kommen denn du sollst dabei ja etwas lernen.
 
Status
Es sind keine weiteren Antworten möglich.
Top