Netcologne Packetloss bei Gamestream

markuslanger25

Cadet 1st Year
Dabei seit
Mai 2021
Beiträge
12
Hallo

Ich wollte mal Fragen, ob weitere NetCologne Kunden über Packetloss Probleme klagen, denn ich kann zu keinem Gamestreamservice vernünftig Streamen, obwol ich per Kabel an meine Fritzbox 7530 angebunden bin und als einziger die Leitung benutzt.

Eigentlich ist meine Internetverbindung (VDSL 50Mbits Vertrag) auch in Ordnung, denn ich erhalte den vollen Durchsatz in jeglichen Speed Tests etc. und habe seit einem Jahr keine keine Verbindungsabbrüche gesehen. Die Latenzzeiten sind für VDSL auch extrem gut mit konstanten 9ms ping zu Google.

Jedoch kann ich einfach nicht vernünftig Gamestreamen, sei es Geforce Now (Nur 15mbits kommen an mit 5% Packetloss (Geforce Now Speedtest), PS Now oder auch die Verbindung zu meinen Gameservern (Azure, AWS, Paperspace) mit Parsec und Moonlight (Immer Packetloss). Außerdem muss ich immer die Bitraten reduzieren, damit der Packetloss minimiert wird, sprich so zwischen 10-20Mbits ist es meistens ok, alles darüber wird unertragbar (Lags, Packetloss etc.).

Es ist auch kein Betriebssystem oder Gerätefehler daran schuld, denn ich habe die selben Probleme mit meinem Smartphone und meiner Linux Maschine.

Außerdem habe ich schon den Netcologne Support angeschrieben, aber helfen können die mir nicht... (Bestimmt Routing / Peering Problem seitens NetCologne, anders kann ich mir das nicht erklären).

Ich hab natürlich auch bei meinen Nachbarn die Verbindungen getestet (Telekom und Vodafone Kunden) und siehe da, bei denen zeigt Geforce Now den Vollen Durchsatz an ohne Packetloss und auch die Verbindung zu meinen Gameservern läuft ohne Packetloss auf höchsten Bitrates ab... ich bin schon neidisch...

Was ich herausgefunden habe ist, dass wenn ich einen TCP VPN (Openvpn im TCP Tunnelmodus) benutzte, Geforce Now keinen Packetloss mehr anzeigt, dafür aber die Latenzen steigen und die Bandbreite auf 20-30Mbits (Anstatt 50Mbits) sinkt.
In der Praxis ist das Problem der Lags und des Packetlosses durch den TCP VPN zwar minimiert worden, jedoch nicht behoben, da gelegentlich die selben Probleme auftreten.

Zuletzt wollte ich auch noch wissen, ob auch nicht Netcologne Kunden Packetloss Probleme haben und wenn ja, bei welchem Anbieter ihr seid und ob ein TCP VPN bei euch Abhilfe schafft oder ob ihr das Problem irgendwie beheben konntet?

Grüße
Markus
 
Zitat von markuslanger25:
edoch kann ich einfach nicht vernünftig Gamestreamen, sei es Geforce Now (Nur 15mbits kommen an mit 5% Packetloss (Geforce Now Speedtest)
Ist immer und bei allen netcologne kunden so. Reproduzierbar.
Liegt soweit ich das debuggen konnte am Peering mit Telia - Ich habe ein Ticket auf, aber es passiert nichts.

Wie du schon bemerkt hast, geht es wenn du ein VPN nutzt. Jep, dann gehst du nicht den weg durchs netcologne netz zu nvidia, sindern direkt zum VPN endpoint und von da zu nvidia
 
  • Gefällt mir
Reaktionen: Engaged
Was sagt der Spiele Provider zu dem problematischen Peering mit Telia?
Gerade ein Spiele Provider sollte vernünftige Peerings haben.
 
Hier NetCologne Kunde, habe keinerlei Probleme oder paketloss auf meiner Leitung.
 
Ebenfalls NetCologne Kunde. Keine Probleme, weder heute, noch in der Vergangenheit.

MfG
 
Ebenfalls NetCologne (50769), hier läuft alles schon ewig ohne Highping, Paketloss, Disconnects etc.
 
Zitat von markuslanger25:
Die Latenzzeiten sind für VDSL auch extrem gut mit konstanten 9ms ping zu Google.
Dieser "Test" hat übrigens wenig Aussagekraft, wie bei jedem größeren Provider, stehen auch bei NetCologne Google Server in eigenem Netzwerk.
1621669034965.png

Zitat von markuslanger25:
oder auch die Verbindung zu meinen Gameservern (Azure, AWS, Paperspace) mit Parsec und Moonlight (Immer Packetloss).
Ich würde mal gerne wissen wie du das feststellst, hoffentlich nicht so.
1621669207327.png

Wenn auf der Strecke zum Ziel Pakete verworfen werden, ist das ein normales Verhalten diverser Router. Router sind zum routen da und nicht um Echo Anfragen zu beantworten und sobald sie genug zu tun haben, werden solche Anfragen verworfen. Entscheidend sind einzig die Antworten vom Zielsystem.
 
  • Gefällt mir
Reaktionen: WodkaGin und 0-8-15 User
GeForce Now kann ich nicht beurteilen, aber zu normalen Gameservern habe ich keinerlei Probleme via Netcologne. Hat da jemand evtl. einen Test oder eine IP Adresse die man mal tracerouten könnte? Also speziell Geforce now oder PS Now. Kann dazu nichts finden, was für mich schon aus diesem einzigen Grund gegen den Dienst spricht. Blizzard bietet genau dafür sogar ein Tool an, wäre schön wenn das alle mal hinkriegen würden...
 
So danke erstmal für alle Beiträge, ich hab noch einen Reddit Beitrag erstellt, der über das gleiche Thema handelt, hier findet ihr ihn falls Interesse besteht:

https://www.reddit.com/r/de_EDV/comments/ni5ylu/netcologne_packetloss_bei_gamestream/

Ich werde das ausprobieren, was dort vorgeschlagen wurde.


Zitat von madmax2010:
Ist immer und bei allen netcologne kunden so. Reproduzierbar.
Liegt soweit ich das debuggen konnte am Peering mit Telia - Ich habe ein Ticket auf, aber es passiert nichts.

Wie du schon bemerkt hast, geht es wenn du ein VPN nutzt. Jep, dann gehst du nicht den weg durchs netcologne netz zu nvidia, sindern direkt zum VPN endpoint und von da zu nvidia

Hmm das heißt, dass hier nur Netcologne Abhilfe schaffen kann? Und ja VPN hilft zwar, ist aber nicht besonders effektiv... Seit wann ist das Ticket bei dir am Stillstehen? Meines steht seit 220 Tagen unbeantwortet :D.



@luda @Graphixx @JJJT
Könnt ihr vielleicht mal einen Geforce Now Speed Test durchführen? Der zeigt meistens sehr genau an, ob es Packet Verlust bei UDP Packeten gibt oder nicht. Ein normaler Speed Test zeigt glaube ich nur ICMP Packet Verlust an, welcher bei mir auch nicht auftritt (Latenzen in Online spielen sind sehr stabil und Packet Verlust tritt beim Online Spielen nicht auf, nur Gamestreaming).



Zitat von xexex:
Dieser "Test" hat übrigens wenig Aussagekraft, wie bei jedem größeren Provider, stehen auch bei NetCologne Google Server in eigenem Netzwerk.
Anhang 1082851 betrachten

Ich würde mal gerne wissen wie du das feststellst, hoffentlich nicht so.
Anhang 1082852 betrachten
Wenn auf der Strecke zum Ziel Pakete verworfen werden, ist das ein normales Verhalten diverser Router. Router sind zum routen da und nicht um Echo Anfragen zu beantworten und sobald sie genug zu tun haben, werden solche Anfragen verworfen. Entscheidend sind einzig die Antworten vom Zielsystem.

Ich hatte im Letzen Jahr mit per Wireshark die IP Adresse eines Geforce Now servers in EU-Central 3 herausgefunden und einen Tracert versucht. Auf meinem Heimrechner kam es nach circa 20 Pings zu Packet Verlusten. Von meinem Gameserver aus (Azure) war dies aber nicht der Fall, da waren noch nach circa 200 Pings keine Packet Verluste zu sehen.

Hier mal die Screenshots, die ich dem NetCologne Kundensupport mitgegeben habe:
https://imgur.com/a/2zC3rfL


Außerdem habe ich per Parsec auf meinen Gamestream Server (Azure und auch AWS) extreme Netzwerkprobleme:

https://i.imgur.com/NROaPuch.jpg

der letzte Abschnitt mit dem N: steht für Netzwerkprobleme und Parsec beschreibt diese wie folgt:

N measures your network stats. The first number is how many slow retransmits have occurred during the stream. The second number is the number of fast retransmits. The third number is the number of congestion events. You want all of these numbers to be as close to 0 as possible. The slow retransmits and congestion events indicate serious connection issues.

If you see your retransmits rising and want to resolve the issue, you should ensure that both ends of the connection are reliably connected to the internet. This means connecting with ethernet on both ends where possible. Additionally, find the models of each of the routers on either end and look them up on wikidev , if either router has an Intel Puma chip in it, then you should look to replace it, as these chips do not handle intensive network tasks very well and often cause severe stream issues.

Die Probleme bestehen weiterhin.


Zitat von Snowi:
GeForce Now kann ich nicht beurteilen, aber zu normalen Gameservern habe ich keinerlei Probleme via Netcologne. Hat da jemand evtl. einen Test oder eine IP Adresse die man mal tracerouten könnte? Also speziell Geforce now oder PS Now. Kann dazu nichts finden, was für mich schon aus diesem einzigen Grund gegen den Dienst spricht. Blizzard bietet genau dafür sogar ein Tool an, wäre schön wenn das alle mal hinkriegen würden...

Wenn du eine Geforce Now session startest und Wireshark im Hintergrund laufen hast kannst du die IP Adresse des Gameservers herausfinden.

Ich habs mal per Browser funktion versucht und hier ist eine IP von einem EU-Central 3 Geforce Now Server:
1621712210833.png
 
Zuletzt bearbeitet:
Zitat von markuslanger25:
Wenn du eine Geforce Now session startest und Wireshark im Hintergrund laufen hast kannst du die IP Adresse des Gameservers herausfinden.
Dazu brauchst kein Wireshark, ein "netstat -nb" in einer Eingabeaufforderung mit Administratorberechtigungen reicht auch.

Mal eine andere Überlegung, hast du die genannten Probleme auch mit IPv6?
1621713421417.png
 
Zuletzt bearbeitet:
Oh ok, das wusste ich nicht. Danke für die Info!

IPv6 habe ich deaktiviert. Mit IPv6 habe ich auch keinen unterschied/Besserung gesehen.

Btw: Warum wird für Geforce Now der Port 443 verwendet? 443 verwendet doch nur TCP als Protokoll oder nicht?

PS: Ich hab hier einen MTR Test zu dem Geforce Now Server gemacht, hier ist der zu sehen:
https://imgur.com/a/LpGAm5g
 
Zuletzt bearbeitet:
Zitat von markuslanger25:
Btw: Warum wird für Geforce Now der Port 443 verwendet? 443 verwendet doch nur TCP als Protokoll oder nicht?
Jain. 443 ist normalerweise HTTPS, was nur via TCP läuft. Es wäre sehr unwahrscheinlich dass da was über UDP läuft, aber ggf. nutzen die auch ein eigenes Protokoll über Port 443. Kann ich nicht genau sagen.
Läuft wirklich die gesamte Kommunikation über Port 443, oder nur ein Teil? Wäre ein seltsames Konzept, sowas nur über TCP laufen zu lassen.

Zum Routing: Ich hab mal einen Traceroute auf die IP gemacht: Erst Hops über Netcologne, dann Megaport in Frankfurt, von da nach BelCloud in Bulgarien, dann zu Vivacom in Bulgarien, dann 2 Hops über Bulgarian Telecommunications Company Plc.und dann 2 Hops die Nvidia zugeordnet sind und in Sofia stehen.
Insgesamt ist das Routing soweit Ok, nicht gut, aber auch nicht super schlecht.

Packetloss zu der IP hatte ich allerdings gar nicht, habe mal ein paar Minuten einen Ping durchlaufen lassen. Klar, wenn da Last drauf ist verhält sich das anders, aber das kann ich leider nicht testen.

Zum Speedtest Screenshot vom ersten Beitrag fällt mir ein: Nimm mal einen anderen Zielserver als hotspot.koeln.
Ich unterstelle Netcologne nichts, aber Hotspot.Koeln gehört zu Netcologne, das Routing dorthin ist also was anderes als zu einem "externen Anbieter". MyLoc kannst du zB nehmen in Düsseldorf, die haben nichts direkt mit Netcologne zu tun und haben auch viele Gameserver von den ganzen Gameserver-Anbietern für CS, Minecraft & Co.
Aber auch da hab ich 0 Probleme. Also keine Ahnung woran es liegt, evtl. ist Sofia als Standort auch einfach nicht gut von DE aus, aber da kann ich leider nicht viel zu sagen...
 
Port 443 wird verwendet, weil der meist auf allen Firewalls freigeschaltet sein dürfte und GeForce NOW auch in einem Browser läuft. Es werden aber bei mir diverse IPv6 und IPv4 Adressen angesteuert, um zu schauen von welcher Adresse nun die Hauptlast kommt müsste ich wohl tatsächlich Wireshark anwerfen. Bringt bei mir aber eh wenig, da ich eine Vodafone Leitung nutze.

Wo die Server stehen, kann man hier sehen und aus dem Kölner Raum sind nur die drei relevant.
1621732631186.png

https://status.geforcenow.com/
 
Zuletzt bearbeitet:
Ich hab mal nen iperf und mtr test zu meinem Azure Gameserver gemacht und folgendes ist dabei rausgekommen:

Hier der Test zum Gameserver Azure:

mtr: https://imgur.com/a/7yMFogf

iperf Empfangen: https://imgur.com/a/2UnBKYZ

Bei iperf sieht man, dass bei unterschiedlichen Bitraten unterschiedlich hohe Packet Loss Werte angezeigt werden.

Das interessante dabei ist, dass wenn mein Client Daten sendet und den kompletten Upload ausreizt (10Mbits für meinen Tarif) es 0% Packet Loss gibt, dass heißt wohl, dass es wirklich nur beim empfangen (Download) zu Packet Loss kommt oder?

iperf Senden: https://imgur.com/a/UAy5jLU



Edit: Ich hab mal eine Linux VM erstellt und iperf Tests gemacht und da schaut es besser aus, aber es herrscht immer noch packet Loss, auch wenn es weniger ist:

iperf Empfangen: https://imgur.com/a/aWUAJpF

iperf Senden: https://imgur.com/a/wuHqtpd



Ich bräuchte mehr vergleiche mit NetCologne Kunden und einem Geforce Now Speed Test mit dem Servern von EU Central 3, damit ich das sammeln kann und eventuell dem NetCologne Kundensupport übergebe, wenn die Ergebnisse sich mit meinem überschneiden.
 
Ich verstehe dein Problem nicht! Du hast doch am Ziel keine Paketverluste und in beiden Fällen wird doch fast die volle Bandbreite geliefert.
1621767215111.png


Das nicht jeder Router deine Echo Anfragen interessieren und er sie schlichtweg ignoriert ist normal. Die Aufgabe eines Routers ist wie bereits gesagt, Pakete zu Routen und nicht deine Echo Anfragen zu beantworten.

Bei den "Paketverlusten" müsstest du prüfen ob sie auch bei TCP so auftreten, es könnte durchaus vom "Bandbreitenbegrenzer" kommen, weil bei 10Mbit/s sind praktisch keine Paketverluste mehr aufgetreten.
1621767492400.png


Alternativ stelle mal UDP 45MBit/s ein, wenn die Werte dann genauso wie bei der 10Mbit/s Messung aussehen, dann ist alles in Ordnung.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: brainDotExe
Ich verstehe das Problem ja auch nicht, deshalb der Beitrag :D

Fakt ist, dass ich keinen Game stream ohne Packet Loss betreiben kann.

Hier seht ihr mal, was ich meine mit Packetloss ingame etc.

https://imgur.com/a/gOtNc8T

Parsec und Moonlight habe ich auf 30Mbits beschränkt, da alles über 30Mbits extremen Packetloss verursacht und fast nix mehr möglich ist.

So sieht es bei mir in Geforce Now, Azure Gamestream und PS Now aus.. immer das gleiche. Aussetzer und Lags durch Packet Loss, den ich mir nicht erklären kann.

Wie gesagt, ich nutze das Internet komplett alleine und bin nur per Kabel verbunden (Keine WLAN Geräte eingeschaltet)

Hab schon meine Geräte in der Fritzbox Priorisiert aber nichts hat bis jetzt Verbesserungen gebracht.

Zitat von xexex:
Alternativ stelle mal UDP 45MBit/s ein, wenn die Werte dann genauso wie bei der 10Mbit/s Messung aussehen, dann ist alles in Ordnung.

Dann gibt's immer noch Packetloss, erst so bis 20 Mbits kommt Packetloss mit iperf nur noch selten vor, aber wenn ich Parsec und Moonlight auf 20Mbits stelle habe ich trotzdem hier und da mal Packetloss... Auch wenn es nicht so häufig ist wie mit 30Mbits




PS: Ich habe mal bei einem Kumpel nachgeschaut, welcher einen 50Mbits NetCologne Kabel Verbindung hat und siehe da, bei ihm gibt es kein Packet Loss. Er nutzt diese Route zu einem Gameserver in den US:

https://imgur.com/a/ia2f0QW

Vermutlich liegt der Grund an meinem Packet Loss an entweder der bras-vc4.netcologne.de [195.14.226.160] oder bdr-sto1-ae2.netcologne.de [81.173.192.118] Route, wenn Pakete empfangen werden sollen. Beim Versenden werden die noch richtig geroutet, nur beim empfangen kommt es zu Problemen. Anders kann ich es mir nicht vorstellen. Oder es liegt irgendein Problem in der Leitung vor, aber dazu sind meine Fritzboxwerte zu "gut".

https://imgur.com/a/fkxg5dF
 
Zuletzt bearbeitet:
Besteht dein Problem noch?
 
Zuletzt bearbeitet:
Zitat von xexex:
Dieser "Test" hat übrigens wenig Aussagekraft, wie bei jedem größeren Provider, stehen auch bei NetCologne Google Server in eigenem Netzwerk.
Das stimmt zwar, jedoch gehen Anfragen an die DNS-Server von Google am Global Cache (so schimpfen sich die Server im eigenen AS) vorbei direkt an Google. Das wurde uns so von Google selbst gesagt, wir haben auch solche Systeme im Einsatz.
 
Hier auch Netcologne-Kunde mit den gleichen Problemen.

Ausgangslage sind 100 MBit im Downstream, die sonst in allen anderen Anwendungsfällen auch ausgereizt werden können. Nur bei GeForce Now, so scheint es, gibt es derlei Schwierigkeiten.

1628269642585.png
 
Hallo, hast du das Problem lösen bzw. den Fehler herausgefunden. Habe exakt die gleichen Probleme mit meinem Provider hier in Österreich. Habe 100/20 Leitung und Geforce Now ist unspielbar.
 
Zurück
Top