PHP PHP Strict Standards errors finden?

lordfritte

Lieutenant
Dabei seit
Juli 2006
Beiträge
839
Hallo da wird bald mal endlich auf eine neue PHP Version umsteigen haben wir uns jetzt einen weiteren entwicklungsserver zum Testen aufgetzt.
Jetzt habe ich hier eine riese Liste von "PHP Strict Standards" errors und die Liste wird immer länger :D
Gibt eine Software Lösung welche mich beim finden dieser Fehler unterstützen kann?
 

Daaron

Fleet Admiral
Dabei seit
Dez. 2011
Beiträge
13.487
Eigentlich sollte eine gute IDE auch die Möglichkeit bieten, die PHP-Version zu definieren, gegen die der Code laufen soll.
 

[ChAoZ]

Captain
Dabei seit
Jan. 2010
Beiträge
4.071
Was empfielst du für eine IDE für PHP Entwicklung @ Daaron
Wir nutzen PHP Storm hier in der Firma, und privat natürlich auch.... nie wieder Zend Studio, nie wieder!!!^^
 

Blackbenji

Lieutenant
Dabei seit
Nov. 2009
Beiträge
553
kann ebenfalls nur phpstorm empfehlen. es gibt sogar die möglichkeit zur laufzeit zwischen einzelnen versionen zu schalten um Kompatibilität, etc zu testen. ebenfalls gibt es eine code analyse über das gesammte project

Bildschirmfoto 2014-02-17 um 20.42.19.jpg
 

Daaron

Fleet Admiral
Dabei seit
Dez. 2011
Beiträge
13.487
Ich nutz aus jahrelanger Gewohnheit Eclipse (mit Aptana-Plugin für FTP-Sync).
Ich wollte mal Netbeans testen, aber weder die Version aus den Ubuntu Repositories noch heruntergeladene Sources oder ein PPA wollten laufen. Schade eigentlich, angeblich kann Netbeans Code Refactoring für PHP, Eclipse scheitert da kläglich.

Eclipse hat seine Schwächen, aber... Macht der Gewohnheit.

Die meiste Zeit arbeite ich aber eh direkt via Shell mit VIM oder bestenfalls Geany. Viele meiner Aufgaben laufen darauf hinaus, kleine Scripte zu modifizieren.
 
Top