VLC gehorcht mkv-Untertitel-Flags nicht

mr hyde

Lieutenant
Dabei seit
Okt. 2012
Beiträge
815
Hallo.

Seit einigen Monaten treibt mich ein Problem um.

Gegeben sei eine beliebige Videodatei im matroska Container. Im mkv Container enthalten seien mindestens zwei Untertitelspuren.
Ich möchte, dass beide Untertitelspuren das "forced" Flag tragen, also auf jeden Fall abgespielt werden. Eine davon soll Priorität haben, die andere als Fallback dienen.
Ich setze
Spur 1: default JA, forced JA
Spur 2: default NEIN, forced JA
(eine evtl. 3. Spur würde zB zweimal NEIN haben, und in jedem Fall manuell ausgewählt werden müssen...)
Sprache ist bei allen Spuren gleich (Deutsch).

VLC (relativ frische, brandaktuelle Installation auf neuem Win10 System) spielt nun grundsätzlich (!) die LETZTE(!) Spur, die ein "forced" flag trägt, in diesem Fall also die 2. Spur. Das default flag der 1. Spur wird ignoriert.
Ich bin mir ziemlich sicher, dass das in früheren Versionen anders war, und dass das aktuelle Verhalten den Matroska Spezifikationen widerspricht.

Kodi hingegen hält sich an den Matroska Standard und spielt brav Spur 1.

Frage: Wie kann ich VLC beibringen, standardmäßig Spur 1 zu spielen (und sich an das default flag zu halten)?

In google finde ich nichts zu meinem Problem, und auch in den Experteneinstellungen von VLC habe ich nix gefunden.

edit: Ich nutze mkvtoolnix zum Setzen der flags.

edit: aus der Ausgabe von "mkvtoolnix / mkvpropedit":
'Anzeige Erzwungen'-Flag: Gesetzt, falls der
| | Track beim Abspielen benutzt werden MUSS. Für
| | jeden Tracktyp (Audio, Video oder Untertitel)
| | kann es mehrere erzwungene Tracks geben. Das
| | Abspielprogramm sollte denjenigen auswählen,
| | dessen Sprache mit den Benutzereinstellungen
| | übereinstimmt, oder der sowohl das 'Standard'
| | als auch das 'erzwungen'-Flag gesetzt hat.
 
Zuletzt bearbeitet:

mr hyde

Lieutenant
Ersteller dieses Themas
Dabei seit
Okt. 2012
Beiträge
815
MPC spielt Spur 1 ab. Das bestätigt meine Annahme, dass VLC sich hier nicht konform verhält.

Ist das ein bekannter VLC Bug? Oder kann man das in den Einstellungen irgendwie ändern?

edit: Mein aktueller workaround ist, dass ich Spur 2 auch auf NEIN/NEIN setze. Nachteil: Wenn Spur 1 zB von einem Wohnzimmer - Player nicht unterstützt wird, müsste ich Spur 2 manuell auswählen.
Andere Alternative, am PC statt VLC MPC zu verwenden, befriedigt mich auch nur partiell ;)
 
Zuletzt bearbeitet:
Top