Wordpress Seite zu langsam ;-(

croxxx69

Lt. Junior Grade
Registriert
Sep. 2007
Beiträge
352
Hallo,

gibt es hier einen der weiss wie man meine Seite etwas schneller machen kann?
Leider schaffe ich es nicht die Seite etwas aufzupeppen.
Was meint ihr? Wo sieht ihr die Probleme?
Kann mir hier einer helfen?
Hier mal alle Infos:


`
### wp-core ###

version: 5.7.2
site_language: hr
user_language: hr
timezone: Europe/Zagreb
permalink: /%year%/%monthnum%/%day%/%postname%/
https_status: true
multisite: false
user_registration: 0
blog_public: 1
default_comment_status: open
environment_type: production
user_count: 1319
dotorg_communication: true

### wp-paths-sizes ###

wordpress_path: /var/www/vhosts/hosting119150.a2fa9.netcup.net/httpdocs
wordpress_size: 884,20 MB (927151561 bytes)
uploads_path: /var/www/vhosts/hosting119150.a2fa9.netcup.net/httpdocs/wp-content/uploads
uploads_size: 1,78 GB (1906064348 bytes)
themes_path: /var/www/vhosts/hosting119150.a2fa9.netcup.net/httpdocs/wp-content/themes
themes_size: 29,92 MB (31375224 bytes)
plugins_path: /var/www/vhosts/hosting119150.a2fa9.netcup.net/httpdocs/wp-content/plugins
plugins_size: 149,21 MB (156459040 bytes)
database_size: 325,06 MB (340852076 bytes)
total_size: 3,13 GB (3361902249 bytes)

### wp-dropins (1) ###

maintenance.php: true

### wp-active-theme ###

name: Astra (astra)
version: 3.4.8
author: Brainstorm Force
author_website: https://wpastra.com/about/
parent_theme: none
theme_features: core-block-patterns, astra_hooks, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, amp, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets, menus
theme_path: /var/www/vhosts/hosting119150.a2fa9.netcup.net/httpdocs/wp-content/themes/astra

### wp-themes-inactive (3) ###

Storefront: version: 3.7.0, author: Automattic
Twenty Twenty: version: 1.7, author: WordPress tim
Twenty Twenty-One: version: 1.3, author: WordPress tim

### wp-mu-plugins (1) ###

WP Migrate DB Compatibility: version: 1.2, author: Delicious Brains

### wp-plugins-active (22) ###

Advanced Order Export For WooCommerce: version: 3.1.8, author: AlgolPlus
Asset CleanUp: Page Speed Booster: version: 1.3.7.9, author: Gabe Livan
Autoptimize: version: 2.8.4, author: Frank Goossens (futtta)
Checkout Field Editor for WooCommerce: version: 1.4.8, author: ThemeHigh
Contact Form 7: version: 5.4.1, author: Takayuki Miyoshi
Croatian payment slip generator for WooCommerce: version: 1.6, author: Marinela Levak
Elementor: version: 3.2.4, author: Elementor.com
Facebook for WooCommerce: version: 2.5.1, author: Facebook
FiboSearch - AJAX Search for WooCommerce: version: 1.11.0, author: FiboSearch Team
Google Tag Manager for Wordpress: version: 1.13.1, author: Thomas Geiger
Limit Login Attempts: version: 1.7.1, author: Johan Eenfeldt
MX Woocommerce HRK currency + PayPal: version: 1.1, author: Media X
Starter Templates: version: 2.6.11, author: Brainstorm Force
WooCommerce: version: 5.3.0, author: Automattic
WooCommerce - All in One SEO Pack: version: 1.3.4, author: Visser Labs
WooCommerce Cart Abandonment Recovery: version: 1.2.12, author: CartFlows Inc
WooCommerce Customizer: version: 2.7.4, author: SkyVerge
WPForms Lite: version: 1.6.7, author: WPForms
WP Mail SMTP: version: 2.8.0, author: WPForms
WPS Hide Login: version: 1.8.5, author: WPServeur, NicolasKulka, wpformation
YITH WooCommerce Wishlist: version: 3.0.22, author: YITH
Yoast SEO: version: 16.4, author: Team Yoast

### wp-plugins-inactive (9) ###

a3 Lazy Load: version: 2.4.5, author: a3rev Software
Antispam Bee: version: 2.9.4, author: pluginkollektiv
CartFlows: version: 1.6.14, author: CartFlows Inc
Gutentor - Gutenberg Blocks - Page Builder for Gutenberg Editor: version: 3.1.0, author: Gutentor
Query Monitor: version: 3.7.1, author: John Blackbourn
Storefront Product Sharing: version: 1.0.6, author: WooCommerce
Storefront Sticky Add to Cart: version: 1.1.9, author: WooThemes
WP-Optimize - Clean, Compress, Cache: version: 3.1.9, author: David Anderson, Ruhani Rabin, Team Updraft
WP-Sweep: version: 1.1.3, author: Lester 'GaMerZ' Chan

### wp-media ###

image_editor: WP_Image_Editor_Imagick
imagick_module_version: 1687
imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
file_uploads: File uploads is turned off
post_max_size: 128M
upload_max_filesize: 128M
max_effective_size: 128 MB
max_file_uploads: 20
imagick_limits:
imagick::RESOURCETYPE_AREA: 122 MB
imagick::RESOURCETYPE_DISK: 1073741824
imagick::RESOURCETYPE_FILE: 393216
imagick::RESOURCETYPE_MAP: 512 MB
imagick::RESOURCETYPE_MEMORY: 256 MB
imagick::RESOURCETYPE_THREAD: 16
gd_version: bundled (2.1.0 compatible)
ghostscript_version: 9.26

### wp-server ###

server_architecture: Linux 4.9.0-12-amd64 x86_64
httpd_software: Apache
php_version: 7.4.18 64bit
php_sapi: cgi-fcgi
max_input_variables: 4000
time_limit: 180
memory_limit: 512M
max_input_time: 60
upload_max_filesize: 128M
php_post_max_size: 128M
curl_version: 7.52.1 OpenSSL/1.0.2u
suhosin: false
imagick_availability: true
pretty_permalinks: true
htaccess_extra_rules: true

### wp-database ###

extension: mysqli
server_version: 5.7.33
client_version: mysqlnd 7.4.18

### wp-constants ###

WP_HOME: undefined
WP_SITEURL: undefined
WP_CONTENT_DIR: /var/www/vhosts/hosting119150.a2fa9.netcup.net/httpdocs/wp-content
WP_PLUGIN_DIR: /var/www/vhosts/hosting119150.a2fa9.netcup.net/httpdocs/wp-content/plugins
WP_MEMORY_LIMIT: 40M
WP_MAX_MEMORY_LIMIT: 512M
WP_DEBUG: false
WP_DEBUG_DISPLAY: true
WP_DEBUG_LOG: false
SCRIPT_DEBUG: false
WP_CACHE: false
CONCATENATE_SCRIPTS: undefined
COMPRESS_SCRIPTS: undefined
COMPRESS_CSS: undefined
WP_LOCAL_DEV: undefined
DB_CHARSET: utf8
DB_COLLATE: undefined

### wp-filesystem ###

wordpress: writable
wp-content: writable
uploads: writable
plugins: writable
themes: writable
mu-plugins: writable

### wpforms ###

version: 1.6.7
lite: sij 12, 2021 @ 1:16am
upload_dir: Writable
db_tables: wp_wpforms_tasks_meta
total_forms: 1
total_submissions: undefined

### wp_mail_smtp ###

version: 2.8.0
license_key_type: lite
debug: No debug notices found.
db_tables: wp_wpmailsmtp_tasks_meta

`
 
Du könntest ein Cache Plugin installieren.

Du hostest bei NetCup, richtig? Ein normales Webspace Paket?
 
Hi,

vernünftiges Caching aktivieren (AutOptimize, W3Total Cache), Bilder entsprechend anpassen (compressor.io), Inhalt richtig setzen. Wenn du einen Link posten würdest könnte man auch konkret was sagen. Seite Analysieren mit PageSpeed, GTMetrix und Pingdom hilft die Lücken zu finden.

VG,
Mad

Edit: ist es die Seite? https://jeftini-top-proizvodi.com/
 
  • Gefällt mir
Reaktionen: M-X
Viele Plugins. Vor allem die nicht aktiven davon mal löschen. Beim Rest schauen, was wirklich gebraucht wird. Je mehr man eine WordPress-Seite mit Plugins aufbläht, desto langsamer wird die sowieso nicht schnellste Software.

Wieviel RAM hängt dahinter? WordPress sollte ein bisschen was "unterm Arsch" haben, damit es flüssig läuft.

Madman1209 schrieb:
Wenn du einen Link posten würdest
Ist ersichtlich: https://jeftini-top-proizvodi.com/
 
  • Gefällt mir
Reaktionen: madmax2010
Hi,

  • GZip nicht aktiviert
  • Server Antwortzeit zu langsam
  • zwei Facebook JS Files, die u.U. lange laden könnten
  • Google Fonts lokal laden
  • Expires Header setzen
  • bei Netcup mindestens das 2000er Paket, damit 4GB RAM garantiert sind

usw usf...


erstens eben nicht direkt ersichtlich und zweitens hab ich den Link oben auch schon gepostet...

VG,
Mad

Edit: die Server Antwortzeit ist viel zu hoch, schreib den Netcup Support doch bitte mal an, da passt etwas nicht
 
Hallo, erstmal vieeeeelen Dank für die ersten Tipps.
Ja, das ist die Seite.
Ehrlich gesagt habe ich irgendwie immer bisschen Sorge um die Seite, sie war auch nicht am Anfang so super schnell, naja, darum glaube ich das nicht die Plugins das Problem sind aber werde mal schauen ob ich welche deaktivieren kann.

  • Google Fonts lokal laden: ok, werde ich mal machen, werde mal googeln wie man das macht.
  • Expires Header setzen - weiss ich auch nicht wie man das macht, also google ich mal
  • Benutze Autooptimize mit der Option Lazy-load images

Ergänzung ()

Madman1209 schrieb:
Edit: die Server Antwortzeit ist viel zu hoch, schreib den Netcup Support doch bitte mal an, da passt etwas nicht
Leider hatte ich das schon mal... sie meinten es ist alles paletti bei denen.
 
Hi,

  • AutOptimize und W3Total Cache müssen richtig konfiguriert werden
  • Laut Test mit Pingdom und GTMetrix ist GZip nicht aktiv, kann aber auch ein Fehler sein
  • Google Fonts: Plugin "OMGF"
  • Serverantwortzeit! Wichtig! Das sind stellenweise 3.8 Sekunden, das ist viel, viel zu langsam! Mit dem Support sprechen, da ist was faul! Bei mir konnte der Support das innerhalb von 10 Minuten erledigen.

VG,
Mad
 
Hi,

Skript- oder Google-Blocker aktiv? Bei mir und auch bei den Tests werden diese einwandfrei geladen. Ist wohl "Lato".

VG,
Mad
 
Madman1209 schrieb:
Serverantwortzeit! Wichtig! Das sind stellenweise 3.8 Sekunden, das ist viel, viel zu langsam! Mit dem Support sprechen, da ist was faul!
der TLS handshake ist bei mir super Flink, der webserver selbst cheint die bremse zu sein.

Madman1209 schrieb:
Skript- oder Google-Blocker aktiv? Bei mir und auch bei den Tests werden diese einwandfrei geladen.
Sind deaktiviert. Im Privaten Fesnter habe ich das verhalten auch






Wie viele Leute besuchen die Seite so im schnitt?
Von aussen fuehlt sich das so an, als ob da ein Webserver vor steht, der nicht genuegend verbindungen auf machen darf
 
HTTP:
{
    "GET": {
        "scheme": "https",
        "host": "jeftini-top-proizvodi.com",
        "filename": "/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.woff2",
        "query": {
            "5.10.0": ""
        }
    }
}

{
    "GET": {
        "scheme": "https",
        "host": "jeftini-top-proizvodi.com",
        "filename": "/wp-content/plugins/woocommerce/assets/fonts/star.woff"
    }
}

fuer die beiden bekomme ich nur NS_BINDING_ABORTED.

Klingt fuer mich noch mehr danach, als ob da was am Webserver krumm ist.

Ich stolpere da gerade zum 1. mal drueber, scheint vor allem Im firefox aufzutreten, wenn der Webserver keine expiry header mit schickt


@Madman1209 aktuell habe ich eine ladezeit von 9 sekunden. Sei lieb zu dem Server :D
Ergänzung ()

ehhhh. gelegentlich geht der request zu den Fonts durch. Im Chrome gehen sie immer durch :)
Ergänzung ()

Madman1209 schrieb:
von welcher Seite sprechen wir?
Ja. Hast recht :)
 
Zuletzt bearbeitet:
Madman1209 schrieb:
Hi,

  • AutOptimize und W3Total Cache müssen richtig konfiguriert werden
  • Laut Test mit Pingdom und GTMetrix ist GZip nicht aktiv, kann aber auch ein Fehler sein
  • Google Fonts: Plugin "OMGF"
  • Serverantwortzeit! Wichtig! Das sind stellenweise 3.8 Sekunden, das ist viel, viel zu langsam! Mit dem Support sprechen, da ist was faul! Bei mir konnte der Support das innerhalb von 10 Minuten erledigen.

VG,
Mad
  • GZip ist wohl aktiv.
  • Google Fonts: Plugin "OMGF" installiert und so gespeichert. Muss das Plugin die ganze Zeit installiert sein oder kann ich es wieder löschen?
  • Also dann werde ich noch netcup kontaktieren, glaube die hatten mir mal geschrieben das wohl das Problem woanders da ist, glaube die hatten eine php.info auf dem Server getan und meinten wenn man die auf meinem Server aufruft, sind schnelle Reaktionszeiten, also das Problem liegt nicht am Server... Versuche es nochmal

- AutOptimize und W3Total Cache müssen richtig konfiguriert werden
Hmmm... und wie weiss ich ob ich Autooptimize gut konfiguriert habe?
 

Anhänge

  • Slika zaslona 2021-06-08 u 00.32.24.png
    Slika zaslona 2021-06-08 u 00.32.24.png
    318,6 KB · Aufrufe: 267
Hallo, die Antwort vom Hoster:
  • "Ein großer Faktor, welcher hier Verzögerungen verursachen kann, ist die Interpretierung Ihres PHP Skriptes, sollten Sie eines nutzen"
  • "Um die tatsächliche Serverantwortzeit zu messen, wiederholen Sie Ihre Tests bitte mit einer HTML Datei, welche auch als solche ausgeliefert wird. Da hierbei keine Skripte verarbeitet werden müssen, kann der Server diese direkt ausliefern und Sie erhalten die tatsächliche Antwortzeit."
  • "Wenn sich diese in einem Bereich befindet, mit welchem Sie zufrieden sind, so müssten Sie Ihre PHP Skripte optimieren. Möglichkeiten wären hier z. B. das Aktivieren von Caching, oder das Reduzieren von Coderedundanz (falls vorhanden), etc."


Also wenn ich die info.php bei mir aufrufe, dann ladet die natürlich ganz schnell.
Habe jetzt Total Cache installiert und glaube jetzt ist die Seite etwas schneller. Bei Google
PageSpeed Insights auf Mobil ist die Seite immer noch nicht grad schnell, weiss nicht ob ich da noch was ändern kann?
 
Zu PHP fällt mir ein, welche Version benutzt du? Es sollte 7.* sein, am besten 7.4.

Wenn du cPanel hast kann man das einstellen. Du kannst dann evtl. auch mal 8 testen (hat bei mir aber nicht funktioniert, ist aber kein Problem, man kann einfach wieder auf 7.4 zurück)

(sehe gerade du benutzt schon PHP 7.4 - gut!)
 
Zuletzt bearbeitet:
Ja, hatte es auf 7.4 zurueckgesetzt. Was meint ihr, ist jetzt nach den installierten Plugins die Seite schneller, bzw. besser?
 
Ist vielleicht Off Topic aber supporten wir hier gerade eine Scam Webseite ? Das Sortiment sieht aus wie einer dieser typischen Fakeshop Seiten die einfach alles anbieten aber nur dein Geld abziehen ?

Und unten "Copyright © 2021 Cheap-Top-Products" ist irgendwie auch nicht sehr vertrauenerweckend.
 
  • Gefällt mir
Reaktionen: Madman1209
Hallo, kannst du mir bitte paar Seiten geben die Vertrauenswürdiger sind? Also nicht die grossen wie Amazon, ebay, etc...
EDIT: habe darum unten die FB Fanpage gelinkt, soll etwas mehr Vertrauen beifügen aber sicherlich ist die Seite noch verbesserungswürdig...
 
Zurück
Oben